Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF over dot1q trunk

I have a 3750 stack running OSPF and exchanginf information another firewall.

I wish to connect a 3650-CG to this stack and run OSPF over a trunk link.

The switches are connected and can ping each other, however, OSPF is not working.  My config is below:

3750:

interface GigabitEthernet1/0/17
description UPLINK TO SW02
switchport trunk encapsulation dot1q
switchport mode trunk
!


router ospf 1
router-id 10.0.0.2
log-adjacency-changes
area 0 authentication message-digest
redistribute connected
network 172.24.5.0 0.0.0.255 area 0
network 192.168.5.0 0.0.0.255 area 0
!


interface Vlan105
ip address 192.168.5.1 255.255.255.0
ip pim dense-mode
ip ospf message-digest-key 1 md5 TEST1
!


3560:

interface GigabitEthernet0/1
description TRUNK TO SW01
switchport trunk encapsulation dot1q
switchport mode trunk
!


router ospf 1
router-id 10.0.0.3
log-adjacency-changes
area 0 authentication message-digest
redistribute connected
!


interface Vlan105
ip address 192.168.5.3 255.255.255.0
ip ospf message-digest-key 1 md5 TEST1
!

If I do a sh ip pro on the 3750 stack, I receive the follwing:

SW01#sh ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 10.0.0.2
  It is an autonomous system boundary router
  Redistributing External Routes from,
    connected
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.24.5.0 0.0.0.255 area 0
    192.168.5.0 0.0.0.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.0.0.1             110      00:49:40
  Distance: (default is 110)


Any help / advice appreciated.

Everyone's tags (5)
2 REPLIES
Green

OSPF over dot1q trunk

Rob,

On the 3560

!
router ospf 1
router-id 10.0.0.3
log-adjacency-changes
area 0 authentication message-digest
redistribute connected
!

There are no subnets in this config
Therefore no interfaces are taking part is OSPF

Re add you config like this:-


!
router ospf 1
router-id 10.0.0.3
log-adjacency-changes
area 0 authentication message-digest
redistribute connected
network 192.168.5.0 0.0.0.255 area 0
!

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
New Member

Hi Acambell,   Got catch.....

Hi Acambell,

   Got catch.....

   I have a strange behavior with OSPF and VRF.

I have a pair of Nexus 7K in vPC, and a pair of 3750 switch stacked. am running a portchannel with vPC at the Nexus End, and Just Portchannel at the 3750.

 I have two vrf, two pass between the two devices, I could see the routing neighbor relationship between 3750 and Nexus, and even i can see the expected routes in the OSPF database table, but not in the OSPF routing table.

 When i investigated it , i found that adv-router is not reachable.. My Ping is properly working between these devices with vrf extension.

  I don't know why am getting such strange behavior can you throw some light on it.

ex: I have shown the configuration of the one of the VRF here..

Nexus 7K:
=========

interface vlan 100
    ip address 192.168.5.2 255.255.255.240
    vrf member CustomerA_vrf
    ip ospf router 1 area 0.0.0.0
!
router ospf 1
  router-id 192.168.5.2
  vrf CustomerA_vrf
    router-id 192.168.5.2
!

Catalyst 3750
=============
interface vlan 100
    ip address 192.168.5.8 255.255.255.240
    vrf member CustomerA_vrf

!
router ospf 1 vrf CustomerA_vrf
 router-id 192.168.5.8
 network 192.168.5.0 0.0.0.15 area 0
 log-adjacency-changes
!

Help appreciated..


Regards,

Arun

 

 

720
Views
0
Helpful
2
Replies