Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF problem on 3750 Metro switches

Hi,

I'm having problems with ospf in the current setup;

2 customer L3 switches (S1 and S2)(using 3750s to simulate)(Running ospf only) dual homed to 2 x 3750 metro switches running ospf and BGP (S3 and S4). These 2 switches connect to another switch that I have setup to simulate a BT BGP peer (S5).

It all runs fine at first. One of the Metros is the preferred route that will have a faster link.

The problem occurs when I power off the preferred gateway metro switch. When it comes back its neighbours can all be seen but it does not learn any ospf routes at all. This happens until the ospf process is cleared and then the ospf routes return. running 12.2-25.SEG3

S1

router ospf 100

router-id 172.29.0.133

log-adjacency-changes

network 172.16.0.0 0.0.0.255 area 0

network 172.16.1.0 0.0.0.255 area 0

network 172.16.2.0 0.0.0.127 area 0

network 172.16.2.240 0.0.0.7 area 0

network 172.16.3.0 0.0.0.255 area 0

network 172.29.0.132 0.0.0.3 area 0

S2

router ospf 100

router-id 172.29.0.137

log-adjacency-changes

network 172.16.0.0 0.0.0.255 area 0

network 172.16.1.0 0.0.0.255 area 0

network 172.16.2.0 0.0.0.127 area 0

network 172.16.2.248 0.0.0.7 area 0

network 172.16.3.0 0.0.0.255 area 0

network 172.29.0.136 0.0.0.3 area 0

S3

router ospf 1

log-adjacency-changes

passive-interface FastEthernet1/0/24

network 172.16.2.240 0.0.0.7 area 0

network 172.16.2.248 0.0.0.7 area 0

network 172.41.1.16 0.0.0.0 area 0

network 172.41.2.60 0.0.0.3 area 0

default-information originate metric 100

!

router bgp 6001

no synchronization

bgp router-id 172.41.2.61

bgp log-neighbor-changes

redistribute ospf 1

neighbor 172.41.2.62 remote-as 2856

neighbor 172.41.2.62 ebgp-multihop 255

neighbor 172.41.2.62 update-source FastEthernet1/0/24

neighbor 172.41.2.62 route-map setMED out

no auto-summary

!

route-map setMED permit 10

set metric 100

!

S4

router ospf 1

log-adjacency-changes

passive-interface FastEthernet1/0/24

network 172.16.2.240 0.0.0.7 area 0

network 172.16.2.248 0.0.0.7 area 0

network 172.41.1.17 0.0.0.0 area 0

network 172.41.2.64 0.0.0.3 area 0

default-information originate metric 200

!

router bgp 6002

no synchronization

bgp router-id 172.41.2.65

bgp log-neighbor-changes

redistribute ospf 1

neighbor 172.41.2.66 remote-as 2856

neighbor 172.41.2.66 ebgp-multihop 255

neighbor 172.41.2.66 update-source FastEthernet1/0/24

neighbor 172.41.2.66 route-map setMED out

no auto-summary

!

route-map setMED permit 10

set metric 200

!

2 REPLIES
New Member

Re: OSPF problem on 3750 Metro switches

Just nailed it down to the redistribution of ospf into BGP.

Once that is removed it works. Just need to figure out how to redistribute correctly.

New Member

Re: OSPF problem on 3750 Metro switches

As an update to this, we got it working with the network x.x.x.x backdoor commands but it seems a bit flaky, requiring the ospf and BGP to be restarted sometimes when we fail a switch and bring it back up.

We then tried the other way redistributing bgp into ospf but ran into more problems.

The best method we have at the moment is altering the distance if the ibgp to higher than the ospf routes with "distance bgp 150 200 200". Definitely NOT recommended by all the documents i've read but it seems more stable and dynamic than the bgp backdoor method.

182
Views
0
Helpful
2
Replies