Cisco Support Community
Community Member

OSPF problem


We are having a problem to establish ospf neig with nortel contivity when using SUP 720, running in native mode IOS#12.2(18)SXF7". No problem in production when using SUP2/MSFC2 IOS#12.1(20)E3. Any change in IOS regarding OSPF ?

Here is some conf and debug:

AC65M40-02#sh ip ospf neig

Neighbor ID Pri State Dead Time Address Interface 1 INIT/DROTHER 00:00:32 142.x.x.2 Vlan159

AC65M40-02#sh ip ospf interface vlan159

Vlan159 is up, line protocol is up

Internet Address 142.x.x.250/24, Area 0

Process ID 1, Router ID 142.x.x.2, Network Type BROADCAST, Cost: 1

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 142.x.x4.2, Interface address 142.x.x.250

No backup designated router on this network

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

oob-resync timeout 40

Hello due in 00:00:04

Supports Link-local Signaling (LLS)

Index 57/57, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 0, maximum is 0

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 1, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)

Message digest authentication enabled

Youngest key id is 1

AC65M40-02#sh run int vlan159

Building configuration...

Current configuration : 286 bytes


interface Vlan159

description WAN TLS

ip address 142.205.xx.255.255.0

no ip redirects

ip pim sparse-mode

ip ospf message-digest-key 1 md5 1 XXXX

standby 205 ip 142.x.x.1

standby 205 priority 255

standby 205 preempt

standby 205 authentication yyyyy


AC65M40-02# sh run


router ospf 1


area 0 authentication message-digest

passive-interface default

no passive-interface Vlan8

no passive-interface Vlan157

no passive-interface Vlan159

no passive-interface Vlan200

no passive-interface Loopback0

no passive-interface Loopback1

network 142.205.xx.0.255.255 area 0

AC65M40-02# debug ip ospf

000385: *Dec 27 10:00:31.437 EST: OSPF: Send with youngest Key 1

000386: *Dec 27 10:00:41.425 EST: OSPF: rcv. v:2 t:1 l:44 rid:

aid: chk:0 aut:2 keyid:1 seq:0x5D1 from Vlan159

000387: *Dec 27 10:00:41.425 EST: OSPF: Rcv hello from area 0 from


000388: *Dec 27 10:00:41.429 EST: OSPF: End of hello processing

000389: *Dec 27 10:00:41.437 EST: OSPF: Send hello to area 0 on Vlan159 from

000390: *Dec 27 10:00:41.437 EST: OSPF: Send with youngest Key 1


Community Member

Re: OSPF problem

Is this the configuration from the Cisco? Can you post config from the Nortel? Have you looked at the authentication?

Re: OSPF problem

Try removing the authentication from the OSPF process and check.


Cisco Employee

Re: OSPF problem

This might be because the Nortel box doesn't support LLS, in which case it should normally simply ignore the option.

Try configuring "no capability lls" under the router ospf process.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
Community Member

Re: OSPF problem

I added the command that hritter suggested and now I can see the Nortel box as OSPF neig.

Is this command will affect other cisco router that I have in the network "I am doing this in the LAB and we don't have other Cisco routers to test this behavior"?

Thanks hritter

Cisco Employee

Re: OSPF problem

LLS is mainly used in support of Cisco OSPF Graceful Restart (GR).

Disabling LLS will have no impact on the other Cisco routers in your network since you are not using OSPF GR in your configuration.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600

Re: OSPF problem

Can you ping the nortel box from the cisco ?


Re: OSPF problem

If you have other routers that need the authentication then you will have to put it back and disable it only for the interface that has the nortel on it or configure the nortel to use md5 keys.


This command will override the global settings on a interface.

Community Member

Re: OSPF problem

The NORTEL's (BAY router) default timers (hello, Dead) are not the same as the Cisco (they were different back in the 90's.. I have not touched a Bay router since they were bought by Nortel). "Debug ip OSPF ADJ" and "Debug IP OSPF Events" should give you an error telling you if and what the differences are.

CreatePlease to create content