Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

OSPF question.

I have the following setup in my environment today (please excuse any invalid network ranges as I changed them to not reflect exact IP's).

router ospf 1

log-adjacency-changes

area 185.224.96.0 range 10.0.64.0 255.255.224.0

area 185.224.96.0 range 185.224.96.0 255.255.240.0

area 185.224.96.0 range 192.168.4.0 255.255.254.0

redistribute static metric 110 subnets

network 10.0.64.0 0.0.31.255 area 185.224.96.0

network 10.1.2.0 0.0.0.31 area 185.224.96.0

network 10.1.34.32 0.0.0.15 area 185.224.96.0

network 10.5.0.0 0.0.1.255 area 185.224.96.0

network 10.5.2.0 0.0.1.255 area 185.224.96.0

network 10.5.4.0 0.0.1.255 area 185.224.96.0

network 10.5.6.0 0.0.1.255 area 185.224.96.0

network 10.5.8.0 0.0.1.255 area 185.224.96.0

network 10.5.10.0 0.0.1.255 area 185.224.96.0

network 10.5.12.0 0.0.1.255 area 185.224.96.0

network 10.5.14.0 0.0.1.255 area 185.224.96.0

network 10.255.17.0 0.0.0.255 area 0

network 185.136.231.32 0.0.0.0 area 185.224.96.0

network 185.136.231.235 0.0.0.0 area 185.224.96.0

network 185.224.4.0 0.0.0.255 area 185.224.96.0

network 185.224.38.64 0.0.0.31 area 185.224.96.0

network 185.224.50.0 0.0.0.15 area 185.224.96.0

network 185.224.55.160 0.0.0.15 area 185.224.96.0

network 185.224.96.0 0.0.15.255 area 185.224.96.0

network 185.224.254.144 0.0.0.7 area 0

network 185.224.254.152 0.0.0.7 area 0

network 185.224.255.145 0.0.0.0 area 185.224.96.0

network 172.16.5.0 0.0.0.31 area 185.224.96.0

network 172.16.11.0 0.0.0.255 area 185.224.96.0

network 192.168.4.0 0.0.1.255 area 185.224.96.0

network 192.168.40.32 0.0.0.7 area 185.224.96.0

network 192.168.40.40 0.0.0.7 area 185.224.96.0

What I want to know is what I might gain or lose with changing my configuration to what follows:

router ospf 1

log-adjacency-changes

area 0 range 10.10.50.0 255.255.255.224

redistribute static metric 110 subnets

network 10.10.50.3 0.0.0.0 area 0

network 10.0.64.0 0.0.31.255 area 10

network 10.1.2.0 0.0.0.31 area 10

network 10.1.34.32 0.0.0.15 area 10

network 10.5.0.0 0.0.1.255 area 10

network 10.5.2.0 0.0.1.255 area 10

network 10.5.4.0 0.0.1.255 area 10

network 10.5.6.0 0.0.1.255 area 10

network 10.5.8.0 0.0.1.255 area 10

network 10.5.10.0 0.0.1.255 area 10

network 10.5.12.0 0.0.1.255 area 10

network 10.5.14.0 0.0.1.255 area 10

network 10.255.17.0 0.0.0.255 area 10

network 185.136.231.32 0.0.0.0 area 10

network 185.136.231.235 0.0.0.0 area 10

network 185.224.4.0 0.0.0.255 area 10

network 185.224.38.64 0.0.0.31 area 10

network 185.224.50.0 0.0.0.15 area 10

network 185.224.55.160 0.0.0.15 area 10

network 185.224.96.0 0.0.15.255 area 10

network 185.224.254.144 0.0.0.7 area 10

network 185.224.254.152 0.0.0.7 area 10

network 185.224.255.145 0.0.0.0 area 10

network 172.16.5.0 0.0.0.31 area 10

network 172.16.11.0 0.0.0.255 area 10

network 192.168.4.0 0.0.1.255 area 10

network 192.168.40.32 0.0.0.7 area 10

network 192.168.40.40 0.0.0.7 area 10

maybe im trying to over simplify this... opinions ?

This is assuming I want to have a new area 0 with new a new interface 10.10.50.3 which would make this device part of area 0.  and all the other networks part of area 10.

2 REPLIES

OSPF question.

Hi john,

it would be easier to read and troubleshoot. Apart from this i would care to change the metric (unless specific reasons) to the static route getting redistributed to avoid confusions and i would care about the limit of devices that are suggested to be present in one single area (area 10).

Definig a router-id (loopback) below the OSPF process might improve stability too.

Alessio

Community Member

OSPF question.

Alessio, thank you for the feedback, Your comments are right on track for what I want to accomplish, easier to read the ospf and troubleshoot. I had forgot to include any loopback but intended to have that listed as you stated.

The redistribut static statement was in place prior to my arrival so I will refresh my understanding on this and make any necessary adjustements.

As to the number of networks listed in area 10, is their a maximum number of networks to define ? i read where its all based on the model of router and processing power and memory.

219
Views
0
Helpful
2
Replies
CreatePlease to create content