Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

OSPF route distribution problem

I am having a area route distribution problem.

Router A

router ospf 1

log-adjacency-changes

auto-cost reference-bandwidth 1000000

area 10 nssa default-information-originate

area 20 nssa default-information-originate metric 5

area 30 nssa default-information-originate metric 5

timers throttle spf 1000 1000 1000

passive-interface default

no passive-interface Vlan100

no passive-interface Port-channel25

no passive-interface Port-channel27

no passive-interface Port-channel28

network 10.200.10.0 0.0.0.7 area 0

network 10.200.10.8 0.0.0.7 area 0

network 10.200.10.16 0.0.0.7 area 10

network 10.200.10.40 0.0.0.7 area 20

network 10.200.10.56 0.0.0.7 area 30

network 10.200.100.0 0.0.0.255 area 0

RouterB

router ospf 1

log-adjacency-changes

auto-cost reference-bandwidth 1000000

area 10 nssa default-information-originate

area 20 nssa default-information-originate

area 30 nssa default-information-originate

timers throttle spf 1000 1000 1000

passive-interface default

no passive-interface Vlan100

no passive-interface Port-channel24

no passive-interface Port-channel26

no passive-interface Port-channel27

network 10.200.10.0 0.0.0.7 area 0

network 10.200.10.8 0.0.0.7 area 0

network 10.200.10.24 0.0.0.7 area 20

network 10.200.10.32 0.0.0.7 area 20

network 10.200.10.48 0.0.0.7 area 30

network 10.200.100.0 0.0.0.255 area 0

Switch A has the following config.

router ospf 1

log-adjacency-changes

auto-cost reference-bandwidth 1000000

area 20 nssa

timers throttle spf 1000 1000 1000

redistribute connected subnets

passive-interface default

no passive-interface Port-channel26

no passive-interface Port-channel27

network 10.200.10.32 0.0.0.7 area 20

network 10.200.10.40 0.0.0.7 area 20

Switch B has the following config.

log-adjacency-changes

auto-cost reference-bandwidth 1000000

area 10 nssa

timers throttle spf 1000 1000 1000

redistribute connected subnets

passive-interface default

no passive-interface Port-channel28

network 10.200.10.16 0.0.0.7 area 10

When I do show route on Switch A, I only see routes for area 0 and not area 10.

When I do show route on Switch B, I only see routes for area 0 and not area 20.

On the routers A & B, I see all routes for everything.

How can I inject or distribute area 10 routes into area 20 from Routers A&B??

Right now everything is pingable because of the default routes are are redistributed from RouterA and RouterB.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: OSPF route distribution problem

You need to remove are 20 nssa from all routers containing that area, not just Switch B.

Also, make sure the command is actually gone. There are times when you have several options within the command, you need to issue the no area 20 nssa twice

5 REPLIES
Hall of Fame Super Bronze

Re: OSPF route distribution problem

You have to configure Area 10 and Area 20 as normal areas, not NSSA.

When you enabled NSSA in an OSPF area no type 3 or 4 summary LSAs are allowed. This means no inter-area routes (IA Routes).

Redistribution is allowed into a NSSA area but a type 5 (external route) is injected as type 7.

You can't redistribute between areas, you can only redistribute between two routing protocols.

I recommend reading the OSPF documentation:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hirp_c/ch15/1chospf.htm

HTH,

__

Edison.

Community Member

Re: OSPF route distribution problem

So I removed the area 20 nssa and I cant create an adjacency for some reason.

Hall of Fame Super Bronze

Re: OSPF route distribution problem

You need to remove are 20 nssa from all routers containing that area, not just Switch B.

Also, make sure the command is actually gone. There are times when you have several options within the command, you need to issue the no area 20 nssa twice

Re: OSPF route distribution problem

Hi Edison,

You're right, removing nssa's will probably cut through the problem.

But: the recommended by you OSPF documentation states that nssa's will retain all the characteristics of stub areas, except that they will accept ASBR's and type-7 LSA's.

The document does not state that type-3 or type-4 LSA's are not allowed in nssa's. So interarea routes (O IA) should appear in the routing table.

I tried a living configuration and the interarea routes did appear for me in the routing table of nssa routers.

If any documentation states the contrary, it should not be true.

Why the expected routes do not appear in the routing table in the current nssa config? Well, I think there may be some causes that would stop propagation of routes across the area or electing them into the routing table.

We would need to see the complete running-configs to have ample information.

Best regards:

Istvan

Hall of Fame Super Bronze

Re: OSPF route distribution problem

Istvan,

You are correct, LSA Type 3 & 4 would be blocked with the no-summary option within the NSSA command.

Thanks for your contribution to this thread.

Regards,

421
Views
3
Helpful
5
Replies
CreatePlease to create content