Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF route distribution with summary on upstream router

Having some issues with a simular setup:

4 routers connected in series:

RTR A >> RTR B >> RTR C >> RTR D

How do I only show the summary in RTR A routing table?

------------

RTR A

fastethernet 0/1

description link to RTR B

ip address 10.1.1.1 255.255.255.252

router ospf 1

network 10.1.1.0 0.0.0.255 area 0

>>>>>>Routing table contains summary address:

O IA 10.250.0.0/23 VIA 10.1.1.2

>>>>>>As well as the individual advertisments:

O E2 10.250.0.0/24 VIA 10.1.1.2

O E2 10.250.1.0/24 VIA 10.1.1.2

------------

RTR B

fastethernet 0/1

description link to RTR A

ip address 10.1.1.2 255.255.255.252

fastEthernet 0/2

description Link to RTR B

ip address 10.2.2.1 255.255.255.252

router ospf 1

network 10.1.1.0 0.0.0.255 area 0

network 10.2.2.0 0.0.0.255 area 1

network 10.250.0.0 255.255.252.0 area 1 <<<<<<<<<<< If I add this the summary address apears as shown in RTR A table.

area 1 range 10.250.0.0 255.255.254.0

------------

RTR C

loopback 1

ip address 10.250.1.1 255.255.255.0

fastEthernet 0/1

description Link to RTR A

ip address 10.2.2.2 255.255.255.252

fastEthernet 0/2

description Link to RTR B

ip address 10.2.2.5 255.255.255.252

router ospf 1

redistribute connected subnets

network 10.2.2.0 0.0.0.255 area 1

------------

RTR D

loopback 1

ip address 10.250.1.1 255.255.255.0

fastEthernet 0/1

description Link to RTR B

ip address 10.2.2.6 255.255.255.252

router ospf 1

redistribute connected subnets

network 10.2.2.0 0.0.0.255 area 1

1 ACCEPTED SOLUTION

Accepted Solutions

Re: OSPF route distribution with summary on upstream router

Hi,

From OSPF's perspective, since D and C are redistributing routes, they are treated as external routes (those connected segments). So to configure summarisation use summary-address command under ospf process on both D and C. This will cause both A and B to see the summarised routes. Please note, not correctly summarising on C and D would lead to ambiguity because Router B will not be able to make the difference (because the first two octets are the same for the connected segment on C and D)

The best solution is to use the network command and make those interfaces on which you dont want to run ospf passive.

If you would like only A to see summarised routes, you must move it into another area and make it a stub area(no type 5 LSAs). By doing so, it will no longer see those external routes at all rather have default route to the ABR for all external routes.

HTH

Lejoe

6 REPLIES

Re: OSPF route distribution with summary on upstream router

Hi Daniel,

This is probably because those routes are external routes, in which case summary-address command must be used. Area range commands are used to summarise I.A routes not external routes.

Instead of redistributing connected segments on C and D, use the network command in ospf process on C and D. Then use the area 1 range command on router B, ofcourse you'll have to remove the line

network 10.250.0.0 255.255.252.0 area

HTH

Lejoe

New Member

Re: OSPF route distribution with summary on upstream router

I appreciate your reply, I have tried that and it works, I would prefer not to run ospf on c and d 10.250.x.0 interfaces.

Is there anyway to get around that?

Thanks -

Re: OSPF route distribution with summary on upstream router

Hi,

From OSPF's perspective, since D and C are redistributing routes, they are treated as external routes (those connected segments). So to configure summarisation use summary-address command under ospf process on both D and C. This will cause both A and B to see the summarised routes. Please note, not correctly summarising on C and D would lead to ambiguity because Router B will not be able to make the difference (because the first two octets are the same for the connected segment on C and D)

The best solution is to use the network command and make those interfaces on which you dont want to run ospf passive.

If you would like only A to see summarised routes, you must move it into another area and make it a stub area(no type 5 LSAs). By doing so, it will no longer see those external routes at all rather have default route to the ABR for all external routes.

HTH

Lejoe

New Member

Re: OSPF route distribution with summary on upstream router

If you dont want to run ospf on C & D, then why dont you create a static route on Router B and "redistribute static subnets" into ospf. This will make Router B an ASBR which will allow you to summarize if needed, meaning if you use multiple static routes.

Another option...

Ralph

www.techsnips.com

New Member

Re: OSPF route distribution with summary on upstream router

Thanks for the option, because of the amount of static routes I would have I would rather have OSPF handle them.

Thanks,

New Member

Re: OSPF route distribution with summary on upstream router

Yes, making the interfaces passive fixed my issue.

Thanks!

155
Views
4
Helpful
6
Replies