Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ospf wildcard mask

i have 2 core routers that is connected via MPLS tunnelling.

I setup a new vlan in one of the layer 3 switch at router A,

10.200.100.0/24, there is one existing vlan at 10.200.90.0/24.

router A ->  router B          

under the ospf routing, there is this area 0 to exchange the LAN segments through the ospf area 1.

do I have to change the wildcard mask in order for the 2nd vlan to go theough ?

router ospf 1

log-adjacency-changes

area 0 authentication message-digest

area 1 authentication message-digest

area 1 range 10.200.0.0 255.255.128.0

area 1 range 10.205.1.0 255.255.255.192

routerA#sh ip route | i 10.200.100

S       10.200.100.0/24 [1/0] via 10.200.90.4

routerA#sh ip route | i 10.200.90

C       10.200.90.0/24 is directly connected, GigabitEthernet0/0

S       10.200.100.0/24 [1/0] via 10.200.90.4

routerB1#sh ip route | i 10.200.100

routerB#sh ip route | i 10.200.90

O       10.200.90.0/24 [19/1001] via 10.205.5.254, 1d00h, Tunnel1090

4 REPLIES
Silver

ospf wildcard mask

Your configuration looks a bit strange. You have no network statements. Do you have OSPF enabled on the interface instead with the ip ospf interface command?

Can you post show ip ospf interface brief?

It looks like you have a static route for 10.200.100.0 and then area statement under OSPF. OSPF will not summarize route unless it is in the OSPF RIB.

To just advertise the network you should put a network statement or enable OSPF on the interface with the ip ospf area command.

Daniel Dib
CCIE #37149

Please rate helpful posts.

Daniel Dib CCIE #37149 Please rate helpful posts.
New Member

Re: ospf wildcard mask

routerA#sh ip ospf interface brief

Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C

Tu1090       1     1               10.205.5.254/30    1000  P2P   1/1

Tu15         1     1               10.205.2.2/30      50    DOWN  0/0

Tu0          1     1               10.205.0.10/24     50    DOWN  0/0

Di0          1     1               10.205.2.34/30     12000 DOWN  0/0

Gi0/0        1     1               10.200.90.1/24     1     DR    0/0

GVPlazaHQ#

routerB#sh ip ospf interface brief

Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C

Gi0/0        1     0               10.199.99.11/24    1     DR    0/0

Tu1011       1     1               10.205.5.41/30     1000  P2P   1/1

Tu1090       1     1               10.205.5.253/30    1000  P2P   1/1

Tu1010       1     1               10.205.5.37/30     1000  P2P   1/1

Tu1009       1     1               10.205.5.33/30     1000  P2P   1/1

Tu1008       1     1               10.205.5.29/30     1000  P2P   1/1

Tu1007       1     1               10.205.5.25/30     1000  P2P   1/1

Tu1006       1     1               10.205.5.21/30     1000  P2P   1/1

Tu1005       1     1               10.205.5.17/30     1000  P2P   1/1

Tu1004       1     1               10.205.5.13/30     1000  P2P   1/1

Tu1003       1     1               10.205.5.9/30      1000  P2P   1/1

Tu1002       1     1               10.205.5.5/30      1000  P2P   1/1

Tu1001       1     1               10.205.5.1/30      1000  P2P   1/1

Tu0          1     1               10.205.0.1/24      25    DR    1/1

interface Tunnel1090

description Tunnel to routerB

ip address 10.205.5.254 255.255.255.252

ip mtu 1500

ip virtual-reassembly

ip tcp adjust-mss 1436

ip ospf message-digest-key 1 md5 7 070C285F4D064E5240

ip ospf priority 0

keepalive 10 3

tunnel source 172.30.90.1

tunnel destination 172.30.100.1

interface Tunnel1090

description Tunnel to routerA

ip address 10.205.5.253 255.255.255.252

ip mtu 1500

ip virtual-reassembly

ip tcp adjust-mss 1436

ip ospf message-digest-key 1 md5 7 070C285F4D064E5240

keepalive 10 3

tunnel source 172.30.100.1

tunnel destination 172.30.90.1

New Member

ospf wildcard mask

ospf is enable on the core router at 10.200.90.1

router ospf 1

log-adjacency-changes

area 1 authentication message-digest

passive-interface GigabitEthernet0/0

network 10.0.0.0 0.255.255.255 area 1

distance 19

at router 2 (10.199.99.1)

router ospf 1

log-adjacency-changes

area 0 authentication message-digest

area 1 authentication message-digest

area 1 range 10.200.0.0 255.255.128.0

area 1 range 10.205.1.0 255.255.255.192

redistribute static metric 500 metric-type 1 subnets route-map filterstatic

network 10.199.99.0 0.0.0.255 area 0

network 10.205.0.0 0.0.0.255 area 1

network 10.205.2.0 0.0.0.255 area 1

network 10.205.3.0 0.0.0.255 area 1

network 10.205.4.0 0.0.0.255 area 1

network 10.205.5.0 0.0.0.255 area 1

default-information originate

distance 19

how do i change the ospf to enable 10.200.100.0/24 instead of static route

Hall of Fame Super Blue

ospf wildcard mask

It's not clear what you are asking.

Is the new network 10.200.100.0/24 a common network between router 1 and router 2 ie. both routers have an interface in that network.

Or does the network only connect to the one router ? If so which one.

How is this related to the static statement ?

Jon

217
Views
0
Helpful
4
Replies