Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Packet drops on SVI interface

Hi.

We are using a Cat 3750-12S as for routing. I am seing packet drops on input. The VLAN has a call manager and MGCP gateway, and consequently we are getting problems with voice quality. Can someone please point me to where start looking? Could it me a physical problem, or a software issue? Where can I start looking with a protocol analyser, and what should I look for.

The switch is not CPU loaded or memory loaded, and other interfaces are OK.

Thanks

Matthew

Here is the relevant part of the show interface command.

Vlan24 is up, line protocol is up

Hardware is EtherSVI, address is 0022.9053.14cc (bia 0022.9053.14cc)

Internet address is 139.86.24.2/21

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not supported

ARP type: ARPA, ARP Timeout 00:05:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/25036/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 4000 bits/sec, 4 packets/sec

16177712 packets input, 1173810655 bytes, 0 no buffer

Received 0 broadcasts (1570117 IP multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

21597336 packets output, 1998430067 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

4 REPLIES
Blue

Re: Packet drops on SVI interface

5 minute input rate 0 bits/sec, 0 packets/sec

Why is that? No input?

Where are you seeing input drops?

New Member

Re: Packet drops on SVI interface

Running CEF, and so often the SVIs sho no or very small packet rates. These drops are on a SVI interface. There don't appear to be any drops on the physical interfaces of the 3750.

Matthew

Super Bronze

Re: Packet drops on SVI interface

You note two issues, a voice quality problem and VLAN input queue drops. I would tend to think the two might be related, but is the voice quality the important issue? Reason I ask, if voice quality is the primary concern, it might be possible to correct it and still see input queue drops.

According to generic troubleshooting (for routers), i.e. http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a0080094791.shtml#topic2, an input queue can fill when the device's forwarding rate can't keep up with the input rate. Unsure how much of this applies to a 3750, but I imagine it might not take much software switched traffic to slow input queue processing. Beyond Cisco TechNotes or contacting TAC, unable to suggest much more on addressing the 3750 device's issue causing the input queue to fill.

As an alternative, to finding the solution for the input queue filling, you might be able to insure your voice quality by trying some of the following.

You might insure you're using the optimal SDM template.

You might try changing the size of the input queue, both up and down. Down will likely increase drops but reduce latency, up will likely decrease drops but increase latency. Depending which is causing the voice issue, voice quality might improve.

You might insure voice packets (both payload and signally) are processed in expedited queues, both egress and ingress queues.

You might, if possible, "shape" the devices feeding your VLAN ingress ports (if not already doing QoS on those to insure expedited queuing for voice, do so [if supported] especially if you "shape").

Blue

Re: Packet drops on SVI interface

Hi:

Besides what Joseph has, it can also be the case that the input queue is filling up because cef forwarding isn't being implemented, and instead process switching is occuring. I know you said you have cef enabled, but could it be thta some of the traffic you think is being forwarded by cef is actually being process switched?

The longer time it will take to process switch will force packets to occupy the buffers for an inordinate amount of time, especially if you have hosts on that vlan that are blasting out the traffic.

502
Views
0
Helpful
4
Replies
CreatePlease to create content