Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PAGP channel failing - error disable

I am trying to create a pagp channel between a 6509 & 4507 switch. The ports on the 4507 keep error disabling with the following error:

%PM-4-ERR_DISABLE: channel-misconfig error detected on Gi1/6, putting Gi1/6 in err-disable state

Catalyst 4507 Config

interface Port-channel2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet1/6

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,408-410,413,430,436,437,446,452,453

switchport mode trunk

udld port

channel-protocol pagp

channel-group 2 mode desirable

Catlayst 6509 config

Channel

Module Protocol

------- --------

1 PAGP

2 PAGP

3 PAGP

4 LACP

5 PAGP

7 PAGP

8 PAGP

set port channel 2/10-11 2

Ports on both switches are set to desirable non silent.

Any ideas why the ports keep shutting down.

Thanks.

4 REPLIES
Purple

Re: PAGP channel failing - error disable

Make sure G1/6 matches exactly whatever the config is on your other port for the etherchannel , this includes things like speed and duplex on the ports . I don't see where on g1/6 it says non-silent like you are saying they are , I think it is silent by default unless you specify non-silent. Should read channel-group 2 mode desirable non-silent" .

New Member

Re: PAGP channel failing - error disable

Hi thanks for your reply.

I now have a slightly different problem. I have two port channels and one port in each channel is showing connected and the other is suspended. I get the following error messages

011198: Oct 12 15:59:09: FEC: pagp_switch_set_gcchange: GC change req Gi1/5

011199: Oct 12 15:59:09: %EC-5-DONTBNDL: Gi1/5 suspended: incompatible partner port with

GigabitEthernet1/6

011200: Oct 12 15:59:09: FEC: pagp_switch_set_gcchange: GC change req Gi1/4

011201: Oct 12 15:59:09: %EC-5-DONTBNDL: Gi1/4 suspended: incompatible partner port with GigabitEthernet1/3

011202: Oct 12 15:59:09: FEC: pagp_switch_set_gcchange: GC change req Gi1/5

My port configs are below and I cannot see anything obvious that differs between the ports.

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface TenGigabitEthernet1/1

!

interface TenGigabitEthernet1/2

!

interface GigabitEthernet1/3

switchport trunk encapsulation dot1q

switchport mode trunk

udld port

channel-protocol pagp

channel-group 1 mode desirable non-silent

!

interface GigabitEthernet1/4

switchport trunk encapsulation dot1q

switchport mode trunk

udld port

channel-protocol pagp

channel-group 1 mode desirable non-silent

!

interface GigabitEthernet1/5

switchport trunk encapsulation dot1q

switchport mode trunk

udld port

channel-protocol pagp

channel-group 2 mode desirable non-silent

!

interface GigabitEthernet1/6

switchport trunk encapsulation dot1q

switchport mode trunk

udld port

channel-protocol pagp

channel-group 2 mode desirable non-silent

!

Have you any further ideas.

Thanks in advance.

Purple

Re: PAGP channel failing - error disable

I would check your 6509 cards , we ran into something like this awhile ago and it ended up being some restriction on the cards on what you etherchannel due to bandwidth restrictions on the card itself I believe . I think the problem was with either a 6348 or a 6548 card. Config wise normally what you have looks right . Maybe you can see something from this doc, http://cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/31sg/configuration/guide/channel.html#wp1020420

Also use the show port capabilities on the 6500 ports to see if you can bundle the ones you want .

New Member

Re: PAGP channel failing - error disable

It is a 6416 fibre gbic module that is being used on the 6509.

The show port capabilites command shows that it supports channeling. It is ports 2/10 & 2/11 on each of the 6509 switches that I am connecting to.

The following is taken from the 6509 config.

set port channel 2/9-12 38

I am using the set port channel 2/10-11 mode desirable command to configure the channel.

Oddly when I do a show port channel command ports 2/10 & 2/11 do not show up as channel (other channels to 6509 & VMWare servers are shown in this list). I expected to see them there. A show port command shows both ports as connected and trunking on the 6509 and one connected & one suspended on the 4507.

Any ideas what I am missing?

Thanks.

599
Views
4
Helpful
4
Replies