Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

PAgP timeout too long

Hi,

I have two site connected with two links with Aironet Bridges 1300 for load balance and fault tolerance.

They are configured as following:

1 pair -> Site A root (192.168.230.2/28) ----- Channel 1 ---- nonroot (192.168.230.3/28) Site B

1 pair  -> Site A nonroot (192.168.230.4/28) ---- Channel 6 ---- root (192.168.230.5/28) Site B

The default-gateway is a 65XX (Core - Distribution) with Supervisor 720, using a SVI interface (Vlan 900) with IP address 192.168.230.1/28.

The bridges are connected to a Access Switch WS-C2960-TC-L, where I had a FastEtherchannel (port-channel 2) with interfaces F0/9 and F0/10 with the follow configuration:

Interface range f0/9 - 10

switchport mode access

switchport access vlan 900

spanning-tree portfast

channel-group 2 mode desirable

Interfaces port-channel 2

switchport mode access

switchport access vlan 900

spanning-tree portfast

And the other site had similar configuration.

The port-channel is up and operational but the time to react to conectivity failures are too long, I have a PC doing extended ping to various destinations and the timeout are close to 30 sec. The are to much time for everything type of traffic TCP or UDP. The link will be use for traffic of backup files, may be using NFS over TCP or UDP.

Can everybody help about that?????

I need to use something tool to acelerate this time? I read about UDLD aggresive on some forum?

Thanks,

David Salazar

2 REPLIES
Community Member

Re: PAgP timeout too long

I found the following information on Cisco Website.

http://ciscosystems.com/en/US/products/hw/switches/ps5304/products_configuration_guide_chapter09186a008007f33a.html

The Cisco IOS software automatically removes a Fast Ethernet or Gigabit Ethernet interface from the EtherChannel if the interface goes down, and the software automatically adds the interface to the EtherChannel when the interface is back up.

Currently, EtherChannel relies on keepalive signals to detect whether the line protocol is up or down. Keepalive signals are enabled by default on the Fast Ethernet and Gigabit Ethernet interfaces. If the line protocol on the interface goes down beca...

However, if the line protocol remains up because keepalive signals are disabled on the Fast Ethernet or Gigabit Ethernet interface, the EtherChannel cannot detect this link failure (other than a cable disconnect) and does not remove the interface fro...

Example of verification:

West_Cat8540# show pagp 1 internal 
Flags: S - Device is sending Slow hello.  C - Device is in Consistent state.
        A - Device is in Auto mode.
Timers:H - Hello timer is running.        Q - Quit timer is running.
        S - Switching timer is running.    I - Interface timer is running.

Channel group 1
                                Hello    Partner  PAgP     Learning  Group
Port      Flags State   Timers  Interval Count   Priority   Method  Ifindex
 
Gi3/0/0   SC    U6/S7   H       30s      1        128        Any      1

I will probe that tomorrow. But I think that is the option to reduce the time.

Thanks.

David Salazar

Community Member

Re: PAgP timeout too long

Hello,

I tried reducing the keepalive time, but It does not work.

Follow the configuration:

NSR-SW-IDF12-1#sh run int port-channel 2
Building configuration...

Current configuration : 172 bytes
!
interface Port-channel2
description +++ Enlace Wireless REC - DIT +++
switchport access vlan 900
switchport mode access
load-interval 30
spanning-tree portfast
end

NSR-SW-IDF12-1#
NSR-SW-IDF12-1#sh run int f0/9
Building configuration...

Current configuration : 230 bytes
!
interface FastEthernet0/9
switchport access vlan 900
switchport mode access
logging event bundle-status
logging event spanning-tree
load-interval 30
keepalive 1
channel-group 2 mode desirable
spanning-tree portfast
end

NSR-SW-IDF12-1#
NSR-SW-IDF12-1#sh run int f0/10
Building configuration...

Current configuration : 231 bytes
!
interface FastEthernet0/10
switchport access vlan 900
switchport mode access
logging event bundle-status
logging event spanning-tree
load-interval 30
keepalive 1
channel-group 2 mode desirable
spanning-tree portfast
end

NSR-SW-IDF12-1#sh pagp inter
NSR-SW-IDF12-1#sh pagp internal
Flags:  S - Device is sending Slow hello.  C - Device is in Consistent state.
        A - Device is in Auto mode.        d - PAgP is down
Timers: H - Hello timer is running.        Q - Quit timer is running.
        S - Switching timer is running.    I - Interface timer is running.

Channel group 2
                                Hello    Partner  PAgP     Learning  Group
Port      Flags State   Timers  Interval Count   Priority   Method  Ifindex
Fa0/9     SC    U6/S7   H       30s      1        128        Any      5002
Fa0/10    SC    U6/S7   H       30s      1        128        Any      5002
NSR-SW-IDF12-1#
NSR-SW-IDF12-1#

As you can see the Hello Timer is 30Sec.

The following web site speak about that:

http://www.ieee802.org/3/trunk_study/april98/finn_042898.pdf

Can be that the timers can not be changed. Can anybody help me  about that?

1316
Views
0
Helpful
2
Replies
CreatePlease to create content