Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PAT configuration

Hi,

I have PAT set up successfully on 6506 chassis - My outside address range is 78.24.112.114 255.255.255.240

Relevant parts of the config below:

interface Vlan10

ip address 10.0.0.1 255.255.255.0

ip nat inside

!

interface Vlan11

ip address 10.0.1.1 255.255.255.0

ip nat inside

!

interface Vlan12

ip address 10.0.2.1 255.255.255.0

ip nat inside

!

interface Vlan13

ip address 10.0.3.1 255.255.255.0

ip nat inside

!

interface Vlan14

ip address 10.0.4.1 255.255.255.0

ip nat inside

!

interface Vlan15

ip address 10.0.5.1 255.255.255.0

ip nat inside

!

interface GigabitEthernet3/48

ip address 78.24.112.114 255.255.255.240

description WAN connection

ip nat outside

speed 100

duplex full

!

ip nat inside source list 7 interface GigabitEthernet3/48 overload

!

ip route 0.0.0.0 0.0.0.0 78.24.112.113

!

access-list 7 permit 10.0.0.0 0.0.7.255

This works fine but of course is only using the one IP address 78.24.112.114.

Can anyone advise how I can utilize the other outside addresses available or is this not really necessary?

I've browsed through loads of Cisco docs but can't seem to find the answer to this - any help much appreciated!

Everyone's tags (2)
2 REPLIES
Hall of Fame Super Silver

Re: PAT configuration

Hello David,

in order to use all the public IP addresses for NAT you need to define a NAT pool

ip nat pool PUBLIC prefix 28

and to change the ip nat inside source command to reference the pool with pool PUBLIC instead of the WAN interface

However, the real behaviour may be that of using a single IP address also with the pool with overload (PAT) set

see

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e77.shtml

Hope to help

Giuseppe

New Member

Re: PAT configuration

Thanks Guiseppe,

I see that a NAT pool can be used in both non overload and overload setups.

In a non overload setup I assume that this means that each of my outside addresses (78.24.112.112/28) can be translated to an internal address.

My question really is that in an overload configuration on the Cisco documentation only one address is used : eg

ip nat pool ovrld 172.16.10.1 172.16.10.1 prefix 24

Is there a way to use the other outside addresses or does overloading always use just the one address?

Many thanks

David

223
Views
5
Helpful
2
Replies