Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Pating not working on cisco 6509 switch

HI

i have configured cisco 6509 to do pating and its not working.Static nat is perfectly working fine below is the config

int vlan 70

ip nat inside

int vlan 179

ip nat outside

ip nat inside source list 10 pool nat_pool overloaded

ip nat nat pool nat_pool 1.1.1.1 1.1.1.1 netmask 255.255.255.0

ip access-list standard 10

permit 10.10.10.0 0.0.0.255

kindly advice

6 REPLIES

Pating not working on cisco 6509 switch

ip nat inside source list 10 pool nat_pool overloaded

ip nat nat pool nat_pool 1.1.1.1 1.1.1.1 netmask 255.255.255.0

ip access-list standard 10

permit 10.10.10.0 0.0.0.255

kindly advice

Are you sure your syntax is really as above?

PAT works best when specifying an interface instead of a pool. Please try to use:

ip nat inside source list 10 interface vlan 179 overload as in:

http://www.cisco.com/en/US/tech/tk583/tk372/technologies_configuration_example09186a008009448f.shtml

regards,

Leo


Purple

Pating not working on cisco 6509 switch

Hi Leo,

just a quick note to say that when specifying the interface in NAT overload the overload keyword is automatically added by the IOS in the configuration so there's no need to specify it.

Regards.

Alain

Don't forget to rate helpful posts.

Re: Pating not working on cisco 6509 switch

Yes, I know that but I was triggered by overloaded instead of overload and ip nat nat pool nat_pool where, IMHO, there is a keyword too many. This output was not gathered from the CLI, probably just quickly typed without checking.

Pleae draw your own conclusions.

Leo

Purple

Pating not working on cisco 6509 switch

Hi Leo,

No harm intended    this was just a remark for the OP but as you had proposed the statement that's why I answered you.

I draw no conclusions different from you.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Pating not working on cisco 6509 switch

Hi

Thanks to all for replying and sorry about spelling mistake as it was typed in urgency.

I use interface also but not working.It may be a bug on IOS

Re: Pating not working on cisco 6509 switch

Perhaps if you can share the output of sh ver and sh module  with us, we can say anything about that.

regards,

Leo

523
Views
0
Helpful
6
Replies
CreatePlease login to create content