Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PBR help needed

What would the pbr policy be using 6506 switch

I need to create a pbr on an interface vlan that checks this:

If traffic is destined for 0.0.0.0 then set the next hop to router A, else continue as normal?

  • LAN Switching and Routing
10 REPLIES
Hall of Fame Super Blue

Re: PBR help needed

Hi

Are you sure that this is the address you want to route to because you shouldn't get packets with this as a destination address.

Jon

Hall of Fame Super Bronze

Re: PBR help needed

You are looking for the set ip default next-hop instead of the set ip next-hop.

The set ip default next-hop will examine the routing table first and if destination address isn't there, it will use the PBR for the next hop while the set ip next-hop will use the PBR first and routing table second.

HTH,

__

Edison.

New Member

Re: PBR help needed

Thanks but what if I already have a default route in the routing table that already points to for example 192.168.2.1 and I want the default route changed specifically for hosts on vlan 200 to 192.168.3.1.

All other vlans, 100 and 300 will use the default route of 192.168.1.1

Any ideas? And keep pbr routing in hardware and not in software?

Hall of Fame Super Bronze

Re: PBR help needed

It will use the PBR for default route that matches the IP within the route-map.

ip default next-hop is done in hardware on the Cat6k.

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SXF/native/configuration/guide/intro.html#wp1031657

New Member

Re: PBR help needed

I'm still kind of confused why it would not use the default route thats in the routing table.

The definition for this is as follows:

default next-hop: Sets next hop to which to route the packet if there is no explicit route for this destination.

If I create this:

Routing table

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

O 192.168.1.0/29 [110/2000] via 192.168.1.1, 1d01h, Port-channel18

O 192.168.3.0/29 [110/2000] via 192.168.3.1, 1d01h, Port-channel28

C 192.168.2.0/24 is directly connected, Vlan200

C 192.168.4.0/24 is directly connected, Vlan400

S* 0.0.0.0/0 [1/0] via 192.168.1.1, 1d01h, Port-channel18

access-list 1 permit 192.168.2.0 255.255.255.0

interface vlan 200

ip address 192.168.2.1 255.255.255.0

ip policy route-map new_route

route-map new_route permit 10

match ip address 1

set ip default next-hop 192.168.3.1

If the route map gets processed for a packet with source address 192.168.2.25 and destination of 66.66.66.66, your saying that it should ignore the static route of 192.168.1.1 and proceed to 192.168.3.1 ???

Bronze

Re: PBR help needed

i think here ur access-list does not match the destination in this example..make it to match ur destination 66.66.66.66,then it would take ur pbr towards the next-hop 192.168.3.1

try out this 4 more understanding..

http://cisco.com/en/US/tech/tk364/technologies_configuration_example09186a00801f3b54.shtml#caseone

New Member

Re: PBR help needed

I read that article but am confused how this access list would look in my situation?

Are extended access lists allowed in route maps?

Looking at my last post, how can I make the pbr work so that the packet get forwarded to 192.168.3.1 instead of 192.168.1.1 ??

Bronze

Re: PBR help needed

i am not sure if deny works with pbr ,but 4rm my logic..

access-list 100 permit any 192.168.0.0 0.0.0.255

access-list 100 deny any 192.168.0.0 0.0.3.255

access-list 100 deny any 192.168.4.0 0.0.0.0

access-list 100 permit any any

(( as u have entry in routing table 4 192.168.1.0-192.168.4.0 and rest is consideras default here))

apply this to ur pbr..

New Member

Re: PBR help needed

I will try this but dont want to mess up a production network :(

197
Views
0
Helpful
10
Replies
This widget could not be displayed.