Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PC behind switch cannot communicate with anything?

R3-R2-R1-S1-S3-PC

 

PC dhcp request failed, everything else pings each other and dont know that is wrong between the pc and the switch (fa18),any thoughts? There is a PC attached to S1 and there are no issues with that one. PC that doesnt communicate is on vlan 31.

S3#show run
Building configuration...

Current configuration : 2175 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname S3
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport mode access
 shutdown
!
interface FastEthernet0/2
 switchport mode access
 shutdown
!
interface FastEthernet0/3
 switchport trunk allowed vlan 99
 switchport mode trunk
!
interface FastEthernet0/4
 switchport mode access
 shutdown
!
interface FastEthernet0/5
 switchport mode access
 shutdown
!
interface FastEthernet0/6
 switchport mode access
 shutdown
!
interface FastEthernet0/7
 switchport mode access
 shutdown
!
interface FastEthernet0/8
 switchport mode access
 shutdown
!
interface FastEthernet0/9
 switchport mode access
 shutdown
!
interface FastEthernet0/10
 switchport mode access
 shutdown
!
interface FastEthernet0/11
 switchport mode access
 shutdown
!
interface FastEthernet0/12
 switchport mode access
 shutdown
!
interface FastEthernet0/13
 switchport mode access
 shutdown
!
interface FastEthernet0/14
 switchport mode access
 shutdown
!
interface FastEthernet0/15
 switchport mode access
 shutdown
!
interface FastEthernet0/16
 switchport mode access
 shutdown
!
interface FastEthernet0/17
 switchport mode access
 shutdown
!
interface FastEthernet0/18
 switchport access vlan 33
 switchport mode access
!
interface FastEthernet0/19
 switchport mode access
 shutdown
!
interface FastEthernet0/20
 switchport mode access
 shutdown
!
interface FastEthernet0/21
 switchport mode access
 shutdown
!
interface FastEthernet0/22
 switchport mode access
 shutdown
!
interface FastEthernet0/23
 switchport mode access
 shutdown

 

1 ACCEPTED SOLUTION

Accepted Solutions

Did you set the same on S1 as

Did you set the same on S1 as well (Trunk port to S3)? What is S1 config looks like?

 

5 REPLIES

interface FastEthernet0/3

interface FastEthernet0/3
 switchport trunk allowed vlan 99 
 switchport mode trunk

 

Trunkport allowing only Vlan 99. Make sure it allows vlan 33 as well.

 

Thx

MS

 

New Member

interface fa0/3 should 33, &

interface fa0/3 should 33, & 99? Its still saying dhcp request failed.

Did you set the same on S1 as

Did you set the same on S1 as well (Trunk port to S3)? What is S1 config looks like?

 

New Member

S1#show runBuilding

S1#show run
Building configuration...

Current configuration : 2175 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname S1
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport mode access
 shutdown
!
interface FastEthernet0/2
 switchport mode access
 shutdown
!
interface FastEthernet0/3
 switchport trunk allowed vlan 99
 switchport mode trunk
!
interface FastEthernet0/4
 switchport trunk allowed vlan 1-30,32,34-98,100-1001
 switchport mode access
 shutdown
!
interface FastEthernet0/5
 switchport mode trunk
!
interface FastEthernet0/6
 switchport access vlan 31
 switchport mode access
!
interface FastEthernet0/7
 switchport mode access
 shutdown
!
interface FastEthernet0/8
 switchport mode access
 shutdown
!
interface FastEthernet0/9
 switchport mode access
 shutdown
!
interface FastEthernet0/10
 switchport mode access
 shutdown
!
interface FastEthernet0/11
 switchport mode access
 shutdown
!
interface FastEthernet0/12
 switchport mode access
 shutdown
!
interface FastEthernet0/13
 switchport mode access
 shutdown
!
interface FastEthernet0/14
 switchport mode access
 shutdown
!
interface FastEthernet0/15
 switchport mode access
 shutdown
!
interface FastEthernet0/16
 switchport mode access
 shutdown
!
interface FastEthernet0/17
 switchport mode access
 shutdown
!
interface FastEthernet0/18
 switchport mode access
 shutdown
!
interface FastEthernet0/19
 switchport mode access
 shutdown
!
interface FastEthernet0/20
 switchport mode access
 shutdown
!
interface FastEthernet0/21
 switchport mode access
 shutdown
!
interface FastEthernet0/22
 switchport mode access
 shutdown
!
interface FastEthernet0/23
 switchport mode access
 shutdown
!
interface FastEthernet0/24
 switchport mode access
 shutdown
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan99
 ip address 192.168.99.2 255.255.255.0
!
ip default-gateway 192.168.99.1
!
banner motd ^CAuth use only^C
!
line con 0
 password 7 0822455D0A16
 login
!
line vty 0 4
 password 7 0822455D0A16
 login
line vty 5 15
 login
!
!
end

New Member

thank you thats what it was!

thank you thats what it was!

49
Views
0
Helpful
5
Replies
CreatePlease login to create content