Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

pc cant access server across two routers (pic is attached)

hey guys,

I have a PC that needs to access a server across two routers. (NO NATTING IS INVOLVED)

how can i make this happen?

router0 is 10.10.35.1 255.255.0.0

NOTE, the routers CAN ping each other

router 1 is 192.168.3.1 255.255.255.0

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: pc cant access server across two routers (pic is attached)

You removed the previous network commands under EIGRP.

On Router 0 you need:

router eigrp 100

network 192.168.2.0

network 10.10.35.0 0.0.0.255

no auto-summary

On Router 1 you need:

router eigrp 100

network 192.168.2.0

network 192.168.3.0

no auto-summary

11 REPLIES
Hall of Fame Super Bronze

Re: pc cant access server across two routers (pic is attached)

Configure the server's default gateway to be Router's 0 LAN IP address.

Configure the PC's default gateway to be Router's 1 LAN IP address.

You need an IP route on Router 0 for Router's 1 LAN subnet with directed connected interface between the routers as the gateway.

You need an IP route on Router 1 for Router's 0 LAN subnet with directed connected interface between the routers as the gateway.

HTH,

__

Edison.

New Member

Re: pc cant access server across two routers (pic is attached)

version 12.2

no service password-encryption

!

hostname Router

!

!

!

!

!

ip ssh version 1

!

!

interface FastEthernet0/0

ip address 192.168.3.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0

ip address 192.168.2.2 255.255.255.0

!

interface Serial0/1

no ip address

shutdown

!

router eigrp 100

network 192.168.3.0

no auto-summary

!

ip classless

ip route 192.168.3.0 255.255.255.0 10.10.35.1

ip route 192.168.2.0 255.255.255.0 10.10.35.1

!

!

!

ip dhcp excluded-address 192.168.3.1 192.168.3.10

!

ip dhcp pool INTERNAL

network 192.168.3.0 255.255.255.0

!

line con 0

line vty 0 4

login

!

!

end

the other router is...

version 12.2

no service password-encryption

!

hostname Router

!

!

!

!

!

ip ssh version 1

!

!

interface FastEthernet0/0

ip address 10.10.35.1 255.255.0.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0

ip address 192.168.2.1 255.255.255.0

ip summary-address eigrp 100 10.10.0.0 255.255.0.0 5

clock rate 64000

!

interface Serial0/1

no ip address

shutdown

!

router eigrp 100

network 10.10.0.0 0.0.255.255

auto-summary

!

ip classless

ip route 10.10.0.0 255.255.0.0 192.168.3.1

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

end

I STILL CANT PING THE SERVER FROM THE PC

Re: pc cant access server across two routers (pic is attached)

On first router add...

!

router eigrp 100

network 192.168.2.0

!

remove...

!

ip route 192.168.3.0 255.255.255.0 10.10.35.1

ip route 192.168.2.0 255.255.255.0 10.10.35.1

!

On the second router add...

!

router eigrp 100

network 192.168.2.0

!

remove...

!

ip route 10.10.0.0 255.255.0.0 192.168.3.1

!

Hall of Fame Super Silver

Re: pc cant access server across two routers (pic is attached)

Dustin

Your post is not clear whether the default gateway has been configured as suggested by Edison. This would be important in getting connectivity between the PC and the server.

But there are issues in the way that the routers are configured that get in the way of connectivity. In particular I notice that you have configuerd EIGRP 100 on both routers and have a network statement under EIGRP for the LAN interface. But you do not have a network statement for the serial interface. Therefore EIGRP is not running on the serial interface and therefore there is no neighbor relationship and no routes are advertised. The simple fix is to add network 192.168.2.0 0.0.0.255 to both EIGRP processes. If you do this then EIGRP should advertise the subnets to both routers and you would not need any static routes.

HTH

Rick

Hall of Fame Super Bronze

Re: pc cant access server across two routers (pic is attached)

You are running a dynamic routing protocol so it will make this easier.

Just include the serial IP subnets under the EIGRP process network 192.168.2.0 0.0.0.255 and remove the ip routes on both routers - they aren't needed.

HTH,

__

Edison.

New Member

Re: pc cant access server across two routers (pic is attached)

awesome...i can ping from the server to the other router, but i cant hit the end machine....

BUT!!!,

the serial is 192.168.2.0

however the network that has the pc on is

192.168.3.0...

do i need to include that in the eigrp 100?

Hall of Fame Super Bronze

Re: pc cant access server across two routers (pic is attached)

The router with LAN IP subnet 192.168.3.0 already has it under EIGRP process.

EIGRP will advertise this subnet over to the LAN IP Subnet 10.10.35.0

If you are able to ping from the server to 192.168.3.1, then the problem is the PCs are missing the default-gateway. Ensure you've entered 192.168.3.1 as the default-gateway on each PC on that subnet.

HTH,

__

Edison.

New Member

Re: pc cant access server across two routers (pic is attached)

your right!!!! Thank you!!!

New Member

Re: pc cant access server across two routers (pic is attached)

Edison

I apologize, this is the error I am getting when i ping the server from the PC...

1 62 ms 62 ms 63 ms 192.168.3.1

2 63 ms * 78 ms 192.168.3.1

3 * 62 ms * Request timed out.

4 62 ms * 48 ms 192.168.3.1

5 * 62 ms * Request timed out.

6 62 ms * 63 ms 192.168.3.1

7 * 63 ms * Request timed out.

8 94 ms * 77 ms 192.168.3.1

9 * 63 ms * Request timed out.

10 63 ms * 63 ms 192.168.3.1

New Member

Re: pc cant access server across two routers (pic is attached)

THis is router 0... (from the pic)

no service password-encryption

!

hostname Router

!

!

!

!

!

ip ssh version 1

!

!

interface FastEthernet0/0

ip address 10.10.35.1 255.255.0.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0

ip address 192.168.2.1 255.255.255.0

clock rate 64000

!

interface Serial0/1

no ip address

shutdown

!

router eigrp 100

network 192.168.2.0

no auto-summary

!

ip classless

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

end

THIS IS ROUTER 2 (from the pic)

hostname Router

!

!

!

!

!

ip ssh version 1

!

!

interface FastEthernet0/0

ip address 192.168.3.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0

ip address 192.168.2.2 255.255.255.0

!

interface Serial0/1

no ip address

shutdown

!

router eigrp 100

network 192.168.2.0

no auto-summary

!

ip classless

!

!

!

ip dhcp excluded-address 192.168.3.1 192.168.3.10

!

ip dhcp pool INTERNAL

network 192.168.3.0 255.255.255.0

!

line con 0

line vty 0 4

login

!

!

end

Hall of Fame Super Bronze

Re: pc cant access server across two routers (pic is attached)

You removed the previous network commands under EIGRP.

On Router 0 you need:

router eigrp 100

network 192.168.2.0

network 10.10.35.0 0.0.0.255

no auto-summary

On Router 1 you need:

router eigrp 100

network 192.168.2.0

network 192.168.3.0

no auto-summary

255
Views
5
Helpful
11
Replies