Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

performance troubleshooting

using a Cisco 2960 switch I get very poor connection to the network

other switches on the network allow a fast reliable connection.

when I switch a PC from this 2960 to other switches the performance boost immediately

how do I troubleshoot and find the reason? (it is a new out of the box switch so I guess it is a config issue and not hardware related)

9 REPLIES

Re: performance troubleshooting

I don't know if you have already configured portfast on the access ports. If it isn't can you configure 'spanning-tree portfast' on the ports connected to PCs and see if that helps.

If you are still having issues can you give more details of your problem.

HTH

Sundar

Community Member

Re: performance troubleshooting

this is the port config:

interface FastEthernet0/16

description ***

switchport access vlan 201

switchport mode access

speed 100

duplex full

FastEthernet0/16 is down, line protocol is down (notconnect)

Hardware is Fast Ethernet, address is 001b.2aaf.a490 (bia 001b.2aaf.a490)

Description: ***

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 10/100BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 04:16:48, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

23123090 packets input, 3306271391 bytes, 0 no buffer

Received 797083 broadcasts (0 multicast)

3 runts, 0 giants, 0 throttles

70945 input errors, 70654 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 274522 multicast, 0 pause input

0 input packets with dribble condition detected

1004846643 packets output, 2307488030 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

it is a plain LAn with few VLANs

what other data would help here?

Re: performance troubleshooting

As you can see there is a lot of CRC errors on the port. It can be due to a duplex issue, bad cable, port, NIC etc. As a first step, can you use the following configuration and see if it helps.

interface FastEthernet0/16

description ***

switchport access vlan 201

switchport mode access

speed auto

duplex auto

spanning-tree portfast

HTH

Sundar

Community Member

Re: performance troubleshooting

looking at other ports on the same switch, CRC errors show all over the place

all the ports are configed in the same way

Re: performance troubleshooting

It could be duplex mismatch between the switch and PC NICs. If you have the NIC duplex set to auto negotiate I would suggest using the duplex to auto on the switch port and see that indeed is the problem here.

Community Member

Re: performance troubleshooting

adding spanning-tree portfast seem to fix the problem.

is there a way (other then booting the switch) to clear the CRC count on each interface so I can check it for additional errors?

Re: performance troubleshooting

Glad to hear that :)

Clear counters should clear the counters.

Community Member

Re: performance troubleshooting

thanks!

Re: performance troubleshooting

No problem. Also, if the CRC errors come back consider setting the duplex to auto.

182
Views
0
Helpful
9
Replies
CreatePlease to create content