Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Pinging router id of ABR router

                   Hi all,

Here is ospf router setup.

R1 is ASBR in area 0.

R2 is ABR connected to area 0 and area 10

R3  is connected to Router R2 and is in area 0 and 10

Say R2 has router id 3.4.4.4.

Now in order to ping this router id of R2 from R1 and R3 

Should we advertise this as network 3.4.4.4 0.0.0.0 area 0 or 10?

Is it possible that both R1 and R3 can ping R2s router id?

So far i found that i am unable to ping any router ids?

Note all 3 routers have routers id configured with router id command.************************************************************************

Thanks

MAhesh

Everyone's tags (3)
3 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Re: Pinging router id of ABR router

Hello Mahesh,

in order to have pingable OSPF router-ids you should use loopback interfaces that is you give the IP address to a loopback interface AND you use a network command to advertise the associated IP address

example for your R2

int loop0

ip address 3.4.4.4 255.255.255.255

desc OSPF RID

router ospf 10

router-id 3.4.4.4.

network 3.4.4.4 0.0.0.0 area 0.0.0.0

!

For routers that act as ABR I would advertise in area 0.0.0.0 their OSPF RID, for routers internal to an area X the network command for the router-id/loopback has to use the same area-id X of the physical interfaces or it would be unreachable.

if all areas are normal areas you should be able to ping from router-id to router-id of all possible router combinations.

The only special case are totally not so stubby area NSSA if a default route is not injected by ABR into the area.

note:

if you would like to use IP subnets that are not /32 you have to configure

example:

int loop0

ip address 3.4.4.4 255.255.255.0

ip ospf network point-to-point

in order to have OSPF to advertise with the correct subnet mask, OSPF by default advertises /32 for loopbacks whatever subnet mask is configured in the IP address

Hope to help

Giuseppe

Hall of Fame Super Silver

Re: Pinging router id of ABR router

Hello Mahesh,

yes it wouldn't be pingable if no interface on the router has the same IP address and this is logical

In other words OSPF router-id command allows only for manually setting of OSPF RID on the device, it does not create a logical interface with that IP address on the node. That choice is left to you depending on your needs.

pingable and reachable OSPF RIDs are very handy in troubleshooting as you can jump on a router using its OSPF RID.

Hope to help

Giuseppe

Hall of Fame Super Silver

Pinging router id of ABR router

Mahesh

To add a little to the very good explanation from Giuseppe, the default in OSPF is to choose the Router ID from an IP address of an interface on the router that is in an up state. And if the RID is an interface IP then it is easy to advertise that address to OSPF neighbors. So the default behavior usually results in RID that is pingable.

But OSPF does not require that the RID be pingable. And when we take advantage of the ability to manually configure the Router ID then we can choose any IP address that we want as the RID. It does not need to be an address that is on the router and it does not need to be advertised to OSPF neighbors. And the RID does not need to be pingable.

If we want the OSPF RID to be pingable it does not necessarily need to be an interface address (though this is the easiest way to do it). The RID needs to be part of a subnet that is advertised to other OSPF routers to make the RID pingable (you could configure a static route to some subnet which includes the RID and then redistribute static into OSPF, and make the RID pingable without having it be an interface address).

HTH

Rick

5 REPLIES
Hall of Fame Super Silver

Re: Pinging router id of ABR router

Hello Mahesh,

in order to have pingable OSPF router-ids you should use loopback interfaces that is you give the IP address to a loopback interface AND you use a network command to advertise the associated IP address

example for your R2

int loop0

ip address 3.4.4.4 255.255.255.255

desc OSPF RID

router ospf 10

router-id 3.4.4.4.

network 3.4.4.4 0.0.0.0 area 0.0.0.0

!

For routers that act as ABR I would advertise in area 0.0.0.0 their OSPF RID, for routers internal to an area X the network command for the router-id/loopback has to use the same area-id X of the physical interfaces or it would be unreachable.

if all areas are normal areas you should be able to ping from router-id to router-id of all possible router combinations.

The only special case are totally not so stubby area NSSA if a default route is not injected by ABR into the area.

note:

if you would like to use IP subnets that are not /32 you have to configure

example:

int loop0

ip address 3.4.4.4 255.255.255.0

ip ospf network point-to-point

in order to have OSPF to advertise with the correct subnet mask, OSPF by default advertises /32 for loopbacks whatever subnet mask is configured in the IP address

Hope to help

Giuseppe

New Member

Pinging router id of ABR router

Hi Giuseppe,

Thanks for reply.

So if router-id is not associated with any loopback interface then we can say that it will not be pingable right?

Thanks

MAhesh

Hall of Fame Super Silver

Re: Pinging router id of ABR router

Hello Mahesh,

yes it wouldn't be pingable if no interface on the router has the same IP address and this is logical

In other words OSPF router-id command allows only for manually setting of OSPF RID on the device, it does not create a logical interface with that IP address on the node. That choice is left to you depending on your needs.

pingable and reachable OSPF RIDs are very handy in troubleshooting as you can jump on a router using its OSPF RID.

Hope to help

Giuseppe

Hall of Fame Super Silver

Pinging router id of ABR router

Mahesh

To add a little to the very good explanation from Giuseppe, the default in OSPF is to choose the Router ID from an IP address of an interface on the router that is in an up state. And if the RID is an interface IP then it is easy to advertise that address to OSPF neighbors. So the default behavior usually results in RID that is pingable.

But OSPF does not require that the RID be pingable. And when we take advantage of the ability to manually configure the Router ID then we can choose any IP address that we want as the RID. It does not need to be an address that is on the router and it does not need to be advertised to OSPF neighbors. And the RID does not need to be pingable.

If we want the OSPF RID to be pingable it does not necessarily need to be an interface address (though this is the easiest way to do it). The RID needs to be part of a subnet that is advertised to other OSPF routers to make the RID pingable (you could configure a static route to some subnet which includes the RID and then redistribute static into OSPF, and make the RID pingable without having it be an interface address).

HTH

Rick

New Member

Pinging router id of ABR router

Hi Rick and Giuseppe,

Many thanks for reply.

Your explaination  was wonderful !.

Its always good to read your  posts.

Lot to learn from you guys.

Best regards

Mahesh

1955
Views
0
Helpful
5
Replies