Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Pls help with multicast stream which sometimes turns to broadcast to each port of switch

Hello all. May be anybody met such problem ?

We have strange problems with multicast stream behavior. Most of time it works as it has, but sometimes ALL multicast stream (not only

groups, which requested by igmp) goes from one switch with source (MainPOP, c4948) to the second (POP-1, c2970) and than from c2970 to c2950T (access level). MVR and IGMP snooping enabled at c2970 and all c2950T.

What can be the reason that multicast stream turned to broadcast, cos c2970 sends the same stream to each connected trunk to c2950T (about 7 pc's) ?

And after some time it returns to ordinary behavior (from 500Mbit to 145-160).

MC-strange.JPG

Some details about configuration:

1. Multicast stream as source goes to MainPOP, c4948E

ip multicast-routing

interface GigabitEthernet1/12  (shown at picture above)

description IPTV Trunk to POP-1 (Green SFP)

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 970

switchport mode trunk

interface GigabitEthernet1/41

description IPTV Source from MainPOP

switchport access vlan 970

switchport mode access

load-interval 60

spanning-tree portfast

interface Vlan970

ip address 192.168.10.10 255.255.255.0

no ip redirects

ip pim sparse-mode

ip pim rp-address 192.168.10.10 IPTV override

!

ip access-list standard IPTV

permit 239.255.1.0 0.0.0.255

permit 239.255.2.0 0.0.0.255

permit 239.255.3.0 0.0.0.255

permit 224.50.0.0 0.0.0.255

2. POP-1, c2970

ip igmp snooping

mvr

mvr mode dynamic

mvr vlan 970

mvr group 239.255.1.1  100

interface GigabitEthernet0/15

description IPTV Trunk to core-4948 (Green SFP)

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 970

switchport mode trunk

mvr type source

interface GigabitEthernet0/4

description Point-2 (Trunk to access level SW)

switchport trunk encapsulation dot1q

switchport trunk native vlan 15

switchport trunk allowed vlan 2-12,14-4094

switchport mode trunk

mvr type source

Everyone's tags (6)
312
Views
0
Helpful
0
Replies