Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Plz help mw with PPTP with multicast enable

Hi ,

ive setup a pptp server on router  , but i want to make sure that multicast udp packets are exchanging between my local lan and users that come by pptp tunel

here is my config of router :

=========================

cisco900#sh run

no ipv6 cef
ip source-route
ip cef
!
!
!
ip multicast-routing 
!
!
!
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
 ! Default PPTP VPDN group
 accept-dialin
  protocol pptp
  virtual-template 1
 l2tp tunnel timeout no-session 15
!
vpdn-group 2
 ! Default L2TP VPDN group
 accept-dialin
  protocol l2tp
!
!
!

!
interface GigabitEthernet0/0
 ip address x.x.x.x 255.255.255.0
 ip pim dense-mode
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.20.30.1 255.255.255.0
 ip pim dense-mode
 ip nat inside
 ip virtual-reassembly in
 ip igmp join-group 224.17.2.148
 ip igmp join-group 224.17.1.148
 ip igmp join-group 224.1.1.1
 duplex auto
 speed 100
!
interface Virtual-PPP3
 no ip address
!
interface Virtual-Template1
 ip unnumbered GigabitEthernet0/0
 ip pim dense-mode
 ip nat inside
 ip virtual-reassembly in
 ip igmp join-group 224.100.100.100
 peer default ip address pool PPTP
 no keepalive
 ppp encrypt mppe 128
 ppp authentication ms-chap ms-chap-v2 DRVIRUS
 ppp authorization DRVIRUS
!
interface vmi3
 no ip address
 mode bypass
!
!
!
router eigrp 1
 network 0.0.0.0
 network 85.252.160.200 0.0.0.0
!
ip local pool PPTP 10.11.12.1 10.11.12.100
ip forward-protocol nd
!

ip nat inside source list INTERNET interface GigabitEthernet0/0 overload

ip nat inside source list NATPPTP interface GigabitEthernet0/0 overload


!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!         
!
gatekeeper
 shutdown
!
!
!
line con 0
line aux 0
line 2
 

================================

Everyone's tags (1)
1 REPLY
New Member

i cant recive multicast on my

i cant recive multicast on my pc , i mean when i run wireshark i only have heloo pim2 messages .

 

ive added eigrp for test , and i could reciver 224.0.0.10 from router.

 

but i want somebody expert to have a look on my config above and make sure it is correct to send & recive multicast packets

 

regards

164
Views
0
Helpful
1
Replies
CreatePlease to create content