Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

policy based routing not working on cisco 6509

Hello,

i have following topology

Cleint ip address: 99.99.99.1 --------------> connected on port 1/33

Load balancer: 101.101.101.50 ---------- > connected on port 1/44.

I have configured pbr so that any traffic coming from client on port 1/33 should be directed to load balancer and following are my configs


=======================================================================================

access-list 197 permit ip host 99.99.99.1 host 4.2.2.2

route-map ingress1 permit 10

match ip address 197

set ip next-hop 101.101.101.50

interface GigabitEthernet1/33

ip address 99.99.99.5 255.255.255.0

ip policy route-map ingress1

interface GigabitEthernet1/44

ip address 101.101.101.5 255.255.255.0

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

For some reason this doesnt seems to be working. From my cisco switch i can ping to both client and load balancer.

What debug commands i can use here to troubleshoot? Is there any misconfiguration?

Thanks

3 REPLIES

policy based routing not working on cisco 6509

debug ip policy

The config looks fine from a pbr perspective. What is your load balancer doing once it receives the packet though? Does it act like a router and forward the packet?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***

policy based routing not working on cisco 6509

Hello Zafar.

You said:

"I have configured pbr so that any traffic  coming from client on port 1/33 should be directed to load balancer and  following are my configs "

But then you configured:

"access-list 197 permit ip host 99.99.99.1 host 4.2.2.2"

So that's not any traffic coming from the client, it just matches traffic between the source host 99.99.99.1 and the destination host 4.2.2.2

what if you try changing to acl to point to any any, like access-list 197 permit ip host 99.99.99.1 any any.

Regards.

Wilson B

New Member

policy based routing not working on cisco 6509

Hi Guys,

Thanks for the help. It was an issue on load balancer.

166
Views
0
Helpful
3
Replies