Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Policy Based Routing

Good afternoon,

I have configured two route maps that I will assign to different interfaces. I am testing with a Cisco 4506 loaded with Version 12.2(37)SG. When I go to assign the route-map to a particular interface, I complete the following commands:

conf t

int gig2/6

and there is no command for ip policy route-map map-tag.

Is there something I am missing on a 4506? It is Cisco IOS version.

Thank you.

Dwane

12 REPLIES
Hall of Fame Super Blue

Re: Policy Based Routing

Dwane

Have you configured the interfaces as layer 3 routed interfaces ie.

conf t

int gi2/6

no switchport

If the interfaces are layer 2 switchports which they are by default then the "ip policy ..." command will not be available.

Jon

New Member

Re: Policy Based Routing

Jon,

Thanks for the quick response, but I have an ip address on that interface.

interface GigabitEthernet2/6

description test HRC to ERC

no switchport

ip address 192.168.254.1 255.255.255.248

spanning-tree portfast

interface Vlan503

ip address 10.101.254.254 255.255.255.128

ip helper-address 129.111.26.6

ip helper-address 129.111.26.7

no ip redirects

ip route-cache same-interface

no ip route-cache cef

no ip route-cache

These are the two interfaces I would like to assign the Route-maps.

This is weird.

THanks

Dwane

Hall of Fame Super Blue

Re: Policy Based Routing

Dwane

Just checked Feature Navigator. IP base image does not support PBR. For PBR you need Enterprise Services.

Which feature set do you have ?

Jon

New Member

Re: Policy Based Routing

Jon,

That is what we thought until we went out and read the Guide for 12.2.37 SG and it showed us exactly how to do this? How the heck can you offer up the ability to do route-maps and not the ability to assign the route-maps?

It is the IP based image. cat4500-IPBASEK9-M

Thanks

Dwane

New Member

Re: Policy Based Routing

My apologies. I said "how can you offer" when I meant how can Cisco offer the ability to create route-maps and not the ability to assign them? Weird. I will look at upgrading. Can you send me the link that you were refering to for the feature sets?

Thanks again for all your help.

Dwane

Hall of Fame Super Blue

Re: Policy Based Routing

http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp

Search by Platform and then in the drop down box ignore the CatOS entries at the top and scroll down to the 4500 entires under IOS.

I guess the thinking is route-maps can be used for other things than just PBR so you may need them in the IP Base image.

Jon

Hall of Fame Super Bronze

Re: Policy Based Routing

You need a SupIV or better for PBR. If you are running SupII, it won't support that feature.

HTH,

__

Edison.

New Member

Re: Policy Based Routing

Edison,

Here is our sup for this switch:

1 2 Supervisor IV 1000BaseX (GBIC) WS-X4515 JAE1118FGLD

is our Sup.

This is odd.

Dwane

New Member

Re: Policy Based Routing

Edison and Jon,

I think Jon hit right on the head with the PBR not being supported in the IP BASIC IOS. IT is supported in the enterprise version. I am sitll not sure why Cisco would offer the route-map capability with the the ability to assign the route-map to an interface.

THis is all too weird.

Thanks for your help. Great Job. Thanks for the advice.

Dwane

Hall of Fame Super Bronze

Re: Policy Based Routing

route-map is not only for PBR. You can use route-map for route distribution.

for instance,

router rip

redistribute connected metric 1 route-map test

HTH,

__

Edison.

New Member

Re: Policy Based Routing

Edison,

Thank you.

Please view this link for the necessary explanation.

http://www.cisco.com/en/US/docs/ios/12_0/qos/configuration/guide/qcpolicy.html

Thanks but I think it is actually an issue with the version I am running. I will acke it on Monday. Have a great weekend and thanks for everyone's help.

Dwane

Dwane

Hall of Fame Super Bronze

Re: Policy Based Routing

Yes, I know the version you are running isn't capable of supporting PBR. I was merely pointing out the fact that you can use route-map (which is a component of PBR) for other purposes.

The key command for PBR is ip policy route-map.

311
Views
0
Helpful
12
Replies
CreatePlease login to create content