Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

policy-map not matching DSCP EF

As a test I have enabled a policy-map PM-QOS-LAN on my switch VLAN 'LAN' interface to match packets based on ACL, and set DSCP EF.  I can see matches for this policy-map.  However when I enable another policy-map PM-QOS-WAN on my switch VLAN 'WAN' interface to match for DSCP EF I can't see any matches. 

I can't see what I am doing wrong.  Can anyone help thanks?

## Classify traffic & set DSCP EF

ip access-list extended ACL-QOS-LAN

remark Classify traffic

10 permit ip 192.168.16.0 0.0.0.255 192.168.8.0 0.0.0.255

class-map match-any CM-QOS-LAN

  match access-group name ACL-QOS

policy-map PM-QOS-LAN

  class CM-QOS

   set dscp ef

interface vlan 21

description Local Hosts

ip vrf forwarding Test

ip address 192.168.16.254 255.255.255.0

service-policy input PM-QOS-LAN

ip route vrf Test 192.168.8.0 255.255.255.0 192.168.64.1

R1#show policy-map interface vlan 21

Vlan21

  Service-policy input: PM-QOS-LAN

    Class-map: CM-QOS-LAN (match-any)

      724644 packets

      Match: access-group name ACL-QOS-LAN

        724644 packets

      QoS Set

       ip dscp ef

    Class-map: class-default (match-any)

      6586885 packets

      Match: any

## See if classification is working

class-map match-any CM-QOS-WAN

  match ip dscp ef

policy-map PM-QOS-WAN

  class CM-QOS-WAN

interface vlan 11

description WAN

ip vrf forwarding Test

ip address 192.168.64.2 255.255.255.252

service-policy input PM-QOS-WAN

service-policy output PM-QOS-WAN

R1#sh policy-map interface vlan 11

Vlan11

  Service-policy input: PM-QOS-WAN

    Class-map: CM-QOS-WAN (match-any)

      0 packets

      Match: ip dscp ef

        0 packets

    Class-map: class-default (match-any)

      9734258 packets

      Match: any

  Service-policy output: PM-QOS-WAN

    Class-map: CM-QOS-WAN (match-any)

      0 packets

      Match: ip dscp ef

        0 packets

    Class-map: class-default (match-any)

      6536248 packets

      Match: any


## Classify traffic & set DSCP EF

ip access-list extended ACL-QOS-LAN
remark Classify traffic
10 permit ip 192.168.16.0 0.0.0.255 192.168.8.0 0.0.0.255

class-map match-any CM-QOS-LAN
  match access-group name ACL-QOS

policy-map PM-QOS-LAN
  class CM-QOS
   set dscp ef

interface vlan 21
description Local Hosts
ip vrf forwarding Test
ip address 192.168.16.254 255.255.255.0
service-policy input PM-QOS-LAN


R1#show policy-map interface vlan 21
Vlan21

  Service-policy input: PM-QOS-LAN

    Class-map: CM-QOS-LAN (match-any)
      724644 packets
      Match: access-group name ACL-QOS-LAN
        724644 packets
      QoS Set
       ip dscp ef

    Class-map: class-default (match-any)
      6586885 packets
      Match: any


class-map match-any CM-QOS-WAN
  match ip dscp ef

policy-map PM-QOS-WAN
  class CM-QOS-WAN

interface vlan 11
description WAN
ip vrf forwarding Test
ip address 192.168.64.2 255.255.255.252
service-policy input PM-QOS-WAN
service-policy output PM-QOS-WAN


R1#sh policy-map interface vlan 11
Vlan11

  Service-policy input: PM-QOS-WAN

    Class-map: CM-QOS-WAN (match-any)
      0 packets
      Match: ip dscp ef
        0 packets

    Class-map: class-default (match-any)
      9734258 packets
      Match: any

  Service-policy output: PM-QOS-WAN

    Class-map: CM-QOS-WAN (match-any)
      0 packets
      Match: ip dscp ef
        0 packets

    Class-map: class-default (match-any)
      6536248 packets
      Match: any
2 REPLIES
New Member

policy-map not matching DSCP EF

Well I'm not sure why I'm not matching packets for DSCP on the switch WAN interface, but I've enabled an identical policy map on the WAN interface of the next hop device and I can see packets being matched just fine.

Super Bronze

policy-map not matching DSCP EF

Disclaimer

The    Author of this posting offers the information contained within this    posting without consideration and with the reader's understanding that    there's no implied or expressed suitability or fitness for any  purpose.   Information provided is for informational purposes only and  should not   be construed as rendering professional advice of any kind.  Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In    no event shall Author be liable for any damages whatsoever  (including,   without limitation, damages for loss of use, data or  profit) arising  out  of the use or inability to use the posting's  information even if  Author  has been advised of the possibility of such  damage.

Posting

Switches?  Often policy-maps are very restricted on switches vs. software routers.

1369
Views
0
Helpful
2
Replies
CreatePlease to create content