Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

port-based address allocation

Hi,

can i eanble this feature on etherchannel interface ?

i have single server with 2 X NIC (teaming LACP) towards the switch.

thanks,

Avi.

5 REPLIES
VIP Super Bronze

port-based address allocation

Hi,

When you team the NICs together, they logically become one interface.  So DHCP will assign one IP to both interfaces.

HTH

Community Member

Re: port-based address allocation

Ok

Do i need to configure something special?

When i connect the server with single interface it works.

With teaming it doesn't

Sent from Cisco Technical Support iPhone App

VIP Super Bronze

port-based address allocation

On the server side you need to configure NIC teaming with LACP (passive).  On the switch side you need to configure the Etherchannel with LACP (active).  Can you post the config from the switch?

HTH

Community Member

port-based address allocation

yes please do,

also see the debugging messages.

relevant config:

ip dhcp use subscriber-id client-id

ip dhcp subscriber-id interface-name

!

ip dhcp pool VLAN120

   network 181.120.0.0 255.255.0.0

   default-router 181.120.0.254

   dns-server 181.120.0.254

   reserved-only

   address 181.120.10.1 client-id "Fa1/0/1" ascii

   address 181.120.10.111 client-id "Fa1/0/2" ascii

   address 181.120.10.99 client-id "Po1" ascii

   address 181.120.10.88 client-id "Fa2/0/2" ascii

   address 181.120.0.77 client-id "Fa2/0/15" ascii

   address 181.120.0.55 client-id "Fa2/0/23" ascii

   address 181.120.10.95 client-id "Po2" ascii

   address 181.120.10.94 client-id "Port-channel2" ascii

!

!

port-channel load-balance dst-mac

!

interface Port-channel2

switchport access vlan 120

switchport mode access

ip dhcp server use subscriber-id client-id

ip dhcp client client-id Port-channel2

spanning-tree portfas

interface FastEthernet2/0/8

switchport access vlan 120

switchport mode access

channel-protocol lacp

channel-group 2 mode active

spanning-tree portfast

!

interface FastEthernet2/0/9

switchport access vlan 120

switchport mode access

channel-protocol lacp

channel-group 2 mode active

spanning-tree portfast

Switch#sh inter port-channel 2 etherchannel

Port-channel2   (Primary aggregator)

Age of the Port-channel   = 0d:02h:37m:51s

Logical slot/port   = 10/2          Number of ports = 2

HotStandBy port = null

Port state          = Port-channel Ag-Inuse

Protocol            =   LACP

Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits

------+------+------+------------------+-----------

  0     00     Fa2/0/8  Active             0

  0     00     Fa2/0/9  Active             0

Debug:

03:44:23: DHCPD: Reload workspace interface Vlan120 tableid 0.

03:44:23: DHCPD: tableid for 181.120.0.254 on Vlan120 is 0

03:44:23: DHCPD: client's VPN is .

03:44:23: DHCPD: using subscriber-id as client-id

03:44:23: DHCPD: using received relay info.

03:44:23: DHCPD: Sending notification of DISCOVER:

03:44:23:   DHCPD: htype 1 chaddr 0004.23e1.b7dc

03:44:23:   DHCPD: interface = Vlan120

03:44:23:   DHCPD: class id 4d53465420352e30

03:44:23: DHCPD: DHCPDISCOVER received from client 4661.322f.302f.39 on interface Vlan120.

03:44:23: DHCPD: using received relay info.

03:44:23: DHCPD: Sending notification of DISCOVER:

03:44:23:   DHCPD: htype 1 chaddr 0004.23e1.b7dc................intreface mac-address of teaming

03:44:23:   DHCPD: interface = Vlan120

03:44:23:   DHCPD: class id 4d53465420352e30

03:44:23: DHCPD: requested address 169.254.210.64 is not on subnet 181.120.0.0.

03:44:23: DHCPD: Allocate an address without class information (181.120.0.0)

03:44:26: DHCPD: Reload workspace interface Vlan120 tableid 0.

03:44:26: DHCPD: tableid for 181.120.0.254 on Vlan120 is 0

03:44:26: DHCPD: client's VPN is .

03:44:26: DHCPD: using subscriber-id as client-id

03:44:26: DHCPD: using received relay info.

03:44:26: DHCPD: Sending notification of DISCOVER:

03:44:26:   DHCPD: htype 1 chaddr 0004.23e1.b7dc

03:44:26:   DHCPD: interface = Vlan120

03:44:26:   DHCPD: class id 4d53465420352e30

03:44:26: DHCPD: DHCPDISCOVER received from client 4661.322f.302f.39 on interface Vlan120.

03:44:26: DHCPD: using received relay info.

03:44:26: DHCPD: Sending notification of DISCOVER:

03:44:26:   DHCPD: htype 1 chaddr 0004.23e1.b7dc

03:44:26:   DHCPD: interface = Vlan120

03:44:26:   DHCPD: class id 4d53465420352e30

03:44:26: DHCPD: requested address 169.254.210.64 is not on subnet 181.120.0.0.

03:44:26: DHCPD: Allocate an address without class information (181.120.0.0)

03:44:33: DHCP_SNOOPING: checking expired snoop binding entries

03:44:35: DHCPD: Reload workspace interface Vlan120 tableid 0.

03:44:35: DHCPD: tableid for 181.120.0.254 on Vlan120 is 0

03:44:35: DHCPD: client's VPN is .

03:44:35: DHCPD: using subscriber-id as client-id

03:44:35: DHCPD: using received relay info.

03:44:35: DHCPD: Sending notification of DISCOVER:

03:44:35:   DHCPD: htype 1 chaddr 0004.23e1.b7dc

03:44:35:   DHCPD: interface = Vlan120

03:44:35:   DHCPD: class id 4d53465420352e30

Community Member

port-based address allocation

HI,

what do you think?

574
Views
0
Helpful
5
Replies
CreatePlease to create content