Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Port-Channel behaviour ?? (Native VLAN mismatch, EIGRP issue...)

Hi,

I have two switches connected to each other via a port channel.  They also run EIGRP between them.  This connection has been working fine until this morning when on switch A I accidently placed one of the physcial interfaces of the port channel into switchport mode access.  This then unbundled the port channel and the EIGRP neighbourship between the two dropped.  15 minute later when I placed the physcial port back into trunk mode, the relationship came up again.

Looking at the config, you can see that the native VLAN between the two is incorrect (switch A = 1000, switch B = 1001) so i'm supprised this ever worked.  EIGRP will be using VLAN 432 to communicate between the 2 switches.  Below is the config for each switch as it is now.


SWITCH A (4506 - cat4000-i9k91s-mz.122-25.EWA4.bin)

interface Port-channel26
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 1000
switchport trunk allowed vlan 432,448-450,456-458,472-474,480-482,1000
switchport mode trunk

interface GigabitEthernet3/25
switchport trunk encapsulation dot1q
switchport trunk native vlan 1000
switchport trunk allowed vlan 432,448-450,456-458,472-474,480-482,1000
switchport mode trunk
channel-group 26 mode on

interface GigabitEthernet4/23
switchport trunk encapsulation dot1q
switchport trunk native vlan 1000
switchport trunk allowed vlan 432,448-450,456-458,472-474,480-482,1000
switchport mode trunk
channel-group 26 mode on

router eigrp 10
passive-interface default
no passive-interface Vlan432
network 10.0.0.0
no auto-summary

SWITCH B (6509 - s72033-ipbasek9-mz.122-33.SXH5.bin)

interface Port-channel26
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 1001
switchport mode trunk

interface GigabitEthernet1/1/23
  switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 1001
switchport mode trunk
channel-group 26 mode on

interface GigabitEthernet2/1/23
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 1001
switchport mode trunk
channel-group 26 mode on

router eigrp 10
  passive-interface default
  no passive-interface Vlan432
  network 10.0.0.0
  no auto-summary
  nsf

When I placed port Gi 3/25 into access mode on switch A, the following message appeared on the switch:

Switch A

sh log:

.Nov 30 08:56:36: %EC-5-UNBUNDLE: Interface GigabitEthernet3/25 left the port-channel Port-channel26
.Nov 30 08:56:36: %EC-5-CANNOT_BUNDLE2: Gi3/25 is not compatible with  Gi4/23 and will be suspended (dtp mode of Gi3/25 is off, Gi4/23 is on)
.Nov 30 08:56:47: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 10.4.32.1 (Vlan432) is down: holding time expired

What I want to know is, why is the port channel working with a native VLAN mismatch, and also, why did EIGRP stop working when one of the ports dropped out of the port-channel on switch A.

P.S. - I plan to change the native VLAN to match between the two switches in the next couple of days.

Cheers!!

Jimmy

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Port-Channel behaviour ?? (Native VLAN mismatch, EIGRP issu

Jimmy,

As long As the etherchannel is up then Eigrp neighborship should be active and not teared down, The Etherchannel is your uplink between 4506 and 6500 Switches, So I suspect the behaviour you are examining is a GNS issue. the GNS doesnt fully replicate what you have specially in for the Switching.

This is normal and expected behaviour if the uplink between your switches got interrupted and disconnected, it would therfore , tear down the Eigrp session.

HTH

Mohamed

5 REPLIES
Purple

Re: Port-Channel behaviour ?? (Native VLAN mismatch, EIGRP issu

   When you force on the port channel  it will explicitly make it a port channel no matter if its configured right or not  whereas if its a negotiated port channel those things are checked and most likely would have taken the channel down .  You should make sure when you fix the native issue that you make the allowed vlans the same on each side , they are currently not the same .

New Member

Re: Port-Channel behaviour ?? (Native VLAN mismatch, EIGRP issu

Cheers,

Now I just curious to why the EIGRP nieghbour dropped when one of the ports was unbundled from the port-channel.

Re: Port-Channel behaviour ?? (Native VLAN mismatch, EIGRP issu

Jimmy,

The Eigrp neighborship teared down because at the moment you changed the config of one of the etherchannel port, the Etherchannel went down as well. In order for an etherchannel port to be up and active , the member ports of the etherchannel should have identical configuration. If one of the physical ports were physically down , then I would Say EIGRP wont tear the session down , however by changing the config of the physical port manually , you have actuall teared down the etherchannel interface.

The Second point is that, According to what I read befor From Cisco Documentation I recall, The Native Vlan between trunk ports should match or else it could result in inconsistency and spanning-tree loops. Some IOS accepts the native vlan to be mismatched and some Doesnt by shuting down the trunk immediately. However, I highly recommend setting both trunks to the same Native vlan to avoid Spanning-tree loops and Inconsistency problems.

HTH

Mohamed

New Member

Re: Port-Channel behaviour ?? (Native VLAN mismatch, EIGRP issu

Thanks for your response.

I've jsut replicate this in GNS three using c360 with 16 port switch modules.  Same setup as described in the original post.  when I apply switchport mode access to one of the ports, the port drops out of the Port-channel bundle BUT it does not drop the EIGRP:

R6(config-if)#switchport mode access
R6(config-if)#
*Mar  1 00:08:34.779: %EC-5-UNBUNDLE: Interface Fa0/10 left the port-channel Po1
*Mar  1 00:08:34.811: %EC-5-CANNOT_BUNDLE2: Fa0/10 is not compatible with Fa0/11 and will be suspended (trunk mode of Fa0/10 is access, Fa0/11 is trunk)
*Mar  1 00:08:35.283: %DTP-5-NONTRUNKPORTON: Port Fa0/10 has become non-trunk
*Mar  1 00:08:35.655: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to down#
R6(config-if)#

R6#sh ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.11.12.2              Vl432             10 00:05:43   48   288  0  2
R6#

I'm guessing it's down to the old 4506 IOS.  We've had a lot of bugs with this.  Thanks for your input.

Re: Port-Channel behaviour ?? (Native VLAN mismatch, EIGRP issu

Jimmy,

As long As the etherchannel is up then Eigrp neighborship should be active and not teared down, The Etherchannel is your uplink between 4506 and 6500 Switches, So I suspect the behaviour you are examining is a GNS issue. the GNS doesnt fully replicate what you have specially in for the Switching.

This is normal and expected behaviour if the uplink between your switches got interrupted and disconnected, it would therfore , tear down the Eigrp session.

HTH

Mohamed

5603
Views
0
Helpful
5
Replies
CreatePlease login to create content