Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Port channel between two CAT4900M switch and a 3825 router

Hi guys,

I've got a requirement to create port channel for redundancy purpose.

We've got two Cat4900M switch running as HSRP pair. We want to connect a 3825 router with each onboard Gigabit Ethernet port connecting to one Cat4900M switch.I have configured it as below but it isn't working. It's flapping at the switches. Please help!

cat4900m_sw1#show run int g2/3

interface GigabitEthernet2/3
description router01 GI0/0
auto qos voip trust
service-policy input AutoQos-VoIP-Input-Cos-Policy
service-policy output AutoQos-VoIP-Output-Policy

interface Vlan1
description Network
ip address 172.21.1.253 255.255.255.0
no ip redirects
no ip unreachables
standby 0 ip 172.21.1.1
standby 0 priority 200
standby 0 preempt

cat4900m_sw2#show run int g2/3

interface GigabitEthernet2/3
  description router01 GI0/1
  auto qos voip trust
  service-policy input AutoQos-VoIP-Input-Cos-Policy
  service-policy output AutoQos-VoIP-Output-Policy

interface Vlan1
description Network
ip address 172.21.1.254 255.255.255.0
no ip redirects
no ip unreachables
standby ip 172.21.1.1

router01#

interface Port-channel1
ip address 172.21.1.2 255.255.255.0
load-interval 30
h323-gateway voip bind srcaddr 172.21.1.2
hold-queue 110 in
!
interface GigabitEthernet0/0
no ip address
load-interval 30
  duplex auto
speed auto
media-type rj45
no keepalive
channel-group 1
no mop enabled
hold-queue 150 in
!
interface GigabitEthernet0/1
no ip address
load-interval 30
duplex auto
speed auto
media-type rj45
no keepalive
channel-group 1
no mop enabled
hold-queue 110 in
!

4 REPLIES
Cisco Employee

Re: Port channel between two CAT4900M switch and a 3825 router

Hello Saravanen,

Can you please clarify if you are trying to connect a single port-channel on the router to two separate 4900? If so, that is not supported. Both ports of the channel need to connect back to the same device. The only exception would be a switch stack, 6500 VSS or Nexus VPC.

Fabienne

New Member

Re: Port channel between two CAT4900M switch and a 3825 router

Yeah... it wouldn't work on two different switches.

But is there any other way to do this? Provide redundancy link to the router from two core switches?

VIP Super Bronze

Re: Port channel between two CAT4900M switch and a 3825 router

It would also work, if you ware using 3750s stacked

New Member

Re: Port channel between two CAT4900M switch and a 3825 router

As Reza mentioned that you may use stackable switches OR at the minimun, you can

(you already may have it) have a direct L2 link b/w two switches, confiugre a vlan interface on two switches, assign them IP addresses and include them in your routing domain and set metrics according to your needs. This way each swith will be directly connected to router and in case  if direct links fails then you may use the other link through second switch. This scenario still involves single point of failure if router goes down.

522
Views
0
Helpful
4
Replies
CreatePlease to create content