Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Port-Channel caused CRC error ?

Hi NetPro,

currently my port-channel config at Cat6509 as below.

Interface Port-Channel9

switchport

switchport access vlan 64

and used at Cat4507

interface GigabitEthernet4/29

description Cisco

switchport access vlan 64

spanning-tree portfast

channel-group 9 mode on

interface GigabitEthernet4/39

description Cisco

switchport access vlan 64

spanning-tree portfast

channel-group 9 mode on

so, when i " show interface gi 4/29 "

i got input and CRC error.

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 7434000 bits/sec, 669 packets/sec

1987713842 packets input, 188931850324 bytes, 0 no buffer

Received 216462 broadcasts (10659 multicast)

3743826 runts, 0 giants, 0 throttles

6074501 input errors, 2330675 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

12836531883 packets output, 18532759512753 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

any suggest ?

Regards,

Jackal

8 REPLIES
New Member

Re: Port-Channel caused CRC error ?

Hi Jackal,

could it be that one or more of the interfaces on one of the switches are in half-duplex modus?

Regards

Marcos

New Member

Re: Port-Channel caused CRC error ?

Hi Marcos,

initially, i've hardcoded to both site but end up i still got the CRC error, and then when i try auto i still got the same thing.

i am curious about what went wrong ?

Regards,

Jackal

New Member

Re: Port-Channel caused CRC error ?

Hi Jackal,

did you try other cables on the ports? Did you try other Ports? Could it be that the cables be out of specifications? Could it be that the distance between the switches is too long? Did you got the same errors when you unchannel the ports and try one port each other to find out if one or more ports are defective? Personaly I would try it without portfast on the channel, because there is a switch on the other end and the spanningtree could not run correcly during port initialisation.

I hope this will help you to find a solution for your problem.

Regards

Marcos

New Member

Re: Port-Channel caused CRC error ?

Hi Marcos,

yes, i did change cables and another switch port as well, but CRC error still remain. so you would suggest remove the spann-portfast on channel-group ? ok , i will try it and let you know then.

Regards,

Jackal

New Member

Re: Port-Channel caused CRC error ?

Hi NetPro,

i have tried to remove the portfast from the channel-group, but i still got the CRC error ? something i dont understand was from the etherchannel - Gi4/29 and Gi4/39.

since this is port-channel how come the CRC error only occurred on Gi4/29 only ?

even thought i have changed the switch port as well, i still got the CRC error !

interface GigabitEthernet4/29

description Cisco

switchport access vlan 64

channel-group 9 mode on

interface GigabitEthernet4/39

description Cisco

switchport access vlan 64

channel-group 9 mode on

so, when i " show interface gi 4/29 "

i got input and CRC error.

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 7434000 bits/sec, 669 packets/sec

1987713842 packets input, 188931850324 bytes, 0 no buffer

Received 216462 broadcasts (10659 multicast)

3743826 runts, 0 giants, 0 throttles

6074501 input errors, 2330675 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

12836531883 packets output, 18532759512753 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Silver

Re: Port-Channel caused CRC error ?

Hi,

which type of Giga module do you have installed?

Regards

Andrea

Purple

Re: Port-Channel caused CRC error ?

Do a show interface status and see how it negotiated the link and at what speed . One side or the is probably not correct . Match both sides either hardcode both sides or leave both sides as auto .

New Member

Re: Port-Channel caused CRC error ?

Hi Glen,

yes, i have hard code for both sites.

Hi Andrea,

i am using WS-X4448-GB-RJ45 module.

Regards,

Jackal

1221
Views
0
Helpful
8
Replies