Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Port-channel configuration 3560X and 2960S

Hello,

I am trying to connect a 2960 swith to 3560X using port channel. I have configred the switches with the following configratuion and connected them with straight ethernet cable, the link came up and then it went int err-disable state. I re-enabled the links and connected them using one cross over cable it connected and remained connected for a whole day in my lab. When I shut down both switches and took them the server room and connected both ports using cross over cable it came up and then went into err-disable state. Bellow is my configuration, can you please point out to me what I am missing: (no VTP domain configured on any of the switches)

------------------2960 configuration----------------------

interface Port-channel1
switchport trunk native vlan 999
switchport mode trunk

interface GigabitEthernet1/0/51
switchport trunk native vlan 999
switchport mode trunk
channel-group 1 mode on

interface GigabitEthernet1/0/52
switchport trunk native vlan 999
switchport mode trunk
channel-group 1 mode on

------------------3560X configuration-------------------------------

interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport mode trunk

interface GigabitEthernet0/23
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport mode trunk
channel-group 1 mode

interface GigabitEthernet0/24
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport mode trunk
channel-group 1 mode on

Thank you.

Everyone's tags (3)
2 REPLIES
VIP Super Bronze

Re: Port-channel configuration 3560X and 2960S

Hi,

Your condig looks good and straightthrough cable should work just fine.  Can you do the following:

take the interfaces out of the portchannel

shut the portchannel

shut the interfaces

add the interfaces to the portchannel

"no sh" the PO and test again?

This should bring up the interface and the portchannel

HTH

Hall of Fame Super Gold

Port-channel configuration 3560X and 2960S

the link came up and then it went int err-disable state.

Post the output to the command "sh interface status err".

367
Views
0
Helpful
2
Replies
CreatePlease to create content