Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

port-channel issues

Hi

I set up a port-channel trunk between a acess switch 3750 ( int gi2/0/1 and gi2/0/2) and Core 6509( int gi7/11 and gi7/12).

On the both the 3750& 6509 I configured:

interface Port-channel15

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,103

switchport mode trunk

and config all the interfaces gi2/0/1 and gi2/0/2

interface gi2/0/1 and 2 and gi7/11 and gi7/12 as below:

switchport trunk encapsulation dot1q

switchport trunk native vlan111

switchport trunk allowed vlan 100.103

switchport mode trunl

channel-group 15 mode active

but the ports on the core g7/11 and g7/12 keep shutdown and when i do

show interfaces port-channel 15

it show the interface is shutdown.

Any advice is much appreciated.

Thanks

lq

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: port-channel issues

Please post the error message when it shutdown..  Also make sure you have the native vlan command under the port channel SVI's on each side.

6 REPLIES

port-channel issues

>>switchport trunk allowed vlan 100.103

>>switchport mode trunl

You have a period, this is incorrect, is this a typo?

Same for sw mo trunl.....

Have you verified all ints on this port channel are not shutdown (not the port channel but the ints)?

port-channel issues

Are all the physical interfaces up ? Please post the output of show etherchannel summary.

New Member

port-channel issues

hi,

sorry there are a typo in the config posted.

The steps I did was:

set up 2 trunks between the 3750 and core 6509.

set these 4 interfaces to be up - establish a link.

then config the port-channel interfaces in 3750 , then 6509.

config the 4 interfaces to be on port-channels.

then i got a warning message that the 2 interfaces on the 3750 got SHUTDOWN.

and the port-channels on both switches got SHUTDOWN.

when I do show etherchannel sum -it show the port-channel is down.

I always took these configs out the switches - just in case it cause any further issues.

I can do it again if needed.

Thanks

leq

Purple

Re: port-channel issues

Please post the error message when it shutdown..  Also make sure you have the native vlan command under the port channel SVI's on each side.

New Member

Re: port-channel issues

glen.grant wrote:

Please post the error message when it shutdown..  Also make sure you have the native vlan command under the port channel SVI's on each side.

I did not have native VLAN command - maybe that would cause the issues

Currently the configs and the switches state are:

6509

interface g7/11 and g7/12 - up - no port-channel config yet

port-channel15 - shutdown

3750 interface gi2/0/1 and gi2/0/2 - up - no port-channel config

port-channel15 - shutdown

NOW I config both the ints gi2/0/1 and 2 with the comand: channel-group 15 mode active

THEN, the 3750 shut down both the int gi2/0/1 and 2

the log on the 3750 is:

Jan 25 11:19:31.205 AEST: %EC-5-PORTDOWN: Shutting down Gi2/0/1 as its port-channel is admin-down

Jan 25 11:19:31.649 AEST: %EC-5-PORTDOWN: Shutting down Gi2/0/2 as its port-channel is admin-down

Jan 25 11:19:31.943 AEST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan111, changed state to down

Jan 25 11:19:32.060 AEST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan111, changed state to up

Jan 25 11:19:33.210 AEST: %LINK-5-CHANGED: Interface GigabitEthernet2/0/1, changed state to administratively down

Jan 25 11:19:33.654 AEST: %LINK-5-CHANGED: Interface GigabitEthernet2/0/2, changed state to administratively down

Jan 25 11:19:34.216 AEST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/1, changed state to down

Jan 25 11:19:34.661 AEST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/2, changed state to down

in both 3750& 6509 switches' config I did not have "switchport trunk native vlan111"

just these lines below:

"interface Port-channel15

description IS port channel

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,103

switchport mode trunk"

New Member

port-channel issues


enable native vlan111 on both the SVI on both sides and it works beautifully.

Thanks all.

Very much appreciated

1087
Views
0
Helpful
6
Replies
CreatePlease login to create content