Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Port Channel - Not Connect Problem

I'm trying to setup a port channel from a 2960G to a 3750G and I'm getting (Not connect) on the 3750 when I do a sho int Po1 command.  It shows connected on the 2960.  When I do a sho eth sum on each device things look good both ends show that they are bundled.  One difference I see when comparing the sho int po1 on the devices is that the 3750 shows a "Media-type configured as a connector"  see sho int command below.  Could this be the cause of the no connection on the port channel?  I know the cable is good because the uplink works fine when its not port channelled. Its only when I port channel the interface that connection is lost.  Both ends are running in access mode servicing one vlan.  Any ideas?  I've done many port channels and never come accros this one.  Thanks!

Port-channel1 is down, line protocol is down (notconnect)
  Hardware is EtherChannel, address is 000e.d753.f983 (bia 000e.d753.f983)
  Description: etherchannel to CORP-SW3-2960G
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 1000Mb/s, link type is auto, media type is unknown
  Media-type configured as  connector
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:44:06, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec

22 REPLIES

Re: Port Channel - Not Connect Problem

Hi Chris

Can you revert back if you have any media-type command under there interface on any of the switches?

Also can you try using media-type sfp or rj45 based on the port/link you use to interconnect the switches.

regds

New Member

Re: Port Channel - Not Connect Problem

When I try the media-type command on the interconnect interface I get unsupported command.

I cant seem to find a way to negate the "Media-type configured as  connector"  When I do a sho int for any interface on the 3750  it shows them as configured as a connector .

Re: Port Channel - Not Connect Problem

How many Etherchannels do you currently have configured on the 2960?

Also could you post the configs?

Mike

Re: Port Channel - Not Connect Problem

Also what is the IOS on each?

Mike

New Member

Re: Port Channel - Not Connect Problem

3750G IOS-  (C3750-IPSERVICESK9-M), Version 12.2(25)SEE4

2960G IOS- (C2960-LANBASEK9-M), Version 12.2(44)SE6

New Member

Re: Port Channel - Not Connect Problem

Only one etherchannel on the 2960, which is trying to connect to 3750.  It shows connected on the 2960, but not connect on the 3750.  Status of (P) on both ends with the sho eth sum

Here's the 3750G config:

sho ru
Building configuration..

Current configuration : 22234 bytes
!
! Last configuration change at 12:16:41 PST Mon May 17 2010
! NVRAM config last updated at 11:42:30 PST Thu May 13 2010
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname core-48
!
enable secret 5 $1$wYaK$NyCPlhuUZJrEjpiLXOU6U/
!
username admin privilege 15 secret 5 $1$BhxN$Z4kpzXzAx8HKDcvNlIaM90
no aaa new-model
clock timezone PST -8
switch 1 provision ws-c3750g-24t
switch 2 provision ws-c3750g-24t
switch 3 provision ws-c3750g-24t
--More--                           switch 4 provision ws-c3750g-24t
switch 5 provision ws-c3750g-48ts
ip subnet-zero
ip routing
ip cef load-sharing algorithm universal E6984C2C
!
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
--More--                           mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
--More--                           mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
!
!
port-channel load-balance src-dst-ip
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface Port-channel1
description etherchannel to CORP-SW3-2960G
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet1/0/1
--description 10.1 Riverbed
speed 1000
duplex full
!
interface GigabitEthernet1/0/2
description .1
switchport mode access
!
interface GigabitEthernet1/0/3
switchport access vlan 4
switchport mode access
channel-group 1 mode desirable
!
interface GigabitEthernet1/0/4
description .5
switchport access vlan 5
switchport mode access
!
interface GigabitEthernet1/0/5
description .5
switchport access vlan 5
switchport mode access
!
--More--                           interface GigabitEthernet1/0/6
description .5
switchport access vlan 5
switchport mode access
!
interface GigabitEthernet1/0/7
description .5
switchport access vlan 5
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/8
description .5
switchport access vlan 5
switchport mode access
!
interface GigabitEthernet1/0/9
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/10
switchport access vlan 2
switchport mode access
--More--                           !
interface GigabitEthernet1/0/11
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/12
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/13
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/14
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/15
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/16
switchport access vlan 2
--More--                            switchport mode access
!
interface GigabitEthernet1/0/17
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/18
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/19
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/20
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/21
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/22
--More--                            switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/23
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/24
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/1
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/2
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/3
description LINK TO CORP-SW3-2960G
switchport access vlan 4
switchport trunk encapsulation dot1q
--More--                            switchport trunk native vlan 4
switchport mode trunk
shutdown
spanning-tree link-type point-to-point
!
interface GigabitEthernet2/0/4
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/5
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/6
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/7
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/8
switchport access vlan 2
--More--                            switchport mode access
!
interface GigabitEthernet2/0/9
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/10
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/11
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/12
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/13
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/14
--More--                            switchport access vlan 2
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet2/0/15
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/16
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/17
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/18
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/19
switchport access vlan 2
--More--                            switchport mode access
!
interface GigabitEthernet2/0/20
description BCWCK27
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/21
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/22
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/23
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet2/0/24
switchport access vlan 2
switchport mode access
!
interface Vlan1
ip address 172.17.10.1 255.255.255.0
!
interface Vlan2
ip address 172.17.2.1 255.255.255.0
!
interface Vlan3
ip address 172.17.3.1 255.255.255.0
ip helper-address 172.17.2.6
!
interface Vlan4
ip address 172.17.4.1 255.255.255.0
ip helper-address 172.17.2.6
!
interface Vlan5
ip address 172.17.5.1 255.255.255.0
ip helper-address 172.17.2.6
!
interface Vlan7
ip address 172.17.8.1 255.255.255.0 secondary
ip address 172.17.7.1 255.255.255.0
!
interface Vlan8
--More--                            no ip address
!
interface Vlan10
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.10.4
ip http server
ip http authentication local
ip http secure-server
!
!
snmp-server community brwncald RW
snmp-server location Walnut Creek
!
control-plane
!
!
line con 0
line vty 0 4
password xxxxxx
login
--More--                            length 0
line vty 5 15
password xxxxxx
login
!
!
monitor session 1 source interface Gi1/0/1
monitor session 2 source interface Gi5/0/34
monitor session 2 destination interface Gi5/0/35
ntp clock-period 36029514
ntp server 172.17.2.63 key 0 prefer
end

HERE's the 2960G config

sho ru
Building configuration...

Current configuration : 6640 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CORP-SW3-2960G
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$BKsn$B0K33PZ2xP1Q4BCwQljCd/
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
crypto pki trustpoint TP-self-signed-1443897600
--More--                            enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1443897600
revocation-check none
rsakeypair TP-self-signed-1443897600
!
!
crypto pki certificate chain TP-self-signed-1443897600
certificate self-signed 01
  30820247 308201B0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31343433 38393736 3030301E 170D3933 30333031 30303032
  31375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 34343338
  39373630 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100CF3D 68DE3B2F 79E74662 D1684547 07336824 47861B32 83DCE113 049FD21C
  490B66AA 4935B1A6 AA9AABD6 DFFCF894 995A6CDE 22DC9DD7 9F8085CD 8513EC73
  E9AAF7A7 4D33F8A2 37EBB27F 67C68326 7EC5C0BD 8C474984 BA3B0344 71245842
  44FAF6E0 5D3A59C5 773C7D40 4C7E896E 397C75D5 E8E804D9 D672CF18 5DE30F3D
  1F4B0203 010001A3 6F306D30 0F060355 1D130101 FF040530 030101FF 301A0603
  551D1104 13301182 0F434F52 502D5357 332D3239 3630472E 301F0603 551D2304
  18301680 1437C99C 442FCD1F 292C3506 4C346F64 968DCB5D 82301D06 03551D0E
  04160414 37C99C44 2FCD1F29 2C35064C 346F6496 8DCB5D82 300D0609 2A864886
  F70D0101 04050003 8181004F ACE7B9B5 CEFA3E65 DA2A8B36 FD858508 67C7D64F
--More--                             3A972070 6C96A256 BD2C4DA7 4F79C536 9A54EEEF 09898B00 264DF878 64085D83
  69BFE32F ABF572ED 309CCD0D 02890F12 0FC7EDE0 F02E37A3 412A1201 E821DC6A
  7930AB85 E60EC46F EAB6C815 62C7B671 F7A51F9C 46D07E67 A0BBB29C 22E2E012
  BD5BE82C F72DD9F4 FC21E4
  quit
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface Port-channel1
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/1
description UPLINK TO WCK CORE
--More--                            switchport access vlan 4
switchport mode access
shutdown
spanning-tree link-type point-to-point
!
interface GigabitEthernet0/2
description UPLINK TO WCK CORE
switchport access vlan 4
switchport mode access
channel-group 1 mode desirable
spanning-tree link-type point-to-point
!
interface GigabitEthernet0/3
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/4
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/5
switchport access vlan 4
switchport mode access
--More--                           !
interface GigabitEthernet0/6
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/7
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/8
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/9
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/10
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/11
switchport access vlan 4
--More--                            switchport mode access
!
interface GigabitEthernet0/12
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/13
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/14
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/15
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/16
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/17
--More--                            switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/18
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/19
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/20
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/21
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/22
switchport access vlan 4
switchport mode access
!
--More--                           interface GigabitEthernet0/23
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/24
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/25
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/26
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/27
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/28
switchport access vlan 4
switchport mode access
--More--                           !
interface GigabitEthernet0/29
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/30
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/31
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/32
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/33
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/34
switchport access vlan 4
--More--                            switchport mode access
!
interface GigabitEthernet0/35
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/36
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/37
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/38
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/39
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/40
--More--                            switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/41
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/42
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/43
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/44
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/45
switchport access vlan 4
switchport mode access
!
--More--                           interface GigabitEthernet0/46
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/47
switchport access vlan 4
switchport mode access
!
interface GigabitEthernet0/48
switchport access vlan 4
switchport mode access
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan4
ip address 172.17.4.14 255.255.255.0
no ip route-cache
!
ip default-gateway 172.17.4.1
ip http server
--More--                           ip http secure-server
snmp-server community brwncald RO
!
control-plane
!
!
line con 0
line vty 0 4
password xxxxxx
login
line vty 5 15
password xxxxxx
login
!
end

Also- the sho eth sum -
Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------
1      Po1(SU)         PAgP      Gi1/0/3(P)

Re: Port Channel - Not Connect Problem

Also can you post the IOS versions for both. The 2960 needs to be 12.2(25)FX or later to support etherchannels.

Mike

Re: Port Channel - Not Connect Problem

You could try this config.....please verify the ports as the ones you want to use.

interface Port-channel1
description etherchannel to CORP-SW3-2960G
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no shut


interface GigabitEthernet1/0/3
description Ether-Channel to Core
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
no shut

interface GigabitEthernet2/0/3
description Ether-Channel to Core
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
no shut

************************************************************

interface Port-channel1
description 4th Floor EtherChannel
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no shut


interface GigabitEthernet0/1
description UPLINK TO WCK CORE
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
no shut

interface GigabitEthernet2/3/37
description UPLINK TO WCK CORE
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
no shut

Mike

Re: Port Channel - Not Connect Problem

Sorry the previous post was for trunked ports, while you can do it that way here is the way you had it so you can try this and see how it works for you.

interface Port-channel1
description etherchannel to CORP-SW3-2960G
switchport
switchport mode access
switchport access vlan 4
no shut


interface GigabitEthernet1/0/3
description Ether-Channel to Core
switchport
switchport mode access
switchport access vlan 4
channel-group 1 mode on
no shut

interface GigabitEthernet2/0/3
description Ether-Channel to Core
switchport
switchport mode access
switchport access vlan 4
channel-group 1 mode on
no shut

************************************************************

interface Port-channel1
description 4th Floor EtherChannel
switchport
switchport mode access
switchport access vlan 4
no shut


interface GigabitEthernet0/1
description UPLINK TO WCK CORE
description Ether-Channel to Core
switchport
switchport mode access
switchport access vlan 4
channel-group 1 mode on
no shut

interface GigabitEthernet2/3/37
description UPLINK TO WCK CORE
description Ether-Channel to Core
switchport
switchport mode access
switchport access vlan 4
channel-group 1 mode on
no shut

Thanks

Mike

New Member

Re: Port Channel - Not Connect Problem

Thanks, I tried them both....still showing down down, not connect on the port channel.  Also tried removing the port channel completely and re-creating it..no luck.

Re: Port Channel - Not Connect Problem

Hey,

Can you provide the show int po1 command ouput from the C2960 as well.


Regards,

Rajeev Sharma.

New Member

Re: Port Channel - Not Connect Problem

Hi

Try to hardcode the speed/duplex setting at both the end make sure that there is no span port

New Member

Re: Port Channel - Not Connect Problem

I hard coded the duplex and speed and still showing (not connect) on the port channel interface on the 3750G

New Member

Re: Port Channel - Not Connect Problem

Hi,

Here is the out for sho int po1 on the downstream 2960G:

sho int po1
Port-channel1 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 0021.5610.2102 (bia 0021.5610.2102)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is unknown
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Gi0/2
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     45904 packets input, 4925709 bytes, 0 no buffer
     Received 14391 broadcasts (14368 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 14368 multicast, 0 pause input
     0 input packets with dribble condition detected
--More--                                203253 packets output, 15082759 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
CORP-SW3-2960G#

New Member

Re: Port Channel - Not Connect Problem

I see a lot of responses to your question.  I saw in your last show interface that you didn't have to members in your output.  An example of one of my channels (I cut out the non important part to save space. 

Port-channel2 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 001b.d5a2.2d87 (bia 001b.d5a2.2d87)
  Description: to 3-TC1A-6509-1
  MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,  <-------------Note bandwidth
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is unknown
  input flow-control is off, output flow-control is off
  Members in this channel: Gi3/24 Gi5/2   <---------------Note members in the channel

I have lots of port channels configured (3750's, 4948's, and 6500's).    If I was at the console of your devices I would enter as follows:

int range g0/1 , g2/3/37

no channel-group 1 mode on

exit

no int po1


default interface range g0/1 , g2/3/37

We now have the ports cleared.  It only takes a few commands to clear and start from scratch.  Notepad helps.  Time to setup the channel:

int po1

description UPLINK TO WCK CORE

switchport
switchport trunk encapsulation dot1q
switchport mode trunk

shut

"Don't unshut the ports until your channels are setup"


interface GigabitEthernet0/1
description UPLINK TO WCK CORE
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable

shut

interface GigabitEthernet2/3/37
description UPLINK TO WCK CORE
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
shut

int po1

no shut

You can cut and past the commands into the device.  Once the channel is up, you no longer make interface changes on the individual ports, only on the channel port (int po1).  You see above that I didn't "no shut" the individual ports.  Only the "int po1"  With spanning tree, trunk links can play havoc on the network.  I always prune my trunk links to allow only vlans needed across.  Let me know of any questions that you might have.  Make sure the setup is similar on the  other side of the connection.

New Member

Re: Port Channel - Not Connect Problem

Thanks for the reply.  I mirrored your config and I'm still getting down, down, (not connect) on the upstream switch...what do you think about the media-type configured as a connector statement below?  It's the only difference I see when comparing my working etherchannels to this one.  Any way to get rid of that statement?

*Forgot to mention that I started from scratch and kept the po channel down until the interfaces were setup.

Port-channel1 is down, line protocol is down (notconnect)
  Hardware is EtherChannel, address is 000e.d753.f983 (bia 000e.d753.f983)
  Description: UPLINK TO WCK CORE
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 7/255, rxload 5/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 1000Mb/s, link type is auto, media type is unknown
  Media-type configured as  connector

New Member

Re: Port Channel - Not Connect Problem

Media type as connector usually refers to a shared port (can be 10/100/1000 or SFP).  That means the port needs a "media type command".   Is one of the ports being used a shared port?  Can you send a "show int status" on the 2960G Model.  Also when you turn up the port channel are there any log entriies?  Also what is the specific switch model number.  A show version will give it.

From your configs I get this:

Your 3750 on one side of the connection

g1/0/1 = channel group 1

g1/0/3  = channel group 1

Your 2960G on the other side of the connection

g0/1 = channel group 1

g2/3/37 = channel group 1 <---------- I am not familiar with this port designation

I see your configuration for g2/3/37 in the posts, but don't see it in the 2960G config posted above.

Can I get a show run int g2/3/37

Douglas

New Member

Re: Port Channel - Not Connect Problem

No shared port on the 3750G.  I did notice the 2960G has dual purpose ports, but those are ports 45-48.

Every port on the 3750G shows up as "configured as a connector"  The media-type command is unrecognized on the interfaces or while in global config mode.

Here's the sho int stat on the 2960G:

CORP-SW3-2960G#sho int stat
Interface Vlan1 is disabled

Vlan4
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor       1905     158687        131       9743
             Route cache          0          0          0          0
                   Total       1905     158687        131       9743
GigabitEthernet0/1
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor          0          0          0          0
             Route cache          0          0          0          0
                   Total          0          0          0          0
GigabitEthernet0/2
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor          0          0      51221    5583967
             Route cache          0          0          0          0
                   Total          0          0      51221    5583967

The sho int status on the 3750G looks much different:

core-48#sho int status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi1/0/1   10.1 Riverbed      connected    1            full   1000 10/100/1000Ba
seTX
Gi1/0/2   .1                 connected    1          a-full a-1000 10/100/1000Ba
seTX
Gi1/0/3                      connected    trunk      a-full a-1000 10/100/1000Ba

Here's the current port channel members and the config is the same for all the below members.

interface GigabitEthernet1/0/3

switchport trunk encapsulation dot1q
switchport mode trunk
channel-group  1 mode desirable

On the 2960G Side-  ports Gig0/1 and gig0/2 are members of channel-group 1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------

1      Po1(SU)         PAgP      Gi0/1(P)    Gi0/2(P)

On the 3750G side-   ports Gig1/0/3 and  gig3/0/11 are members of channel-group 1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+------------------------------------------------
1      Po1(SU)         PAgP      Gi1/0/3(P)   Gi3/0/11(P)

I've also tried port channel modes active, on, auto and cant get the line protocol up on the 3750G....very odd.  They bundle fine but no connection on po1.

New Member

Re: Port Channel - Not Connect Problem

I don't have any 2960 switches at work.  I do have one that a bought used on ebay.  I haven't even booted it up yet.  I do have 250 Cisco 3750's in service at work.  So lets check the configs for each port.  This shouldn't be too difficult. I have your configs.  I will play with them in the morning when I get to work.   How far are the devices from each other?   Can you get link on each of the ports?  Which port physically connects to the other?  I will respond as often as possible.

3750

show run int g1/0/1

show run int g1/0/3

show run int po1

2960

show run int g0/1

show run int g0/2

show run int po1

Re: Port Channel - Not Connect Problem

I don't know why this did not click with me earlier. The PAgP is not supported for cross-stack EtherChannels. I notice that you have one link on the first switch in the stack and one on the third switch. Try putting them both on the same switch in the stack.

This is from the Cisco website.....

*********************************************************************************

For cross-stack EtherChannel configurations, ensure that all ports targeted for the EtherChannel are either configured for LACP or are manually configured to be in the channel group using the channel-group channel-group-number mode on interface configuration command. The PAgP protocol is not supported on cross- stack EtherChannels.

*********************************************************************************

Mike

New Member

Re: Port Channel - Not Connect Problem

The port channel is up and connected.  The change I made was creating po6 and re-assigning the appropriate switch ports to it. .  Not sure why the 3750G didn't like port channel 1. 

New Member

Re: Port Channel - Not Connect Problem

Glad to see that you got it working.

11016
Views
0
Helpful
22
Replies
CreatePlease to create content