Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Port-Channel (suspended) status

I have two VSS 6500 installations one set of 6503 as core router/switch and a pair of 6509 as collasped distribution. the core VSS I have 5 etherchannels configured in variouse configuration some are "on" some are desirable and LACP.

I am trying to add another port channel beteen to pairs of VSS they are both running same code just as teh otehr 6500 with etherchannels already in place.

I have configured the IP's and vlan's correctly everthing works fine I can ping, my routes are being found via EIGRP. this of course is with out addting the physical interface into teh port-chanel.

I shut down tthe physical interface (one per VSS) . I default the physical interface and I create my Port-c:

!

interface Port-channel16

switchport

switchport trunk allowed vlan 182

switchport mode trunk

shutdown

end

It's a simple configuration, the portchannel on the other VSS interface is the exact same configuration.

I then configure the physicla ports on each VSS as follows:

Core VSS:

interface GigabitEthernet1/2/17

switchport

channel-group 16 mode active

no shut

end

Distribution VSS:

interface g 1/5/1

channel-group 16 mode active

no shut

end

Of course interface remain down until I bring up the portchannel.

as soon as I bring up teh port-channel ( i have bedug ethercha detail turned on) I see the below messages:

Core VSS:

Oct 31 16:24:29.776 PDT: SW1: FEC: pagp_switch_is_in_port_channel: Gi1/2/15 is part of agport

CORTUA2-LAMR-SWTH-01(config-if)#

*Oct 31 16:24:29.984 PDT: %EC-SW1-5-CANNOT_BUNDLE2: Gi1/2/17 is not compatible with Po16 and will be suspended (VLAN mask is different)

CORTUA2-LAMR-SWTH-01(config-if)#

*Oct 31 16:24:30.084 PDT: %EC-SW2_STBY-5-CANNOT_BUNDLE2: Gi1/2/17 is not compatible with Po16 and will be suspended (VLAN mask is different)

Distribution VSS: Error

*Oct 31 16:22:12.883 PDT: SW1: FEC: pagp_switch_is_in_port_channel: Te1/5/4 is part of agport

cortua2-lamr-sw24-VS(config-if)#

*Oct 31 16:22:15.131 PDT: %EC-SW1-5-CANNOT_BUNDLE2: Gi1/5/1 is not compatible with Po16 and will be suspended (VLAN mask is different)

cortua2-lamr-sw24-VS(config-if)#

*Oct 31 16:22:15.287 PDT: SW1: FEC: pagp_switch_is_in_port_channel: Te2/5/5 is part of agport

*Oct 31 16:22:16.063 PDT: SW1: FEC: pagp_switch_is_in_port_channel: Te2/5/4 is part of agport

cortua2-lamr-sw24-VS(config-if)#

*Oct 31 16:22:15.231 PDT: %EC-SW2_STBY-5-CANNOT_BUNDLE2: Gi1/5/1 is not compatible with Po16 and will be suspended (VLAN mask is different)

cortua2-lamr-sw24-VS(config-if)#

cortua2-lamr-sw24-VSS#sho ver

cortua2-lamr-sw24-VSS uptime is 3 hours, 41 minutes

Uptime for this control processor is 3 hours, 42 minutes

System returned to ROM by power on

System image file is "bootdisk:s2t54-advipservicesk9-mz.SPA.151-2.SY.bin"

Last reload reason: power-on

Core VSS: 

System image file is "bootdisk:s2t54-advipservicesk9-mz.SPA.151-1.SY.bin"

Last reload reason: Admin CLI

I don't belive it's an subnet mask because with being in the Port-channel the interfaces work just fine.

Distribution VSS Interface:

cortua2-lamr-sw24-VSS#sho int g 1/5/1

GigabitEthernet1/5/1 is up, line protocol is down (suspended)

  Hardware is C6k 1000Mb 802.3, address is a44c.1177.4254 (bia a44c.1177.4254)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 1000BaseLH

  input flow-control is off, output flow-control is off

  Clock mode is auto

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     126 packets input, 10244 bytes, 0 no buffer

     Received 22 broadcasts (21 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     126 packets output, 10460 bytes, 0 underruns

     0 output errors, 0 collisions, 3 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

Core VSS Interface:

GigabitEthernet1/2/17 is up, line protocol is down (suspended)

  Hardware is C6k 1000Mb 802.3, address is bc16.65e2.b1f8 (bia bc16.65e2.b1f8)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 1000BaseLH

  input flow-control is off, output flow-control is off

  Clock mode is auto

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 11w6d

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     461089 packets input, 37419535 bytes, 0 no buffer

     Received 460408 broadcasts (460347 multicasts)

     0 runts, 0 giants, 0 throttles

     3 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     755820 packets output, 84912050 bytes, 0 underruns

     0 output errors, 0 collisions, 34 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

Any suggestion any information that coud be useful...

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Port-Channel (suspended) status

I think the problem is the configuration of the physical port. You should add "switchport trunk allowed vlan 182" along with configuring each interface to as a trunk port since you have it configured on the port channel interface.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
3 REPLIES

Re: Port-Channel (suspended) status

I think the problem is the configuration of the physical port. You should add "switchport trunk allowed vlan 182" along with configuring each interface to as a trunk port since you have it configured on the port channel interface.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Green

Port-Channel (suspended) status

Gregory,

Can you try sorting out the dist switch interface as ensure layer 2

!

Distribution VSS:

interface g 1/5/1

switchport

channel-group 16 mode active

no shut

end

!

Then try bringing up the port channel again

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Purple

Re: Port-Channel (suspended) status

    To me it looks like port channel 16 was previously used on different ports  and is  still asigned to those ports and maybe has different parameters.  Check the port configs on the ones they are complaining about . Is port channel 16 on these ports and formerly running pagp (channel-group 16 mode desirable)  ?  If port channel 16 is on these ports clear it and bounce the port channel.  Check each side for ports in the channel with the show etherchannel sumary command , it should only show one port on each side .  If there is more than 1 thats your issue and check those other ports and remove them if need be.

Oct 31 16:22:15.287 PDT: SW1: FEC: pagp_switch_is_in_port_channel: Te2/5/5 is part of agport

*Oct 31 16:22:16.063 PDT: SW1: FEC: pagp_switch_is_in_port_channel: Te2/5/4 is part of agport

Also check this.  Does this port have port channel 16  on it from a previous config ?

*Oct 31 16:24:29.984 PDT: %EC-SW1-5-CANNOT_BUNDLE2: Gi1/2/17 is not  compatible with Po16 and will be suspended (VLAN mask is different)

CORTUA2-LAMR-SWTH-01(config-if)#

*Oct  31 16:24:30.084 PDT: %EC-SW2_STBY-5-CANNOT_BUNDLE2: Gi1/2/17 is not  compatible with Po16 and will be suspended (VLAN mask is different)

3480
Views
5
Helpful
3
Replies
CreatePlease to create content