Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Port-Channel to Trunk question(s) ?

I have a 4x1G ether channel between 2 6513's - I am running into issues with VLANs not passing. 6513A is the VTP server, and 6513B is in transparent mode. I happen to notice on 6513B the port-channel and its member phys interfaces are not set to trunk - i am assuming this could be part of the issue. This is a hospital and not an easy place to have downtime... anyone have advice/ideas on how to get the trunk setup with no downtime for devices/networks on 6513B ?

6513 A - all ports are in ether channel and set to trunk (CatOS - sup 2s, i know, i know)

6513 B - is sup 720s with the following config :

interface Port-channel1

switchport

no ip address

mls qos trust dscp

end

interface GigabitEthernet7/1

switchport

no ip address

mls qos trust dscp

channel-group 1 mode desirable non-silent

end

interface GigabitEthernet7/2

switchport

no ip address

mls qos trust dscp

channel-group 1 mode desirable non-silent

end

interface GigabitEthernet8/1

switchport

no ip address

mls qos trust dscp

channel-group 1 mode desirable non-silent

end

interface GigabitEthernet8/2

switchport

no ip address

mls qos trust dscp

channel-group 1 mode desirable non-silent

end

2 REPLIES

Port-Channel to Trunk question(s) ?

Josh,

You may be out of luck. I believe you're going to have to shut the port-channel down, make each interface in the channel-group a trunked port, and then bring the port-channel back up. I don't have a way of testing this at the moment, but I believe once you try to change one of the members of the channel, the channel will go down.

I set up gns to do this real quick. It was as I suspected that the channel will go down, so you'll want downtime scheduled:

Group Port-channel  Ports

-----+------------+-----------------------------------------------------------

1     Po1(SU)     Fa1/1(P)   Fa1/2(P)   Fa1/3(P)

R1(config-if-range)#swi

R1(config-if-range)#switchport mode trunk

R1(config-if-range)#

*Mar  1 00:03:19.463: %EC-5-UNBUNDLE: Interface Fa1/1 left the port-channel Po1

*Mar  1 00:03:19.483: %EC-5-CANNOT_BUNDLE2: Fa1/1 is not compatible with Fa1/2 and will be suspended (trunk mode of Fa1/1 is trunk, Fa1/2 is access)

*Mar  1 00:03:19.511: %EC-5-UNBUNDLE: Interface Fa1/2 left the port-channel Po1

*Mar  1 00:03:19.539: %EC-5-CANNOT_BUNDLE2: Fa1/2 is not compatible with Fa1/3 and will be suspended (trunk mode of Fa1/2 is trunk, Fa1/3 is access)

*Mar  1 00:03:19.559: %EC-5-UNBUNDLE: Interface Fa1/3 left the port-channel Po1

*Mar  1 00:03:19.559: %EC-5-CANNOT_BUNDLE2: Fa1/1 is not compatible with Po1 and will be suspended (trunk mode of Fa1/1 is trunk, Po1 is access)

*Mar  1 00:03:19.563: %EC-5-CANNOT_BUNDLE2: Fa1/2 is not compatible with Po1 and will be suspended (trunk mode of Fa1/2 is trunk, Po1 is access)

*Mar  1 00:03:19.563: %EC-5-CANNOT_BUNDLE2: Fa1/1 is not compatible with Po1 and will be suspended (trunk mode of Fa1/1 is trunk, Po1 is access)

*Mar  1 00:03:19.563: %EC-5-CANNOT_BUNDLE2: Fa1/2 is not compatible with Po1 and will be suspended (trunk mode of Fa1/2 is trunk, Po1 is access)

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Port-Channel to Trunk question(s) ?

Josh,

John is right - I work on a hospital as well and i know what you are saying in terms of downtime

switchport mode trunk is the command you need to run on the interfaces and port channel interface.

and then if you wanted to only allow specific VLANs "switchport trunk all VLAN ...." otherwise all VLANs are permitted by default

good luck and hopefully you get your outage window.

273
Views
9
Helpful
2
Replies
CreatePlease to create content