Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started.

New Member

Port channels on Nexus 7k 10G interfaces LACP if possible

Hello

 

I need to create a port-channel with (2) 10G interfaces on a Nexus 7010. This port channel

will connect to a Data Domain device. The Data Domain device will bundle 2 10G interfaces and give

it an ip address.

 

I am not too familiar with Nexus.

The vendor stated they would prefer LACP to round robin.


currently I have the interfaces as follows:

interface Ethernet8/45
description DataDomain EMC
switchport
switchport access vlan 804

spanning-tree port type edge
no shutdown

 

Can I just add channel-group x on each, lacp active and be done?

sMc
  • LAN Switching and Routing
2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Super Bronze

Hi,LACP is the only protocol

Hi,

LACP is the only protocol supported on Nexus series devices

Just add "channel-group 10 mode active" to your physical interfaces.

In this case the portchannel id is 10, but you can use any other number you want.

Once this config is done, go under the Portchannel interface and issue "no sh" to bring up the Portcahnnel interface.

interface Ethernet8/45
description DataDomain EMC
switchport
switchport access vlan 804

channel-group 10 mode active

spanning-tree port type edge
no shutdown

HTH

VIP Super Bronze

Hi Steve,Yes, since you have

Hi Steve,

Yes, since you have 2 Nexus devices, I would put both connections in the same VPC. The same config for both switches:

interface Ethernet8/45
description DataDomain EMC
switchport
switchport access vlan 804

channel-group 10 mode active

spanning-tree port type edge

vpc 10
no shutdown

HTH

14 REPLIES
VIP Super Bronze

Hi,LACP is the only protocol

Hi,

LACP is the only protocol supported on Nexus series devices

Just add "channel-group 10 mode active" to your physical interfaces.

In this case the portchannel id is 10, but you can use any other number you want.

Once this config is done, go under the Portchannel interface and issue "no sh" to bring up the Portcahnnel interface.

interface Ethernet8/45
description DataDomain EMC
switchport
switchport access vlan 804

channel-group 10 mode active

spanning-tree port type edge
no shutdown

HTH

New Member

How does vPC play into this

How does vPC play into this port-channel?

 

Each port-channel will have (2) 10G interfaces from different Nexus 7k switches.

 

what will that interface config look like?

 

sMc
VIP Super Bronze

The Portchannel will have one

The Portchannel will have one 10Gig interface to each 7k.  

In order for the VPC to work correctly, the 2 7ks need to be VPCed together also.

You can check that by issuing "sh vpc" on both 7ks.

Can you provide the output of "sh vpc" and "sh run vpc" from both 7ks?

HTH

 

New Member

I see it here is what config

I see it

 here is what config should look like, i think

 


PRODUCTION DataDomain device

A-Dist (7k) & B-Dist (7k)
interface Ethernet8/45
description DataDomainProd
switchport
switchport access vlan 804
channel-group 13 mode active
vpc 13
spanning-tree port type edge
no shutdown

A-Dist (7k) & B-Dist (7k)
interface Ethernet8/46
description DataDomainProd
switchport
switchport access vlan 804
channel-group 14 mode active
vpc 14
spanning-tree port type edge
no shutdown

 

Does this look correct?

sMc
VIP Super Bronze

Looks correct, except the VPC

Looks correct, except the VPC number for both 7ks should be the same, if the 7ks are VPCed together.

 

New Member

Reza I have (2) separate Data

Reza

 

I have (2) separate Data Domain devices 1) Prod  2). DR

I will be configuring (4) port-channels. Each pair of interfaces get's it's own vpn/portchannel #, yes?

sMc
VIP Super Bronze

Yes, if 7ks are 2 different

Yes, if 7ks are 2 different devices and not connected together via a VPC. Then each side get their own Portchannel.

New Member

7k's are connected via VPC

7k's are connected via VPC domain 1

I apologize for any confusion. Does the following look correct?

Switch-A
interface Ethernet8/46
description DataDomainProd
switchport
switchport access vlan 804
channel-group 14 mode active
vpc 14
spanning-tree port type edge
no shutdown

 

Switch-B

interface Ethernet8/46
description DataDomainProd
switchport
switchport access vlan 804
channel-group 14 mode active
vpc 14
spanning-tree port type edge
no shutdown

sMc
VIP Super Bronze

Yes, the config is correct

Yes, the config is correct now.

887
Views
0
Helpful
14
Replies