Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Port Channels - WLC 5508 and 4510

LACP and PAgP are not supported on the controller and it appears that the 4500 series will not use LAG.

interface Port-channel10
 description WLC Port-Channel
 switchport
 switchport mode trunk
 service-policy input AutoQos-4.0-Input-Policy
 service-policy output OUTPUT-PRIORITY-POLICING-ETHERCHANNEL

interface GigabitEthernet3/1

 description Cisco 5508 Wireless Controller 
 switchport mode trunk
 channel-group 10 mode active
 spanning-tree link-type point-to-point
!
interface GigabitEthernet3/2
 description Cisco 5508 Wireless Controller 
 switchport mode trunk
 channel-group 10 mode active
 spanning-tree link-type point-to-point

 

I am getting the error, "lacp not enabled on remote port..". I removed the 2nd fiber cable and removed the channel-group so I could get the WLC back online. Any help would be greatly appreciated. 

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

In order to get the ether

In order to get the ether channel to work with the WLC you need to change your configuration from:

 

!

interface GigabitEthernet3/1
 channel-group 10 mode active
!
interface GigabitEthernet3/2
 channel-group 10 mode active
 !

To mode ON

 

!

interface GigabitEthernet3/1
 channel-group 10 mode on
!
interface GigabitEthernet3/2
 channel-group 10 mode on
 !

 

Mode ON tells the switch to do Link Aggregation Protocol and does try and negotiate using one of the two control protocols LACP or PAgP.

 

using mode ON is part of the configuration guide when enabling Cisco WLC LAG option.

 

 

 

5 REPLIES
VIP Super Bronze

Both sides of the connection

Both sides of the connection have to support the same protocol.  In your case and as you noted the 5508 does not support link aggregation (Etherchannle), so it is not possible to configure it even though the 4500 supports it.

HTH

New Member

You need to go into the WLC

You need to go into the WLC and enable LAG in order for this to work.

You can do this from the command line by entering the following command:

config lag enable

or going into the GUI under:

Controller --> General and change LAG Mode one next reboot from disabled to enabled.

Ether of these settings require a reboot before they will take affect.

Also per design guide the channel-group should be configured with mode on instead of active.

Hope that helps.

 

 

New Member

Lag is enabled on the WLC.

Lag is enabled on the WLC. The function was working previously when connected to a 3750 switch. We just upgraded to a 4510 and get this error.

New Member

In order to get the ether

In order to get the ether channel to work with the WLC you need to change your configuration from:

 

!

interface GigabitEthernet3/1
 channel-group 10 mode active
!
interface GigabitEthernet3/2
 channel-group 10 mode active
 !

To mode ON

 

!

interface GigabitEthernet3/1
 channel-group 10 mode on
!
interface GigabitEthernet3/2
 channel-group 10 mode on
 !

 

Mode ON tells the switch to do Link Aggregation Protocol and does try and negotiate using one of the two control protocols LACP or PAgP.

 

using mode ON is part of the configuration guide when enabling Cisco WLC LAG option.

 

 

 

New Member

Here is the link to the

Here is the link to the configuration guide to that explains configuring LAG and why the switch needs to be set to mode ON.

http://www.cisco.com/c/en/us/td/docs/wireless/controller/7-0MR1/configuration/guide/wlc_cg70MR1/cg_ports_interfaces.html#21072

1544
Views
0
Helpful
5
Replies
CreatePlease to create content