Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
VIP Purple

Port-channelxx is down, line protocol is down (notconnect)

Hello Everyone, i tried to make it up but coudnt get suceed.

Here are the screenshot of configs:

RZ1XCF01#sh interface Port-channel28

Port-channel28 is down, line protocol is down (notconnect)

  Hardware is EtherChannel, address is 001b.d4f7.4e61 (bia 001b.d4f7.4e61)

  Description: *** Po28, 2 CU Etherchannel 11/29-11/30, CITSESX14 ***

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed

  input flow-control is off, output flow-control is off

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 02:35:55

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 4 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

-----------------------------------------------------------------------------------------------------------------------------------------------------------------

configs of the ports and port-channel

interface Port-channel28
description *** Po28, 2 CU Etherchannel 11/29-11/30, CITSESX14 ***
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4,10,11,18-21
switchport mode trunk
no ip address

interface GigabitEthernet11/29-------------------------------------------> up
description *** Gi11/29, CITSESX14, 10.18.20.124 ***
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4,10,11,18-21
switchport mode trunk
no ip address
no cdp enable
spanning-tree portfast trunk
spanning-tree bpdufilter enable
channel-group 28 mode active

!
interface GigabitEthernet11/30--------------------------------------------------> up
description *** Gi11/30, CITSESX14, 10.18.20.124 ***
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4,10,11,18-21
switchport mode trunk
no ip address
no cdp enable
spanning-tree portfast trunk
spanning-tree bpdufilter enable
channel-group 28 mode active

Can you please try to find out the problem..

Thanks

Everyone's tags (3)
3 REPLIES

Port-channelxx is down, line protocol is down (notconnect)

Hi

i dont know what switch this is, but there is no channel protocol defined on the interfaces, like for instance

channel-protocol lacp

New Member

Port-channelxx is down, line protocol is down (notconnect)

Hi Sandeep,

I guess by the description of the Port Channel this is a PO group to an ESX server?

In which case you will need different channel commands:

"channel-group 28 mode on"

By specfiying active in the channel-group commands your effectively turning LACP negotiation on then expecting ESX to respond  to this and form an LACP based channel.

Unfortuantely up until ESX / ESXi 5.x LACP isn't supported and no negotiation will happen.

However Static Trunking / EtherChannel is supported (IP Hash load-balancing in ESX) in combination with "mode on" static etherchannel.

Basically when you configured a channel-group with the "mode on" command you explictly force trunking without any channel-protocol negotation (PAgP or LACP).

Any questions let me know.

Dunc.

VIP Purple

Port-channelxx is down, line protocol is down (notconnect)

Hi DuncanM,

I willl try this tommorow and let you know.

I have to ask about the version of ESXi server from my colleauges..and then i can configure this command.

Thanks for the help.

Regards

Sandeep

4345
Views
0
Helpful
3
Replies
CreatePlease to create content