Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Port channnel error

                   Hi all,

I was trying to create port channel on 4507

I config 2 ports as trunk ports and ran this command

channel-group 10 mode active and got the error below

Command rejected (Port-channel10, Gi1/1): Either port is L2 and port-channel is

L3

Command rejected (Port-channel10, Gi1/1): Either port is L2 and port-channel is

L3

Can someone please tell me about this error and how to fix it?

Thnaks

MAhesh

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Port channnel error

Hi Mahesh,

Try these command under each interface:

Switch(config)# interface range fastethernet 5/4 - 5 (Note: Space is mandatory.)

Switch(config-if)# no switchport 

Switch(config-if)# no ip address 

Switch(config-if)# channel-group 1 mode desirable 

Switch(config-if)# end 

config guide:

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/54sg/configuration/guide/channel.html

HTH

5 REPLIES
VIP Super Bronze

Port channnel error

Hi Mahesh,

Try these command under each interface:

Switch(config)# interface range fastethernet 5/4 - 5 (Note: Space is mandatory.)

Switch(config-if)# no switchport 

Switch(config-if)# no ip address 

Switch(config-if)# channel-group 1 mode desirable 

Switch(config-if)# end 

config guide:

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/54sg/configuration/guide/channel.html

HTH

New Member

Port channnel error

Hi Reza,

Many thanks again

Regards

MAhesh

VIP Super Bronze

Re: Port channnel error

Hi Mahesh.

What was the issue?

Thanks for the rating

Reza

Sent from Cisco Technical Support iPhone App

New Member

Port channnel error

Hi Reza,

I was trying to create port channel between 3560 and 4507  .

on 3560 i did

int port-channel 10

switchport mode trunk

int gi0/1 and gi0/2

switchport mode trunk

channel-group 10 mode active

&&&&&&&&&&&&&&&&&&&&&&&&&

4507

int gi0/1  and gi0/2

switchport mode trunk

whenever i type command channel-group 10 mode active  it gave me error as i told earlier

as soon as i did

no switchport

no ip address  it worked ok.

now both ports are in portchannel.

So this was the issue.

Seems on 4507 we need to create  either layer 2 or layer 2 port channel.

when i type no switchport then on 4507 the port channel changed to type  layer 3.

Thanks

MAhesh

VIP Super Bronze

Port channnel error

Hi Mahesh,

Thanks for the update!

Reza

280
Views
0
Helpful
5
Replies
CreatePlease to create content