Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Port Forwarding to second interface on a Cisco 1841

If any of you have time and wouldn't you mind helping me with a cisco 1841 router, I would greatly appreciate it. I need to forward ports 80, 443, 22 to the secondary inside address.

Some background info:

We use ATT for AVPN connectivity.

The T1 comes in on Serial 0/0/0 from remote Datacenter's edge router (AVPN)

The schools internal network is on Fe 0/0 (IP 10.30.58.1/24) this is the IP I use to manage the router

The server I am trying to port forward to is on Fe0/1 (192.168.45.1) the server’s IP is 192.168.45.50

Thank you.

Everyone's tags (3)
3 REPLIES
Silver

Port Forwarding to second interface on a Cisco 1841

analyzing your IP its a private address connected both in your router.... so therefore you dont need port forwarding. what you need is routing from one interface to another. since it is connected to only one router by default router routes a packets from one interface to another. Port Forwarding example:

Datacenter/WAN IP ex: 1.1.1.1

Server IP: 192.168.45.50

Port forward syntax: Router(config)#ip nat inside source static tcp 192.168.45.50 80 1.1.1.1 80 extended

---

Posted by WebUser Randy Llandelar from Cisco Support Community App

New Member

Port Forwarding to second interface on a Cisco 1841

I will test and let you know. Thank you for the reply.

New Member

Port Forwarding to second interface on a Cisco 1841

Sorry it did not work. I placed a static rout entry at the DC. and addedd the nat info as stated. If it helps here is part of the router config.

!

!

interface Loopback0

ip address 192.168.165.165 255.255.255.255

!

interface FastEthernet0/0                                !!!!!!!!!!!!! Internal network  !!!!!!!!!!!!!  I manage the router on this interface  !!!!

ip address 10.30.58.1 255.255.255.0

ip helper-address 10.250.1.5

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1                            !!!!!!!!!!!!!!  Server I am tring to forward to  !!!!!!!!!!!!!!!!

description LAN

ip address 192.168.43.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface Serial0/0/0                                          !!!!!!!   AVPN from datacenter  !!!!!!!!!!!!!!!!!!!!

description T1 PPP Port DHEC.969609.ATI

ip address 192.168.165.1 255.255.255.252

encapsulation ppp

no peer neighbor-route

service-module t1 timeslots 1-24

no cdp enable

!

ip classless

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

ip route 0.0.0.0 0.0.0.0 192.168.165.2

!

no ip http server

!

dialer-list 1 protocol ip permit

831
Views
0
Helpful
3
Replies
CreatePlease login to create content