Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Portchannel between ASR1001 & 3750G down

Hi,

We have an annoying issue that has happened twice now in the past couple of months. We are using a Cisco ASR1001 for our WAN connection to 2 remote sites.

From the ASR we have a 2 port etherchannel using LACP into our switch (Cisco 3750G). Twice now, the etherchannel has gone down, the interfaces were up but line protocol down.

The first time I consoled into the device and got halfway through typing a couple of show commands and the portchannel interface came up again by itself.

The second time, I tried shut/no shut on both the router and switch and got nothing. I reloaded the router and the portchannel came back up straight away.

The ASR is running:

Cisco IOS XE Software, Version 03.11.00.S – Standard Support Release
Cisco IOS Software, ASR1000 Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 15.4(1)S, RELEASE SOFTWARE (fc2)

And the 3750 is running

Cisco IOS Software, C3750 Software (C3750-IPBASE-M), Version 12.2(35)SE5, RELEASE SOFTWARE (fc1)

Here is the config on the ASR

interface Port-channel3
ip address X.X.X.X 255.255.255.0
negotiation auto

interface GigabitEthernet0/0/2
no ip address
negotiation auto
channel-group 3 mode active

interface GigabitEthernet0/0/3
no ip address
negotiation auto
channel-group 3 mode active

The config on the 3750 is:

interface Port-channel3
!

interface GigabitEthernet1/0/6
description WAN – TO ASR1001
channel-group 3 mode active
spanning-tree portfast
!

interface GigabitEthernet1/0/7
description WAN – TO ASR1001
channel-group 3 mode active
spanning-tree portfast

Has anyone run into anything similar or have any idea's on what could be causing it? Thanks

11 REPLIES
VIP Super Bronze

Hi,Have you tried hard

Hi,

Have you tried hard setting the ports to Gig?

speed 1000

duplex full

HTH

 

New Member

For us it was the version of

For us it was the version of IOS we were running on the ASR. TAC identified a bug. Once we upgraded, we did not experience any further issues.

New Member

Hi empsonmatthew, Can you

Hi empsonmatthew,

 

Can you share the bug ID ? If not, could you at least tell us affected version and fixed one?

Thanks,

Andrei

New Member

CSCul35389 was the bug ID

CSCul35389 was the bug ID which was first resolved in 15.4(1)S1.

 

TAC advised us that 3.13.2S/15.4(3)S2 is the Cisco suggested release at the time. Haven't had an issue since.

New Member

It happened again, although

It happened again, although ports were forced in Speed & Duplex.

I've just upgraded the IOS, hope it solves the problem.

@ empsonmatthew,

where did you get those messages from ?

i found the tracelogs/IOSCC_0-0.log.25219.**** logs filled with Pending connection to server, but nothing else.

 

Thank you,

Andrei Anghel

New Member

All logs we collected were

All logs we collected were sent to TAC. Didn't look at them myself sorry.

Hi,There are some

Hi,

There are some requirements when using ether channel, like all physical interfaces have to have same duplex and speed, being in the same vlan and none of them can be a span port.

Regards,

Aref

New Member

Thanks guys, I will try hard

Thanks guys, I will try hard coding speed and duplex. Would it be advisable to remove 'spanning-tree portfast' as well from the switch ports? I think thats just a bit of left over old config.

VIP Super Bronze

Usually Portfast is for end

Usually Portfast is for end devices, as they connect and disconnect from the network often and not between switches. I would remove it.

HTH

You are welcome. Portfast

You are welcome. Portfast should be configured on all switch ports where there is no need for listening and learning state (no bpdus exchanged on those ports), in other words where the port has to be set immediately in forwarding state.

Regards,

Aref

New Member

It happened to me also. I

It happened to me also. I have solved it by harcoding speed and duplex on physical interfaces and port-channels on both sides. Since then , Port-Channel is up & running.

 

279
Views
0
Helpful
11
Replies