Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Portchannel Trouble

Hi All

I am doing my CCNP certification I was configuring portchannels on GNS3 router with SW interface. some interface shows down. I checked ports is configure fine and mode is on on all interfaces but when ever I check in sh etherchannel summay it show some interface are down . how to resolve this issue plese guide me thanks.

i am getting this error

Switch 1 Config

NL_B1_SW1#sh etherchannel  summary

Flags:  D - down        P - in port-channel

        I - stand-alone s - suspended

        R - Layer3      S - Layer2

        U - in use

Group Port-channel  Ports

-----+------------+-----------------------------------------------------------

1     Po1(SU)     Fa1/0(D)   Fa1/1(P)

2     Po2(SU)     Fa1/2(P)   Fa1/3(P)

Switch 2 Config

NL_B1_SW2#sh etherchannel summary

Flags:  D - down        P - in port-channel

        I - stand-alone s - suspended

        R - Layer3      S - Layer2

        U - in use

Group Port-channel  Ports

-----+------------+-----------------------------------------------------------

1     Po1(SU)     Fa1/0(D)   Fa1/1(P)

Switch 3 Config

NL_B1_SW3#sh etherchannel summary

Flags:  D - down        P - in port-channel

        I - stand-alone s - suspended

        R - Layer3      S - Layer2

        U - in use

Group Port-channel  Ports

-----+------------+-----------------------------------------------------------

1     Po1(SD)     Fa1/0(D)   Fa1/1(D)

11 REPLIES
VIP Super Bronze

Portchannel Trouble

Can you post your configs?

New Member

Portchannel Trouble

For Switch 1 Config

Building configuration...

Current configuration : 125 bytes

!

interface Port-channel1

switchport trunk allowed vlan 1,64,66,68,69,71,1002-1005

switchport mode trunk

duplex full

end

NL_B1_SW1#sh confi

NL_B1_SW1#sh configuration

Using 2361 out of 155640 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname NL_B1_SW1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$GfK6$XK/fHlJKoZnnGDabSMmuU1

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

ip domain name nuggetlabs.com

ip name-server 4.2.2.2

ip name-server 4.2.2.3

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

vtp file nvram:vlan.dat

username admin secret 5 $1$RxI8$o4F82juKyDQ1w.5HM6Mqv0

!

!

ip ssh version 2

!

!

!

!

!

interface Port-channel1

switchport trunk allowed vlan 1,64,66,68,69,71,1002-1005

switchport mode trunk

duplex full

!

interface Port-channel2

switchport trunk allowed vlan 1,64,66,68,69,71,1002-1005

switchport mode trunk

duplex full

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1/0

switchport trunk allowed vlan 1,64,66,68,69,71,1002-1005

switchport mode trunk

duplex full

channel-group 1 mode on

!

interface FastEthernet1/1

switchport trunk allowed vlan 1,64,66,68,69,71,1002-1005

switchport mode trunk

duplex full

channel-group 1 mode on

!

interface FastEthernet1/2

switchport trunk allowed vlan 1,64,66,68,69,71,1002-1005

switchport mode trunk

duplex full

channel-group 2 mode on

!

interface FastEthernet1/3

switchport trunk allowed vlan 1,64,66,68,69,71,1002-1005

switchport mode trunk

duplex full

channel-group 2 mode on

!

interface FastEthernet1/4

!

interface FastEthernet1/5

!

interface FastEthernet1/6

!

interface FastEthernet1/7

!

interface FastEthernet1/8

!

interface FastEthernet1/9

!

interface FastEthernet1/10

!

interface FastEthernet1/11

!

interface FastEthernet1/12

!

interface FastEthernet1/13

!

interface FastEthernet1/14

!

interface FastEthernet1/15

!

interface Vlan1

no ip address

shutdown

!

interface Vlan71

ip address 10.1.71.1 255.255.255.0

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

!

mgcp behavior g729-variants static-pt

!

!

!

!

!

banner motd ^CC

****************

DO NOT LOGIN

****************

^C

!

line con 0

exec-timeout 180 0

password cisco

logging synchronous

line aux 0

line vty 0 4

password cisco

login local

!

ntp server 64.73.32.135

!

end

For Switch 2 Config

Using 1626 out of 155640 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname NL_B1_SW2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

vtp file nvram:vlan.dat

!

!

!

!

!

!

!

interface Port-channel1

switchport trunk allowed vlan 1,64,66,69,71,1002-1005

switchport mode trunk

duplex full

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1/0

switchport trunk allowed vlan 1,64,66,69,71,1002-1005

switchport mode trunk

duplex full

channel-group 1 mode on

!

interface FastEthernet1/1

switchport trunk allowed vlan 1,64,66,69,71,1002-1005

switchport mode trunk

duplex full

channel-group 1 mode on

!

interface FastEthernet1/2

!

interface FastEthernet1/3

!

interface FastEthernet1/4

!

interface FastEthernet1/5

!

interface FastEthernet1/6

!

interface FastEthernet1/7

!

interface FastEthernet1/8

!

interface FastEthernet1/9

!

interface FastEthernet1/10

!

interface FastEthernet1/11

!

interface FastEthernet1/12

!

interface FastEthernet1/13

!

interface FastEthernet1/14

!

interface FastEthernet1/15

!

interface Vlan1

no ip address

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

!

mgcp behavior g729-variants static-pt

!

!

!

!

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

login

!

!

end

For Switch 3 Config

Using 1626 out of 155640 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname NL_B1_SW3

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

vtp file nvram:vlan.dat

!

!

!

!

!

!

!

interface Port-channel1

switchport trunk allowed vlan 1,64,66,69,71,1002-1005

switchport mode trunk

duplex full

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1/0

switchport trunk allowed vlan 1,64,66,69,71,1002-1005

switchport mode trunk

duplex full

channel-group 1 mode on

!

interface FastEthernet1/1

switchport trunk allowed vlan 1,64,66,69,71,1002-1005

switchport mode trunk

duplex full

channel-group 1 mode on

!

interface FastEthernet1/2

!

interface FastEthernet1/3

!

interface FastEthernet1/4

!

interface FastEthernet1/5

!

interface FastEthernet1/6

!

interface FastEthernet1/7

!

interface FastEthernet1/8

!

interface FastEthernet1/9

!

interface FastEthernet1/10

!

interface FastEthernet1/11

!

interface FastEthernet1/12

!

interface FastEthernet1/13

!

interface FastEthernet1/14

!

interface FastEthernet1/15

!

interface Vlan1

no ip address

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

!

mgcp behavior g729-variants static-pt

!

!

!

!

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

login

!

!

end

I have attached all the 3 switches configuration thanks in advance for your help.

faisal


VIP Super Bronze

Portchannel Trouble

Can you add command:

switchport trunk encapsulation dot1q 

to the physical ports and Etherchannel interfaces?

New Member

Portchannel Trouble

yes I did

I add this command and its accepted but not showing on interface output.

New Member

Portchannel Trouble

Switch 3 Switchport status

NL_B1_SW3#sh interfaces port-channel 1 switchport

Name: Po1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: 1,64,66,69,71,1002-1005

Trunking VLANs Active: none

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

Switch 2 Switchport status

Name: Po1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: 1,64,66,69,71,1002-1005

Trunking VLANs Active: 1,64,66,69,71

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

Switch 1 Switchport Status

Name: Po1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: 1,64,66,68,69,71,1002-1005

Trunking VLANs Active: 1,64,66,68-69,71

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

may be you find some problem in this out put


VIP Super Bronze

Portchannel Trouble

For simplicity, can you try configuring the Etherchannel between just 2 switches and not 3

Also can you use LACP instead of on

So switch-1

channel-group 1 mode active

switch-2

channel-group 1 mode passive

If this does not work, can you create a new portchannel and apply the LACP config?

HTH

New Member

Portchannel Trouble

hi

its not giving me these options as I am running an IOS version on GNS3 . and I am doing practice lab directly watching the jeremey videos. but he didnot get any error and I got this interface bundled problem.

Bronze

Re: Portchannel Trouble

These commands will be helpful

show etherchannel 1 port-channel

show int Fa0/1

show int status err-disabled

New Member

Portchannel Trouble

I just tried to bundle the interfaces but its not bundled i dun know why. I am watching jeremy video and doing step by step work but I got this issue right now .

           Port-channels in the group:

                ----------------------

Port-channel: Po1

------------

Age of the Port-channel   = 00d:02h:28m:45s

Logical slot/port   = 8/0           Number of ports = 1

GC                  = 0x00010001      HotStandBy port = null

Port state          = Port-channel Ag-Inuse

Ports in the Port-channel:

Index   Port   EC state

------+------+------------

  0     Fa1/1    on

Time since last port bundled:    00d:01h:05m:35s    Fa1/1

Time since last port Un-bundled: 00d:01h:05m:35s    Fa1/1

Hall of Fame Super Gold

Portchannel Trouble

Remove the Po1 configuration of both Fa1/0 and Fa1/1.  Does the link go up? 

New Member

Portchannel Trouble

got the solution

actually configurations are right I have restart the switch thats why configuration doesnot take place

well thanks for guielines

I really appericiate all of your help

regards

faisal

921
Views
0
Helpful
11
Replies
CreatePlease to create content