Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Portchannels, Channelgroups and Vlans

Hello,

I have a 4948, which is new for us, and I want to create a vlan with two ports channel-grouped together to increase the bandwidth back to a 6506. I have two vlans on the 4948 and the second one is private with 12 ports added into it. The problem is once I create the channelgroup on the 4948 it doesn't belong to the Vlan1 anymore. I cannot add either the portchannel or the actual interfaces to access the vlan.

I know this is probably stupid but if anyone can help me I would appreciate it.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: Portchannels, Channelgroups and Vlans

You need to go into the port-channel interface and issue the command switchport, as well.

12 REPLIES
Hall of Fame Super Bronze

Re: Portchannels, Channelgroups and Vlans

Can we see the config ?

If seems like the port is changing from Layer2 mode to Layer3.

New Member

Re: Portchannels, Channelgroups and Vlans

Hello,

Here is the config...

Hall of Fame Super Blue

Re: Portchannels, Channelgroups and Vlans

William

Are you just trying to have a layer 2 etherchannel from your 4948 back to your core switch.

If so

interface GigabitEthernet1/1

no switchport

no ip address

speed 1000

duplex full

channel-group 1 mode auto

!

interface GigabitEthernet1/2

no switchport

no ip address

speed 1000

duplex full

channel-group 1 mode auto

You need to change each interface above to be a switchport

eg.

int gi1/1

switchport

int gi1/2

switchport

Once you've done this you should be able to allocate them into a vlan.

Also if you are using auto at this end make sure it is set to desirable or on at the other end or the channel won't form.

HTH

Jon

New Member

Re: Portchannels, Channelgroups and Vlans

Hello,

Thanks for your response...

The issue is now I'm back to my original issue. I cannot type channel-group on the interfaces in question after setting them to switchport. How do I channel-group the interface if I set it to switchport?

Hall of Fame Super Bronze

Re: Portchannels, Channelgroups and Vlans

Do you mean that you go into

config t [enter]

interface GigabitEthernet1/1 [enter]

you can't type

channel-group 1 mode on

?

New Member

Re: Portchannels, Channelgroups and Vlans

This is the message I get...

Command rejected (Port-channel1, Gi1/1): Either port is L2 and port-channel is L

3, or vice-versa

Hall of Fame Super Bronze

Re: Portchannels, Channelgroups and Vlans

You need to go into the port-channel interface and issue the command switchport, as well.

Hall of Fame Super Bronze

Re: Portchannels, Channelgroups and Vlans

As Jon stated, if you want to proceed with any Layer2 task such as Vlan membership, you need to change the port default behavior from Layer3 to Layer2 with the switchport command.

Currently, your ports are in Layer3 mode (default) and you are only allowed to enter IP address information.

New Member

Re: Portchannels, Channelgroups and Vlans

Hello,

If I understand you correctly you are saying that I am not able to group ports together for improved bandwidth and then add them to Vlans?

Hall of Fame Super Bronze

Re: Portchannels, Channelgroups and Vlans

Etherchanneling will provide bandwidth aggregation and you are doing the right thing. However, your initial query stated you want to assign Vlans on those ports, therefore you need to convert those ports from Layer3 ports to Layer2 ports.

The switchport command does that for you.

Cisco Employee

Re: Portchannels, Channelgroups and Vlans

William,

As stated by Edison, you can use the switchport command under the port-channel interface.You can also remove the interface port-channel that got created when you configured the ether-channel on the ports and when you configure the etherchannel on L2 ports it will also get added as l2 only.

Do this:

Config t

no interface port-channel

default interface gig 1/1

default interface gig 1/2

Then,

interface gig 1/1

switchport mode access

switchport access vlan 1

channel-group 1 mode on

interface gig 1/2

switchport mode access

switchport access vlan 1

channel-group 1 mode on

HTH,Please rate if it does.

-amit singh

New Member

Re: Portchannels, Channelgroups and Vlans

Hello,

I appreciate all the answers on this post...

I see where I have gone wrong and it is I didn't type switchport on the portchannel interface. When I do that I am able to channelgroup the ports as I hoped to.

Thanks for all the help :)

451
Views
5
Helpful
12
Replies
CreatePlease to create content