Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

portfast default / bpduguard default

Hello,

Issue 1).

I am applying the following command: "spanning-tree portfast default" in config mode and then when I check the running-config I don't see all ports in portfast as I understand they should be according to book...... is there any explanation to this? Is this IOS version related?

Issue 2).

I have some ports manually configured as portfast. Then I apply the command "spanning-tree porfast bpduguard defaul" but when I check the running-config I don't see those ports with the bpduguard as I understand they should be according to book...... any explanation?

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: portfast default / bpduguard default

Hey,

Switch(config)#spanning-tree portfast ?
  default  Enable portfast by default on all access ports

so that means, it enable portfast  but it will not write the spanning-tree portfast command for each interface into the running or startup config.

In your config, u have just 1 entry "spanning-tree portfast default" so all access ports are portfast.

Btw. Same with bpduguard

U can check, if its globally activated by "show spanning-tree summary"

Bye,

Patrick

5 REPLIES
New Member

Re: portfast default / bpduguard default

Hey,

Switch(config)#spanning-tree portfast ?
  default  Enable portfast by default on all access ports

so that means, it enable portfast  but it will not write the spanning-tree portfast command for each interface into the running or startup config.

In your config, u have just 1 entry "spanning-tree portfast default" so all access ports are portfast.

Btw. Same with bpduguard

U can check, if its globally activated by "show spanning-tree summary"

Bye,

Patrick

Cisco Employee

Re: portfast default / bpduguard default

Hi,

Issue 1).

I am applying the following command: "spanning-tree  portfast default" in config mode and then when I check the  running-config I don't see all ports in portfast as I understand they  should be according to book...... is there any explanation to this? Is  this IOS version related?

-  "spanning-tree  portfast default" command will enable portfast on all switchports in access mode. This will not be reflected in ruuning config. If you can check "show spanning-tree interface portfast" you can see that portfast is enabled.

- Same shud be applicable for Issue 2 as well. I dont remember the command to verify the same.

HTH,

Nagendra

Re: portfast default / bpduguard default

Sounds like you are expecting these commands to appear in each interface configuration section. If so, that is incorrect.

acc01#sh run | i default

spanning-tree portfast default
spanning-tree portfast bpduguard default

Note: Global configuration commands found in running config.


acc01#sh run int gi0/1

interface GigabitEthernet0/1
description
switchport access vlan
switchport mode access
switchport nonegotiate
switchport port-security
switchport port-security violation restrict
load-interval 60
no keepalive
no cdp enable
spanning-tree guard root
ip dhcp snooping limit rate 15
end

Note: Absence of interface configuration commands pertaining to portfast and bpduguard.


acc01#sh spanning-tree interface gi0/1 portfast


MST00            enabled
MST01            enabled

MST02            enabled

Note: Portfast enabled on each spanning tree instance, on this interface.

Note:Your output may look different than ours as we are using Multiple STP. You are likely using a different STP.

FYI: The ports will need to be configured for access mode.

E.g.:

interface GigabitEthernet0/1

switchport access vlan 100
switchport mode access

Best Regards,

Mike

Hall of Fame Super Silver

Re: portfast default / bpduguard default

Hello Mike,

very good post with show commands showing the facts

rated as it deserves (5P)

Best Regards

Giuseppe

Re: portfast default / bpduguard default

Giuseppe:

Thank you for the positive feedback, and your extensive forum support.

Best Regards,

Mike

2401
Views
12
Helpful
5
Replies
CreatePlease to create content