Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

possible routing/bridging issue - if not it's odd

I've got a strange problem. Here is the set up below:

6500 running OSPF and switching at site A

6500 running OSPF and switching at site B

3750 L3 switch running OSPF at site C

Router A and B have both an OSPF connection and a L2 trunk running between them (this is needed as there's lots of legacy stuff still running on common vlans). This seems to work fine and clients on site B are able to reach everything.

However, added new router C through OSPF to router B. Clients on Router B are then unable to reach anything on vlan X (a common vlan). Take the router C out of the equation and everything works again.

How can just adding a new network in to OSPF cause this? I would have thought if it's a routing/bridging conflict it would be happening all the time.

Any ideas?

5 REPLIES

Re: possible routing/bridging issue - if not it's odd

You may have a classfull boundry issue or a duplicate IP subnet.

Can you provide config/remove sensitive information.

Community Member

Re: possible routing/bridging issue - if not it's odd

Here is the router C config

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router C

!

boot-start-marker

boot-end-marker

!

logging buffered 16384

enable secret

enable password

!

username admin password

no aaa new-model

clock summer-time BST recurring last Sun Mar 2:00 last Sun Oct 2:00

switch 1 provision ws-c3750e-24pd

switch 2 provision ws-c3750e-24pd

system mtu routing 1500

vtp domain XXX

vtp mode transparent

udld aggressive

ip subnet-zero

no ip source-route

ip routing

no ip domain-lookup

ip domain-name

ip name-server x.x.x.x

ip name-server x.x.x.x

!

!

ip multicast-routing distributed

ip igmp ssm-map enable

no ip igmp ssm-map query dns

!

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos

!

crypto pki trustpoint TP-self-signed-3418629120

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3418629120

revocation-check none

rsakeypair TP-self-signed-3418629120

!

!

!

!

!

errdisable recovery cause udld

errdisable recovery cause link-flap

errdisable recovery interval 60

port-channel load-balance src-dst-ip

!

!

!

spanning-tree mode rapid-pvst

spanning-tree loopguard default

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

spanning-tree vlan 1-19 priority 4096

!

vlan internal allocation policy ascending

!

vlan 102

name X

!

vlan 103

name X

!

vlan 104

name X

!

vlan 105

name X

!

vlan 106

name X

!

vlan 107

name X

!

vlan 108

name X

!

vlan 109

name X

!

vlan 110

name X

!

vlan 111

name X

!

vlan 112

name X

!

vlan 113

name X

!

vlan 114

name X

!

vlan 115

name X

!

vlan 116

name X

!

vlan 117

name X

!

vlan 118

name X

!

vlan 119

name X

!

vlan 254

name X

!

ip ftp username

ip ftp password X

!

!

!

interface Loopback0

ip address x.x.x.x 255.255.255.255

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

!

interface Port-channel2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

!

interface Port-channel3

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

!

interface Port-channel4

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

!

interface Port-channel5

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

!

interface Port-channel6

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

!

interface Port-channel48

no switchport

ip address x.x.x.x 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-mode

ip ospf message-digest-key 2 md5

mls qos trust dscp

no shut

end

!

interface FastEthernet0

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

shutdown

!

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

channel-group 1 mode active

!

interface GigabitEthernet1/0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

channel-group 2 mode active

!

interface GigabitEthernet1/0/3

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

channel-group 3 mode active

!

interface GigabitEthernet1/0/4

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

channel-group 4 mode active

!

interface GigabitEthernet1/0/5

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

channel-group 5 mode active

!

interface GigabitEthernet1/0/6

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

channel-group 6 mode active

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

!

interface GigabitEthernet1/0/13

!

interface GigabitEthernet1/0/14

!

interface GigabitEthernet1/0/15

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet1/0/16

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet1/0/17

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet1/0/18

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet1/0/19

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet1/0/20

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

!

interface GigabitEthernet1/0/24

!

interface GigabitEthernet1/0/25

no switchport

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-mode

ip igmp version 3

ip ospf message-digest-key 1 md5

udld port aggressive

mls qos trust dscp

channel-group 110 mode on

!

interface GigabitEthernet1/0/26

shutdown

!

interface GigabitEthernet1/0/27

shutdown

!

interface GigabitEthernet1/0/28

shutdown

!

interface GigabitEthernet2/0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

channel-group 1 mode active

!

interface GigabitEthernet2/0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

channel-group 2 mode active

!

interface GigabitEthernet2/0/3

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

channel-group 3 mode active

!

interface GigabitEthernet2/0/4

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

channel-group 4 mode active

!

interface GigabitEthernet2/0/5

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

channel-group 5 mode active

!

interface GigabitEthernet2/0/6

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-19,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

channel-group 6 mode active

!

interface GigabitEthernet2/0/7

!

interface GigabitEthernet2/0/8

!

interface GigabitEthernet2/0/9

!

interface GigabitEthernet2/0/10

!

interface GigabitEthernet2/0/11

!

interface GigabitEthernet2/0/12

!

interface GigabitEthernet2/0/13

!

interface GigabitEthernet2/0/14

!

interface GigabitEthernet2/0/15

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet2/0/16

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet2/0/17

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet2/0/18

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet2/0/19

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet2/0/20

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet2/0/21

!

interface GigabitEthernet2/0/22

!

interface GigabitEthernet2/0/23

!

interface GigabitEthernet2/0/24

!

interface GigabitEthernet2/0/25

no switchport

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-mode

ip igmp version 3

ip ospf message-digest-key 1 md5

udld port aggressive

mls qos trust dscp

channel-group 110 mode on

!

interface GigabitEthernet2/0/26

shutdown

!

interface GigabitEthernet2/0/27

shutdown

!

interface GigabitEthernet2/0/28

shutdown

!

interface Vlan1

no ip address

shutdown

!

interface Vlan102

ip dhcp relay information trusted

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

!

interface Vlan103

ip dhcp relay information trusted

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

!

interface Vlan104

ip dhcp relay information trusted

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

!

interface Vlan105

ip dhcp relay information trusted

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

!

interface Vlan106

ip dhcp relay information trusted

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

!

interface Vlan107

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

!

interface Vlan108

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

!

interface Vlan109

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

!

interface Vlan110

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

ip igmp version 3

!

interface Vlan111

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

!

interface Vlan112

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

!

interface Vlan113

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

!

interface Vlan114

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip helper-address x.x.x.x

ip pim sparse-mode

!

interface Vlan115

no ip address

shutdown

!

interface Vlan116

no ip address

shutdown

!

interface Vlan117

no ip address

shutdown

!

interface Vlan118

no ip address

shutdown

!

interface Vlan254

ip address x.x.x.x 255.255.255.0

!

router ospf 100

log-adjacency-changes

area 0 authentication message-digest

redistribute connected

passive-interface default

no passive-interface GigabitEthernet1/0/25

no passive-interface GigabitEthernet2/0/25

no passive-interface port-channel48

network x.x.x.x 0.0.255.255 area 0

network x.x.x.x 0.0.0.3 area 0

!

ip classless

ip http server

ip http secure-server

ip pim ssm range 2

!

!

access-list 1 permit x.x.x.x

access-list 1 permit x.x.x.x

access-list 1 permit x.x.x.x

access-list 1 permit x.x.x.x

access-list 1 permit x.x.x.x 0.0.0.255

access-list 2 permit x.x.x.x 255.255.0.0

!

snmp-server community

snmp-server community

snmp-server community

snmp-server location

snmp-server contact

snmp-server system-shutdown

snmp-server enable traps vlancreate

snmp-server enable traps vlandelete

snmp-server enable traps flash insertion removal

snmp-server enable traps port-security

snmp-server enable traps envmon fan shutdown supply temperature status

snmp-server enable traps config-copy

snmp-server enable traps config

snmp-server enable traps hsrp

snmp-server enable traps bridge newroot topologychange

snmp-server enable traps stpx inconsistency root-inconsistency loop-inconsistency

snmp-server enable traps syslog

snmp-server enable traps mac-notification change move threshold

snmp-server enable traps vlan-membership

!

control-plane

!

banner login ^C******* ^C

!

line con 0

exec-timeout 0 0

login local

line vty 0 4

access-class 1 in

login local

length 0

transport input ssh

transport output none

line vty 5 15

Re: possible routing/bridging issue - if not it's odd

check VLAN/IP Subnet duplication/overlapps.

Blue

Re: possible routing/bridging issue - if not it's odd

I don't think there isn't too much that can be said until we see the pertinent device configurations, as well as the output of the OSPF neighbors command and perhaps the sh ip ospf command.

Victor

Community Member

Re: possible routing/bridging issue - if not it's odd

The OSPF forms an adjacency fine, with Full neighbour status. Router B is the DR, with router C the BDR, which is what we want.

We are using a basic OSPF config, so just the network statement and md5 encryption. Interestingly, the vlan it has issues with is a /16 common vlan. You can still access it from another vlan, it just knocks out access to that /16 vlan from router B when the OSPF forms the adjaceny.

215
Views
0
Helpful
5
Replies
CreatePlease to create content