Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Power loss causes Catalyst switch link notconnected

Hello all,

I am new as a Cisco admin and a recent CCNA. I have a perplexing problem. Recently we experienced a power loss in our switch core which consists of Catalyst 3550 switches. All links came up after power was restored except for two. One was a link to a Catalyst 2950 access switch and one was to a Catalyst 2900 access switch. Neither of these links came up. There is no link light and the status shows down, down (notconnect). I have checked the interfaces for any errors and there are none. The wiring is the same and has not been tampered with. There has been no damage to the wiring. The only change was a power loss to our switch core. Afterward the links to these 2 switches are down, down and will not come up.

Here is the really baffling part. I grabbed a HP Procurve switch and plugged the 2950 end of the link into it. I then plugged a patch cable into both the Procurve and the 2950. Viola! I got a link light on the 2950 and everything is velvet. I reversed the process and plugged the cable directly into the 2950 as it was originally and the results were the same as before. No link light; down, down(notconnect). I can only get the 2950 to connect if it is not plugged directly into the 3550 and instead is passed through the HP switch first. I have done all I know to do to troubleshoot this problem and am at a loss. From my training, the only reason I know of that a link could be down, down (notconnect) is if there is a layer 1 problem. Cable broken or damaged, simply not plugged in, a miss-wire...however, none of these are the issue.

Could someone please help this newbie out?

Very best regards.

Hall of Fame Super Silver

Re: Power loss causes Catalyst switch link notconnected

Hello Michael,

you are speaking of cables so I guess these are electrical ports RJ-45

what are the interface settings regarding speed and duplex, check if one side is in auto mode and the other has speed and duplex configured.

is the HP procurve port connecting to the same port on C3550 that you used before?

What if you swap the ports in the HP procurve?

one port can have been  damaged but this should lead to no link in all conditions.

Hope to help


New Member

Re: Power loss causes Catalyst switch link notconnected


Yes, my cables are Ethernet copper, Cat 5. Speed and duplex are auto on every port. The Procurve was connected to the 2950 end of the link and yes, on the 3550 the same port is used as before. However, while troubleshooting I did try a different port on both ends just to see if I could get a link that way. No dice. So I just plugged it into the same ports as before.

Here was my topology before:

3550 (Fa0/45)-->2950(Fa0/24)     No link (down, down).

Here is what it is now (and this is what it is currently):

3550(Fa0/45)-->HP Procurve-->2950(Fa0/24)     Link established (up, up).

The ports used for this link are exactly the same as they were originally for both the 3550 and the 2950. However, when plugged in directly, no link. When plugged in using the Procurve in between, the link comes alive on both ends.

Here is a little additional troubleshooting I did. In the access closet where the 2950 is located there is an old Cisco hub that was not even plugged in. I'm assuming that when the upgrade to the 2950 took place the engineer simply unplugged the hub and left it there out of laziness. I plugged the old hub back in and powered it up. I then did this: 3550(Fa0/45)-->Cisco Hub, no link light on either end. So I tried this: 3550(Fa0/45)-->HP Procurve-->Cisco Hub, link light on both Cisco devices. It seems that if a Cisco device is plugged in directly to the 3550, the link will not come up. However, if another vendor is used in the middle, the link will come up on the Cisco devices.

Any suggestions?

EDIT: This problem is solved. It turns out that some of the closets' patch panels were crosswired on the jack that is to be used for the switch-to-switch link while others were wired stright-thru. I hate to even admit that I could have missed this, but I did. What a lesson learned! I apologize for any inconvenience to anyone who may have worked to help me try to resolve this. Thank you, Giuseppe, for your response. Thank you, Rob, for bringing the obvious to my attention!