Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Prioritizing network traffic

Hi everyone,


Thank you for your help. I have some questions about network traffic shaping questions.


Currently, we have a Cisco router (28xx), ASA 5520, and a core switch 4500. We have different vlans. We also have Auto QoS running for our Cisco IP Phones.


My manager just asked me to see if I can either reserve some certain bandwidth for one vlan, or give that vlan higher priority on internet traffic than the others. So my questions are:

1.) Anyway we can reserve some more bandwidth for one vlan than other vlans?

2.) If #1 cannot be done, how can we provide higher priority on the internet traffic to one vlan than the others?

3.) Is #1 or #2 the same config? If not, which one would be easier (without changing our current QoS settings)?
4.) If 1 or 2 can be done, which device I should config the settings on?

5.) This question may be duplicate, but do we need to reset our current QoS to achieve the goal?

I may have more questions but basically those are all comes to my mind. Hope you can help!

Thank you very much for your help.

Takami

1 ACCEPTED SOLUTION

Accepted Solutions
Super Bronze

Prioritizing network traffic

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting


Depending your you device topology (Internet <> 2800 <> ASA <> 4500 ?), and what you really want to accomplish for one VLAN vs. the others, you might be able to (even easily) accomplish it for outbound (to Internet) traffic. Unfortunately, effectively/optimally controlling inbound (from Internet) bandwidth (on ingress) is quite difficult to impossible on ordinary routers and switches.

6 REPLIES
New Member

Prioritizing network traffic

Hi Bobson,

i think you need to configure Marking for the VOIP data as close as possibe to the IP phones, then giving them more priority through the LLQ. below two documets, the first one an overview of QOS, and the second how to configure LLQ.

http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfintro.html

http://www.cisco.com/en/US/docs/ios/12_0t/12_0t7/feature/guide/pqcbwfq.html

hopfully to help you

thanks,

Makar

New Member

Prioritizing network traffic

Hi Makar,

Thank you for your response! I really appreciate it. What do you mean "VOIP Data"? Or do you mean just data?

My goal is to provide higher priority of Internet access for one specific vlan...how do we approach this? That vlan in fact is for our police department.

Thank you again!

New Member

Prioritizing network traffic

Hi Bobson,

VOIP Data means Voice, fax, SMS , and/or voice-messaging applications used on some devices like IP Phones that are transported via the Internet, rather than the public switched telephone network  (PSTN).

when you try to give it more priority you can achieve that through LLQ because it gives the Voip data more priority with policing which it means it reserve the required bandwidth for VOIP data without starving or consuming the remaining bandwidth from the other types of netwok data lik HTTP, FTP, SMTP, etc...

so kindly go through those two documents and i think they will help you on how to configure it on your network.

rate plz

thanks

Makar

Prioritizing network traffic

Try this and let me know.

class-map match-any Voice-1
match  dscp ef

policy-map setclass
class Voice-1
  set ip precedence 5

class class-default
  fair-queue
  random-detect


------------------------------------


class-map match-any Voice-2
match ip precedence 5

policy-map mapclass

class Voice-2
   bandwidth percent 33

class class-default
  fair-queue
  random-detect

--------------------------------------
 

interface FastEthernet0/0
Description Your Inside interface
ip address xxx.xxx.xxx.xxx 255.255.255.0
service-policy in setclass

interface FastEthernet0/1
Description Your Outside interface
ip address xxx.xxx.xxx.xxx 255.255.255.252
service-policy output mapclass

Thanks

Rizwan Rafeek

Super Bronze

Prioritizing network traffic

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting


Depending your you device topology (Internet <> 2800 <> ASA <> 4500 ?), and what you really want to accomplish for one VLAN vs. the others, you might be able to (even easily) accomplish it for outbound (to Internet) traffic. Unfortunately, effectively/optimally controlling inbound (from Internet) bandwidth (on ingress) is quite difficult to impossible on ordinary routers and switches.

New Member

Prioritizing network traffic

Hi Everyone, thank you very much for all your help on this. I will definitely read the QoS link. But my concern here is more on one specific vlan traffic.

I really appreciate your help! I was sick for almost a week and thank you very much for all your kind responses!


Takami Chiro

2214
Views
0
Helpful
6
Replies
CreatePlease to create content