Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Priority-queue out does not work.

Hi,

I am marking Microsoft-DS SMB file sharing traffic with DSCP 46 and it supposed to be priorized over FTP traffic however each has 50% bandwith when files are being uploaded.

I would like to see that SMB is getting priorized.

Please give me suggestions what and how should i do!

The topology is the following:

QoS.png

Configs

3560:

mls qos

!

!

!

interface FastEthernet0/1

description TO_3550_A

switchport trunk encapsulation dot1q

switchport mode trunk

speed 10

duplex full

srr-queue bandwidth share 50 20 15 15

priority-queue out

mls qos trust cos

!

interface FastEthernet0/2

description TO_3550_B

switchport trunk encapsulation dot1q

switchport mode trunk

speed 10

duplex full

srr-queue bandwidth share 50 20 15 15

priority-queue out

mls qos trust cos

!

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6

10   PRIORITY_DATA                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1    enet  100001     1500  -      -      -        -    -        0      0

10   enet  100010     1500  -      -      -        -    -        0      0

3550_A_

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos

!

!

!

!

!

!

spanning-tree mode rapid-pvst

spanning-tree portfast default

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

class-map match-all DATA

match access-group 100

!

!

policy-map SET

class DATA

  set dscp ef

!

!

!

!

!

!

interface FastEthernet0/1

description TO_3560

switchport trunk encapsulation dot1q

switchport mode trunk

speed 10

duplex full

mls qos trust cos

priority-queue out

!

!

interface FastEthernet0/4

switchport access vlan 10

switchport mode access

service-policy input SET

!

access-list 100 permit tcp any any eq 445

access-list 100 permit tcp any eq 445 any

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/2, Fa0/3, Fa0/5, Fa0/6

10   PRIORITY_DATA                    active    Fa0/4

3550_B:

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos

!

!

!

!

!

!

spanning-tree mode rapid-pvst

spanning-tree portfast default

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

class-map match-all DATA

match access-group 100

!

!

policy-map SET

class DATA

  set ip dscp ef

!

!

!

!

!

interface FastEthernet0/2

description TO_3560

switchport trunk encapsulation dot1q

switchport mode trunk

speed 10

duplex full

mls qos trust cos

priority-queue out

!

interface FastEthernet0/3

switchport mode dynamic desirable

!

interface FastEthernet0/4

switchport access vlan 10

switchport mode access

service-policy input SET

!

access-list 100 permit tcp any any eq 445

access-list 100 permit tcp any eq 445 any

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/1, Fa0/3, Fa0/5, Fa0/6

10   PRIORITY_DATA                    active    Fa0/4

Br,

István

Everyone's tags (3)
524
Views
0
Helpful
0
Replies
CreatePlease to create content