Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Private Vlan Trunk between Cisco 3560 and IBM 1/10 G BNT Switch

Hi,

I have a IBM Blade chassis connected to my DMZ switch (Cisco 3560) in trunk mode.

Cisco Swith G0/17 ------- IBM Switch EXT 7

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------

The configuration of Cisco switch is as follows.

interface GigabitEthernet0/17

description NEWIBM-BLADE

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2-4094

switchport mode trunk

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------

IBM Switch Configuration is as follows

/c/l2/vlan 41/privlan

        type community

        ena

        map 100

/c/l2/vlan 100

        ena

        name "VLAN 100"

        def EXT7

/c/l2/vlan 100/privlan

        type primary

        ena /c/l2/vlan 41/privlan
        type community
        ena
        map 100
/c/l2/vlan 100
        ena
        name "VLAN 100"
        def EXT7
/c/l2/vlan 100/privlan
        type primary
        ena

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

/c/l2/trunk 1

        ena

        add EXT7 /c/l2/trunk 1
        ena
        add EXT7

Switch details

Switch   Ports Model             SW Version             SW Image      

------   ----- -----             ----------             ----------        

1   28     WS-C3560G-24TS     12.2(35)SE5             C3560-IPBASE-M    

My issue is I have an Guest OS running windows 2008 Server R2 in Blade/Server 5 of IBM Chasis and the Vlan 100 is tagged on Exsi level. Vlan 100 is my DMZ vlan. I can see the arp entries in the Cisco switch but communication is not happening. Am trying to ping from 10.11.30.154 to 10.11.30 254 (gateway)

sh arp

Protocol Address         Age (min) Hardware Addr   Type   Interface

Internet 10.11.30.154           10   0050.56bb.33f2 ARPA   Vlan100

I am having the same setup in another IBM Chasis which is working fine. The only difference is vlan 1 is also allowed in trunk . (G0/20 is connected to working IBM server)

Please help me in isolating the issue.

Thanks

3 REPLIES
VIP Super Bronze

Private Vlan Trunk between Cisco 3560 and IBM 1/10 G BNT Switch

Hi,

Under interface gi0/17, can you delete this command and test again?

You really don't need this command as you are allowing all vlans under this interface anyway.

switchport trunk allowed vlan 2-4094

HTH

New Member

Private Vlan Trunk between Cisco 3560 and IBM 1/10 G BNT Switch

Dear Reza

As I mentioned there is another Blade connected on G0/20 in trunk mode. So once I remove the

"switchport trunk allowed vlan 2-4094" command I am getting an VLAN 1 flapping between g0/17 and g0/20.

All the servers in that Blade is working fine.

Thanks

New Member

Private Vlan Trunk between Cisco 3560 and IBM 1/10 G BNT Switch

Hi,

The issue is solved ... Enabled PVID tagging on IBM Switch

Thanks

641
Views
0
Helpful
3
Replies
CreatePlease login to create content