Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Problem C3560 with IP-Phone avaya,Pls

Problem in C3560 with IP-Phone avaya,Pls

i want to ping form pc to ip phone avaya [1608 series] but cann't work

and this config on switch C3560

no aaa new-model

ip subnet-zero

ip routing

interface FastEthernet0/2

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport trunk allowed vlan 10,11

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport trunk allowed vlan 10,11

switchport mode trunk

spanning-tree portfast

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

description VLAN-DATA

ip address 155.14.231.2 255.255.255.0

!

interface Vlan11

description VLAN-VOICE

ip address 172.14.33.2 255.255.255.0

!

ip default-gateway 172.14.33.2

ip classless

no ip route static inter-vrf

ip http server

!

Result of ping

from c3560 can ping ip-phone and pc

from pc can ping g/w in c3560 and can ping any computer its connected with ip-phone(same vlan1) but cann't ping any ip-phone

from ip-phone can find tftp server (vlan2) and re-build config complete

then now ip phone its works can be use

and computer can be use lan access

and my problem is my computer(vlan1) its connect with ip-phone can not access in vlan 2 (it test with ping from pc to ipphone) because i must use server its in vlan 2 and next weeks must user softphone on pc i think pc must access in vlan 2 for get config of call manager avaya.

please advice for me.

I don't working in diffical network.

Result of ping

3 REPLIES

Re: Problem C3560 with IP-Phone avaya,Pls

The diagram and your explanation don't tie-up with the configuration you have posted. You mention VLAN's 1 & 2 in your explanation & diagram, however the config shows VLAN 10 & 11 and completely different IP networks.

The other thing is the switch configuration is wrong - there is no need to hard-code the ports as trunks (this was required with 3500XL series switches but that was a LONG time ago). You now just need an access port configuration:

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

switchport voice vlan 11

spanning-tree portfast

Please correct what you originally posted since it is obviously incorrect.

HTH

Andy

Hall of Fame Super Bronze

Re: Problem C3560 with IP-Phone avaya,Pls

Andy,

Your configuration is correct when dealing with Cisco VoIP, however on the few implementations I've been part of (and yes, they are quite recent), Avaya's Best Practice is to configure a dot1q trunk with the data vlan as native.

Their explanation is the phone originally boots in the data Vlan, obtains its information from the DHCP server, it boots again and obtain the information from the TFTP server, from the string supplied from the DHCP server, it then knows it belongs to another Vlan on that trunk (not a special voice vlan like with Cisco).

With Cisco VoIP, the whole process is simplified with CDP.

Re: Problem C3560 with IP-Phone avaya,Pls

This is exactly how Ericsson & Nortel do it (Nortel now support LLDP as well) however the configuration I posted works perfectly for both. Both Ericsson & Nortel request specific options from DHCP (Ericsson Option 43 and Nortel Option 128 & 144) and in the DHCP response they expect to receive a VLAN tag (amongth other things). When they have the VLAN tag they release the IP address from the access VLAN and then start again using the 802.1q they received from the DHCP server.

I have seen documentation from Nortel and this also shows the Cisco switchports configured as trunks, however this just isn't necessary any more.

Their explanation does not require a hard-coded trunk, however both configurations achieve exactly the same result - a 'psuedo' trunk that has a native (or access) VLAN and a single 802.1q tagged VLAN (Voice VLAN). The older 3500XL & 2900XL required the ports to be configured as trunks, everything since 2950's don't.

Andy

631
Views
0
Helpful
3
Replies
CreatePlease to create content