Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Problem configuring Multicasting across subnets

Having a real problem configuring this. 6509 core and 3560 edge switches. Can multicast over the same subnet but not between different subnets.

Multicast routing and igmp enable both on the core and edge switches

8 REPLIES
Cisco Employee

Re: Problem configuring Multicasting across subnets

To get multicast across vlans, you need to:

1) enable either pim sparse mode or pim dense mode across the vlans that source and receive the multicast. If you choose sparse then you need to designate an RP for the network.

2) make sure the multicast does not have a TTL=1 and that it is not using a well known multicast IP (not in the 224.0.0.0/24) range.

Perhaps you can explain the topology a little better and provide some configurations?

Community Member

Re: Problem configuring Multicasting across subnets

Thanks.

6509 core switch with 3560 edit switches

The core switch configuration pertaining to multicasting is:

ip multicast-routing

interface Loopback254

description Multicast RP address

ip address 10.10.0.254 255.255.255.255

ip pim sparse-mode

delay 1

interface Vlan527

description L3 PTP interface Munroe Test

ip address 10.37.0.1 255.255.255.252

no ip redirects

no ip unreachables

ip pim sparse-mode

The edge switch which have the PC's attached to has the following entries for multicasting

ip multicast-routing distributed

interface Vlan10

description ** Data **

bandwidth 100000

ip address 10.37.10.1 255.255.255.0

ip helper-address 192.168.52.45

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-mode

standby 10 priority 95

standby 10 preempt

standby 10 track GigabitEthernet0/1

I am not sure of the command to find what the TTL is set to thanks

Hall of Fame Super Silver

Re: Problem configuring Multicasting across subnets

Hello Gerry,

in pim sparse mode you need to specify the RP address

add to all L3 devices running PIM included core c6500

conf t

ip pim rp-address 10.10.0.254

this is the simplest way to do this with static mapping

Hope to help

Giuseppe

Community Member

Re: Problem configuring Multicasting across subnets

Thanks. I will try that. I'm assuming that I have to ad the ip pim rp-address as well to the core???

Cisco Employee

Re: Problem configuring Multicasting across subnets

A couple pieces are missing:

1. does vlan 10 on the core have the PIM command? or does vlan 527 on the edge have the PIM command? There needs to be a multicast enabled subnet to get the traffic from vlan 527 to vlan 10 if it is not enabled on the same switch.

2. do you have the 'ip pim rp-address ...' on both switches? What is the output of 'show ip pim rp map'

3. to find out the ttl you need to install wireshark somewhere local to the source and capture the multicast traffic, ttl should be in the ip header.

Community Member

Re: Problem configuring Multicasting across subnets

Both the VLAN and 527 have the pim command.

Output from show for the core is

PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static

RP: 10.10.0.254 (?)

Cisco Employee

Re: Problem configuring Multicasting across subnets

Ok if you have the commands:

'ip pim rp-address 10.10.0.254'

On both the 6500 and the 3560 you should be good.

Do you have the multicast group address you are trying to route?

what does 'show ip mroute ' give on the 6500?

You might want to open a TAC case for this, probably can solve this really quick over the phone.

Community Member

Re: Problem configuring Multicasting across subnets

Thanks..

As soon as I made the entry in the 3560 for the ip pim rp address we were able to multicast.

Thanks for all the input!

3220
Views
0
Helpful
8
Replies
CreatePlease to create content