cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
679
Views
20
Helpful
12
Replies

Problem to assing FE port to Vlan

roberto.londono
Level 1
Level 1

I have 3825 router with  twow  HWIC 4ESW  (8 port)  I want to assing it to vlan. My problem is 4 work very well however other 4 don't work.

I tried to create other vlan to see what happen same. Destination host unreachable.

Here is part my configuration.  Thanks for your help.

interface FastEthernet0/2/0

switchport access vlan 100

!

interface FastEthernet0/2/1

switchport access vlan 100

!

interface FastEthernet0/2/2

switchport access vlan 100

!

interface FastEthernet0/2/3

switchport access vlan 100

!

interface FastEthernet0/3/0

switchport access vlan 11

!

interface FastEthernet0/3/1

switchport access vlan 100

!

interface FastEthernet0/3/2

switchport access vlan 100

!

interface FastEthernet0/3/3

switchport access vlan 100

interface FastEthernet0/3/2

switchport access vlan 100

!

interface FastEthernet0/3/3

switchport access vlan 100

!

interface FastEthernet0/0/0

no ip address

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/0/0.100

encapsulation dot1Q 100

ip address 10.100.1.1 255.255.255.0

!

interface FastEthernet0/0/0.110

encapsulation dot1Q 110

ip address 10.210.1.1 255.255.255.0

!

interface Vlan11

ip address 10.110.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan100

ip address 10.0.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

12 Replies 12

roberto.londono
Level 1
Level 1

3825 I have  two  HWIC 4ESW . One slot 2 and other slow 3. When I tried to conect from card is locate at slot 2 I can ping and conect fine. When I tried to do same slot 3 it  give me error Destination host unreachable.

Yesterday I move card is locate slow slow 3 to slow 0. Now it work fine and card slow 2 doesn't work.  Other two slow I have two  HWIC 2 FE (4port L3 port).

I don't some have same problem or some hardware problem?

  Nothing wrong with the hardware, when using  2 hwics in the same chassis you must "stack" them together so they act as a single switch. Read the following doc.

http://www.cisco.com/en/US/partner/docs/ios/lanswitch/configuration/guide/lsw_hwic_ethsw_ic_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1051409


roberto.londono
Level 1
Level 1

Glen

Thanks for you answer

I am appreciation a lot it. The "stack" is very nice. I tried to open link you give me however it give me  errro

http://www.cisco.com/msgs/403.html it doesn’t found. I will try to look how stack it.

Roberto

Sorry , retry link in original post..

Glen

I think get link

http://www.cisco.com/en/US/docs/ios/lanswitch/configuration/guide/lsw_hwic_ethsw_ic_ps10591_TSD_Products_Configuration_Guide_Chapter.html#wp1049119


interface FastEthernet0/0/3
switchport stacking-partner interface FastEthernet0/2/3
!
interface FastEthernet0/2/3
  switchport stacking-partner interface FastEthernet0/0/3
!

I tested it however still continue with problem.

I read note say

Note Both stacking partner ports must have their speed and duplex parameters set to auto.


Corp(config-if)#speed auto
Corp(config-if)#duplex auto
Duplex will not be set until speed is set to non-auto value
Corp(config-if)#

I tried to stetup speed and duplex auto however it aren't posible. I test speed 100 duplex auto doesn't work.

Then version IOS is 15.0 M

thanks for your help.

Roberto

   Did you "no shut" the ports ?   What is the issue at this point ?   Auto speed is the default so just leave it as that , do not hardcode them.   Once you stack them  you also need to create the vlans in the vlan database .

router# vlan database

           vlan XX

           exit

Glen

Here is last show interface  I think it answer your question Did you "no shut" the ports ?

Corp#sh ip int br
Interface                  IP-Address      OK? Method Status                Pr
ocol
GigabitEthernet0/0         172.16.10.1     YES NVRAM  up                    up

GigabitEthernet0/1         172.16.11.1     YES NVRAM  up                    do

FastEthernet0/0/0          unassigned      YES unset  up                    up

FastEthernet0/0/1          unassigned      YES unset  up                    do

FastEthernet0/0/2          unassigned      YES unset  up                    do

FastEthernet0/0/3          unassigned      YES unset  up                    do

FastEthernet0/2/0          unassigned      YES unset  up                    do

FastEthernet0/2/1          unassigned      YES unset  up                    up

FastEthernet0/2/2          unassigned      YES unset  up                    do

FastEthernet0/2/3          unassigned      YES unset  up                    do

FastEthernet0/1/0          XX.XX.XX.XX    YES NVRAM  up                    up
FastEthernet0/1/1          10.1.1.1        YES NVRAM  up                    do

FastEthernet0/3/0          unassigned      YES NVRAM  up                    do

FastEthernet0/3/0.100      10.100.1.1      YES NVRAM  up                    do

FastEthernet0/3/1          192.168.1.1     YES NVRAM  up                    do

NVI0                       172.16.10.1     YES unset  up                    up

Vlan1                      unassigned      YES NVRAM  up                    do

Vlan10                     10.0.1.1        YES NVRAM  up                    up

Vlan100                    unassigned      YES NVRAM  up                    do

What is the issue at this point ?   It is still Destination host unreachable. in the card 0/0/0 is ok 0/2/0 still is same error.

I did Vlan database and also turn off and will continue do same problem.

Here is my copy and page it

Corp#vlan database
% Warning: It is recommended to configure VLAN from config mode,
  as VLAN database mode is being deprecated. Please consult user
  documentation for configuring VTP/VLAN in config mode.

Corp(vlan)#vlan 1
VLAN 1 modified:
Corp(vlan)#vlan 100
VLAN 100 added:
    Name: VLAN0100
Corp(vlan)#vlan 10
VLAN 10 modified:
Corp(vlan)#exit

interface FastEthernet0/0/0
switchport access vlan 10
!
interface FastEthernet0/0/1
switchport access vlan 10
!
interface FastEthernet0/0/2
switchport access vlan 10
!
interface FastEthernet0/0/3
switchport stacking-partner interface FastEthernet0/2/3
!
interface FastEthernet0/2/0
switchport access vlan 10
!
interface FastEthernet0/2/1
switchport access vlan 10
!
interface FastEthernet0/2/2
switchport access vlan 10
!
interface FastEthernet0/2/3
switchport stacking-partner interface FastEthernet0/0/3
!
interface FastEthernet0/1/0

interface Vlan10
ip address 10.0.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly

  Right off hand to me it looks good .  What does a "show int status"  show you ?  Do all the ports on both hwics show in vlaN 10 ?   What device do you have in the port that won't ping ?   Does it have a software firewall and is it turned off ?  does the device have the correct default gateway defined , 10.0.1.1 .   To test just hook up a laptop with a address in vlan 10 and the correct Df gateway  and turn off any windows firewalls and then see if you can reach the laptop .

Corp#sh  int status

Port    Name               Status       Vlan       Duplex Speed Type
Fa0/0/0                    connected    10         a-full   a-100 10/100BaseTX
Fa0/0/1                    notconnect   10           auto    auto 10/100BaseTX
Fa0/0/2                    connected    10         a-full   a-100 10/100BaseTX
Fa0/0/3                    notconnect   10           auto    auto 10/100BaseTX
Fa0/2/0                    notconnect   10           auto    auto 10/100BaseTX
Fa0/2/1                    notconnect   10           auto    auto 10/100BaseTX
Fa0/2/2                    notconnect   10           auto    auto 10/100BaseTX
Fa0/2/3                    notconnect   10           auto    auto 10/100BaseTX
Corp#

I locate lapto any 0/0/0 ... 2 working fing I can ping it.

I just move into 0/2/0..1.. 2.. and does n't no work. I don't change any configuration into lapto I leave for 10 min whint ping -t x x x x

   Do you have those stack ports tied together externally with a patch cable , those  ports show notconnect .  Those 2 ports must be tied togther and show connected with a patch cable.  Yes it does tie up a port on each card .

Per cisco doc:

Stacking is the connection of two Ethernet switch  HWICs resident in the same chassis so that they behave as a single  switch. Stacking is accomplished by daisy-chaining the two cards  together with an "external RJ-45 crossover cable"  that is connected to the  specified stacking port on each switch.

Glen

Now it is work.

Thanks for your patient in it.

God bless you. You help and I learn a lot in case.

Roberto Londono

  Glad to hear it's working ...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card