Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Problem with 2960S Console Port not responding

I am dealing with something I havent run into before.  I have a switch (a 2960 S) that has stopped responding to the console port.  I have tried several different USB to Serial adapters and they have the same problem.  I can take those same USB adapters and they work just fine on other devices using the same cable that I am using when having this problem on the 2960 S.  That would say that my baud rate and other settings are good.

I can connect to a different switch and the telnet/ssh to the other switch, so I am not dead in the water but I would rather be able to connect to the console port.  My initial instinct is to reboot the switch but I would rather avoid the downtime that this will cause.

Via the SSH session, I tried clear line console 0.  That didnt cause the port to wake up or start responding.

Is there some process that I can kill/restart on the switch ?  I tried doing a shut/no shut on the console port but that command isnt available for that port.

Ron

4 REPLIES
New Member

Problem with 2960S Console Port not responding

Is it currently stacked with another 2960's? I have an issue with two 2960's that are stacked and the console works on one, but not the other.

New Member

Problem with 2960S Console Port not responding

Unfortunately this is a standalone switch.  I am getting to it over the network from another switch.

I can SSH/Telnet to this 2960 from over the network as well.  Just not getting any response from the console port on the 2960.

Ron

Problem with 2960S Console Port not responding

Please change baud rate

Switch(config)#line console 0

Switch(config-line)#speed 9600

***Do Rate All Helpful Posts***

Jawad

Jawad
Hall of Fame Super Gold

Problem with 2960S Console Port not responding

Ron

If you have access to the switch then are you able to get the current running config and post it? There are some commands that can make the console unresponsive and I would like to see how the console is currently configured. For example I have seen situations where someone configured no exec on the console. They were thinking of it as an abbreviation for the command no exec-timeout. But it is not an abbreviation and is a command on its own - and it makes the console unresponsive.

Another thing that you can do would be to test sending output to the console. Connect to the console port with a PC, and from your telnet/ssh session make sure that console logging is enabled (preferably at the debug level) and then do something that will generate a log message (go into config t and then exit from config is a good way to generate some log output). If the output does appear on the PC connected to the console then we know that the physical connection is working and we look for what is impacting input from the console. If output is not received then that suggests that something like changing the speed of the console might be helpful.

HTH

Rick

835
Views
0
Helpful
4
Replies
CreatePlease to create content