Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Problem with channel bonding on the switch 2960G - Problem bei Kanalbündelung am Switch 2960G

(English Translation further down page)

Guten Tag allerseits,

ich habe ein Problem beim Umsetzen eines Testaufbaus mit 2 Server und einem Cisco Catalyst 2960G-24TC-L Switch, um Kanalbündelung (Bonding) zu testen.

Der Aufbau sieht wie folgt aus:

aufbau1.png

Das ganze sieht so aus, dass die 4 Verbindungen zwischen dem Switch und den Servern gebündelt sind zu einem Kanal mit einer Geschwindigkeit von 4Gbit (theoretisch).

Hier mal ein paar Sachen zur Konfiguration:

Nachfolgend werd ich einfach die Befehle mit den eventuell dazugehörigen Ausgaben reinstellen.

Switch

Enter configuration commands, one per line.  End with CNTL/Z.
Switch_C2(config)#interface range gigabitEthernet 0/1-4
Switch_C2(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1

Switch_C2(config-if-range)#exit
Switch_C2(config)#interface range gigabitEthernet 0/10-14
Switch_C2(config-if-range)#channel-group 2 mode on
Creating a port-channel interface Port-channel 2

Switch_C2(config-if-range)#exit
Switch_C2(config)#interface range port-channel 1-2
Switch_C2(config-if-range)#switchport mode access
Switch_C2(config-if-range)#switchport access vlan 2
% Access VLAN does not exist. Creating vlan 2
Switch_C2(config-if-range)#exit
Switch_C2(config)#no spanning-tree vlan 2
Switch_C2(config)#end

Switch_C2#show running-config
Building configuration...

Current configuration : 2363 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch_C2
!
enable secret 5 ########
enable password ########
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 1-2
!
vlan internal allocation policy ascending
!
interface Port-channel1
switchport access vlan 2
switchport mode access
!
interface Port-channel2
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet0/1
switchport access vlan 2
switchport mode access
channel-group 1 mode on
!
interface GigabitEthernet0/2
switchport access vlan 2
switchport mode access
channel-group 1 mode on
!
interface GigabitEthernet0/3
switchport access vlan 2
switchport mode access
channel-group 1 mode on
!
interface GigabitEthernet0/4
switchport access vlan 2
switchport mode access
channel-group 1 mode on
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
switchport access vlan 2
switchport mode access
channel-group 2 mode on
!
interface GigabitEthernet0/11
switchport access vlan 2
switchport mode access
channel-group 2 mode on
!
interface GigabitEthernet0/12
switchport access vlan 2
switchport mode access
channel-group 2 mode on
!
interface GigabitEthernet0/13
switchport access vlan 2
switchport mode access
channel-group 2 mode on
!
interface GigabitEthernet0/14
switchport access vlan 2
switchport mode access
channel-group 2 mode on
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface Vlan1
ip address 192.168.10.171 255.255.255.0
no ip route-cache
!
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
password ########
login
line vty 5 15
password ########
login
!
end

Server 1 und 2 sind identisch konfiguriert (bis auf die IP-Adressen natürlich), deswegen nur hier nur einmal die Konfiguration.

IP's:
Server 1 192.168.10.183
Server 1 192.168.10.180

Server
root@server:~# modprobe -v bonding mode=0 miimon=100
insmod /lib/modules/2.6.32-22-server/kernel/drivers/net/bonding/bonding.ko mode=0 miimon=100
root@server:~# ifconfig bond0 192.168.10.183/24
root@server:~# ifenslave bond0 eth6 eth7 eth8 eth9
root@server:~# cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v3.5.0 (November 4, 2008)

Bonding Mode: load balancing (round-robin)
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0

Slave Interface: eth6
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:26:55:d6:e6:25

Slave Interface: eth7
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:26:55:d6:e6:24

Slave Interface: eth8
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:26:55:d6:e6:27

Slave Interface: eth9
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:26:55:d6:e6:26

root@server:~# ifconfig bond0
bond0     Link encap:Ethernet  HWaddr 00:26:55:d6:e6:25
          inet addr:192.168.10.183  Bcast:192.168.10.255  Mask:255.255.255.0
          inet6 addr: fe80::226:55ff:fed6:e625/64 Scope:Link
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1
          RX packets:12682268 errors:0 dropped:0 overruns:0 frame:0
          TX packets:125820909 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:16910386606 (16.9 GB)  TX bytes:189359313578 (189.3 GB)

root@server:~# ifconfig eth6
eth6      Link encap:Ethernet  HWaddr 00:26:55:d6:e6:25
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:3168926 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32427000 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3905010958 (3.9 GB)  TX bytes:48768303033 (48.7 GB)
          Memory:fbde0000-fbe00000

root@server:~# ifconfig eth7
eth7      Link encap:Ethernet  HWaddr 00:26:55:d6:e6:25
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:2410573 errors:0 dropped:0 overruns:0 frame:0
          TX packets:35325322 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2676069126 (2.6 GB)  TX bytes:53162295566 (53.1 GB)
          Memory:fbce0000-fbd00000

root@server:~# ifconfig eth8
eth8      Link encap:Ethernet  HWaddr 00:26:55:d6:e6:25
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:3139995 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28841085 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4549694654 (4.5 GB)  TX bytes:43424812639 (43.4 GB)
          Memory:fbfe0000-fc000000

root@server:~# ifconfig eth9
eth9      Link encap:Ethernet  HWaddr 00:26:55:d6:e6:25
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:3962775 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29227502 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5779612210 (5.7 GB)  TX bytes:44003902340 (44.0 GB)
          Memory:fbee0000-fbf00000

Die Konfiguration funktionierte soweit auch ganz gut, dachte ich zumindest, bis es ans testen des Ganzen ging.

Die Tests hab ich mit netpef (Sender) bzw. netserver (Empfänger) gemacht.

Testverbindung1: Server<->Server

root@server:~# netperf -H 192.168.10.180 -t UDP_STREAM -f g -D 1 -l 5 -- -m 1472
UDP UNIDIRECTIONAL SEND TEST from 0.0.0.0 (0.0.0.0) port 0 AF_INET to 192.168.10.180 (192.168.10.180) port 0 AF_INET : demo
Interim result:    3.83 10^9bits/s over 1.20 seconds
Interim result:    3.82 10^9bits/s over 1.00 seconds
Interim result:    3.82 10^9bits/s over 1.00 seconds
Interim result:    3.82 10^9bits/s over 1.00 seconds
Socket       Message   Elapsed      Messages
Size          Size          Time           Okay       Errors   Throughput
bytes         bytes        secs            #                #      10^9bits/sec

1048576    1472          5.00            1625192      0      3.82                  <- Aussage Sender
1048576                     5.00            1625192              3.82                  <- Aussage  Empfänger

Ergebnis:

Der Sender hat 1.625.192 Pakete mit je 1472Byte Datenanteil in 5.00 Sekunden an dem Empfänger geschickt, wobei 0 Fehler aufgetreten sind und eine Datenrate von 3.82Gbit erreicht wurde (reine Nutzdaten, der Overhead belegt die restlichen 0.18Gbit).

Der Empfänger hat die 1.625.192 Pakete erhalten und dementsprechend mit der gleichen Menge geantwortet und kam ebenfalls eine Datenrate von 3.82 Gbit.

Also soweit schön und gewollt.

Testverbindung2: Server<->Switch<->Server

root@server:~# netperf -H 192.168.10.180 -t UDP_STREAM -f g -D 1 -l 5 -- -m 1472
UDP UNIDIRECTIONAL SEND TEST from 0.0.0.0 (0.0.0.0) port 0 AF_INET to 192.168.10.180 (192.168.10.180) port 0 AF_INET : demo
Interim result:    3.83 10^9bits/s over 1.07 seconds
Interim result:    3.83 10^9bits/s over 1.00 seconds
Interim result:    3.83 10^9bits/s over 1.00 seconds
Interim result:    3.75 10^9bits/s over 1.02 seconds
Socket      Message  Elapsed      Messages
Size         Size         Time           Okay       Errors   Throughput
bytes        bytes       secs            #                #      10^9bits/sec

1048576    1472        5.00            1619005      0       3.81
1048576                   5.00              406514               0.96

Wie zu erkenne ist funktioniert zwar das Senden an den Switch mit 3.8Gbit vom Server aus, aber am Ausgang des Switch kommt nur auf einem Port Daten zum Empfänger und dieser antwortet dementsprechend auch nur mit der Menge Pakete, wie er auch empfangen hat.

Auszug Webinterface Switch

1.PNG

2.PNG

Das was mich wundert/nervt ist die Tatsache, dass am Eingang des Switches 1.619.005 Pakete reingeschoben werden, aber Ausgang nur 406.514 Pakete zum Empfänger gelangen und dieser dementsprechend auch nur 406.514 Pakete zurückschickt.

Stellen sich nur die einfachen Fragen:

Wo sind die restliche 1.200.000 Pakete??

Warum gehen nicht am Ausgang alle Pakete auf den gebündelten Kanälen raus, wie sie am Eingang ankommen???

Was hab ich falsch gemacht/konfiguriert???

Ich hoffe ihr könnt mir helfen...

======================================================================================

[Google Translation to English]

Good day everyone,
 
I have a problem when  converting a test setup with two servers and a Cisco Catalyst  2960G-24TC-L switch for testing channel bonding (bonding).
 
The structure is as  follows:
Image: aufbau1.png  (https: / /  supportforums.cisco.com/servlet/JiveServlet/showImage/5940/aufbau1.png)
The whole looks like that  the 4 connections between the switch and the servers are bundled into  one channel at a speed of 4 Gbit (in theory).
 
Here are some things to  configure:
Below, I'll simply  commands with the reins out any associated expenses.
 
| | * Switch * | |
|
Enter configuration  commands, one per line. End with CNTL / Z.
Switch_C2 (config) #  interface range gigabit ethernet 0/1-4 Switch_C2 (config-if-range) #  channel-group 1 mode on Creating a port-channel interface Port-channel 1

Switch_C2  (config-if-range) # exit
Switch_C2 (config) #  interface range gigabit Ethernet 0/10-14 Switch_C2 (config-if-range) #  channel-group 2 mode on Creating a port-channel interface Port-channel 2

Switch_C2  (config-if-range) # exit
Switch_C2 (config) #  interface range port-channel 1-2 Switch_C2 (config-if-range) #  switchport mode access Switch_C2 (config-if-range) # switchport access  vlan 2% Access VLAN does not exist. Creating vlan 2 Switch_C2  (config-if-range) # exit Switch_C2 (config) # no span Switch_C2  (config) # no spanning-tree vlan 2 Switch_C2 (config) # end Switch_C2 #  show running-config Building configuration ...

Current configuration:  2363 bytes
!
version 12.2
no service pad
service timestamps debug  datetime msec
service timestamps log  datetime msec
no service  password-encryption
!
hostname Switch_C2
!
enable secret 5 ########
enable password ########
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
no file verify auto
!
spanning-tree mode PVST
spanning-tree extend  system-id
no spanning-tree vlan 1-2
!
vlan internal allocation  policy ascending!
interface Port-channel1
switchport access vlan 2
switchport mode access
!
interface Port-channel2
switchport access vlan 2
switchport mode access
!
interface  GigabitEthernet0 / 1
switchport access vlan 2
switchport mode access
channel-group 1 mode on
!
interface  GigabitEthernet0 / 2
switchport access vlan 2
switchport mode access
channel-group 1 mode on
!
interface  GigabitEthernet0 / 3
switchport access vlan 2
switchport mode access
channel-group 1 mode on
!
interface  GigabitEthernet0 / 4
switchport access vlan 2
switchport mode access
channel-group 1 mode on
!
interface  GigabitEthernet0 / 5
!
interface  GigabitEthernet0 / 6
!
interface  GigabitEthernet0 / 7
!
interface  GigabitEthernet0 / 8
!
interface  GigabitEthernet0 / 9
!
interface  GigabitEthernet0/10
switchport access vlan 2
switchport mode access
channel-group 2 mode on
!
interface  GigabitEthernet0/11
switchport access vlan 2
switchport mode access
channel-group 2 mode on
!
interface  GigabitEthernet0/12
switchport access vlan 2
switchport mode access
channel-group 2 mode on
!
interface  GigabitEthernet0/13
switchport access vlan 2
switchport mode access
channel-group 2 mode on
!
interface  GigabitEthernet0/14
switchport access vlan 2
switchport mode access
channel-group 2 mode on
!
interface  GigabitEthernet0/15
!
interface  GigabitEthernet0/16
!
interface  GigabitEthernet0/17
!
interface  GigabitEthernet0/18
!
interface  GigabitEthernet0/19
!
interface  GigabitEthernet0/20
!
interface  GigabitEthernet0/21
!
interface  GigabitEthernet0/22
!
interface  GigabitEthernet0/23
!
interface  GigabitEthernet0/24
!
interface Vlan1
ip address 192.168.10.171  255.255.255.0 no ip route-cache!
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
password ########
login
line vty 5 15
password ########
login
!
end |
| |
 
Server 1 and 2 have the  same configuration (except the IP addresses of course), so only here  once the configuration.
IP's:
Server 1 192.168.10.183
Server 1 192.168.10.180
| | * Server
* | |
| Root @ server: ~ #  modprobe-v bonding mode = 0 miimon = 100
insmod /  lib/modules/2.6.32-22-server/kernel/drivers/net/bonding/bonding.ko mode =  0 miimon = 100 root @ server: ~ # ifconfig bond0 192.168.10.183/24 root  @ server: ~ # ifenslave bond0 eth6 eth7  eth8 eth9 root @ server: ~ # cat / proc/net/bonding/bond0 Ethernet  Channel Bonding Driver: v3.5.0 (November 4, 2008)

Bonding Mode: load  balancing (round-robin) MII Status: up MII Polling Interval (ms): 100 Up  Delay (ms): 0 Down Delay (ms): 0

Slave Interface: eth6
MII Status: up
Link Failure Count: 0
Permanent HW addr:  00:26:55: d6: e6: 25

Slave Interface: eth7
MII Status: up
Link Failure Count: 0
Permanent HW addr:  00:26:55: d6: e6: 24

Slave Interface: eth8
MII Status: up
Link Failure Count: 0
Permanent HW addr:  00:26:55: d6: e6: 27

Slave Interface: eth9
MII Status: up
Link Failure Count: 0
Permanent HW addr:  00:26:55: d6: e6: 26

root @ server: ~ #  ifconfig bond0
bond0 Link encap:  ethernet HWaddr 00:26:55: d6: e6: 25
         
inet addr: 192.168.10.183  Bcast: 192.168.10.255 Mask: 255.255.255.0
         
inet6 addr: fe80:: 226:55  ff: FED6: e625/64 Scope: Link
         
UP BROADCAST RUNNING  MASTER MULTICAST MTU: 1500 Metric: 1
         
RX packets: 12682268  errors: 0 dropped: 0 overruns: 0 frame: 0
         
TX packets: 125820909  errors: 0 dropped: 0 overruns: 0 carrier: 0
         
collisions txqueuelen: 0:  0
         
RX bytes: 16910386606  (16.9 GB) TX bytes: 189 359 313 578 (189.3 GB)

root @ server: ~ #  ifconfig eth6
eth6 Link encap: Ethernet  HWaddr 00:26:55: d6: e6: 25
         
UP BROADCAST RUNNING  SLAVE MULTICAST MTU: 1500 Metric: 1
         
RX packets: 3168926  errors: 0 dropped: 0 overruns: 0 frame: 0
         
TX packets: 32427000  errors: 0 dropped: 0 overruns: 0 carrier: 0
         
collisions txqueuelen: 0:  1000
         
RX bytes: 3905010958 (3.9  GB) TX bytes: 48,768,303,033 (48.7 GB)
         
Memory: fbde0000-fbe00000

root @ server: ~ #  ifconfig eth7
eth7 Link encap: Ethernet  HWaddr 00:26:55: d6: e6: 25
         
UP BROADCAST RUNNING  SLAVE MULTICAST MTU: 1500 Metric: 1
         
RX packets: 2410573  errors: 0 dropped: 0 overruns: 0 frame: 0
         
TX packets: 35325322  errors: 0 dropped: 0 overruns: 0 carrier: 0
         
collisions txqueuelen: 0:  1000
         
RX bytes: 2676069126 (2.6  GB) TX bytes: 53,162,295,566 (53.1 GB)
         
Memory: fbce0000-fbd00000

root @ server: ~ #  ifconfig eth8
eth8 Link encap: Ethernet  HWaddr 00:26:55: d6: e6: 25
         
UP BROADCAST RUNNING  SLAVE MULTICAST MTU: 1500 Metric: 1
         
RX packets: 3139995  errors: 0 dropped: 0 overruns: 0 frame: 0
         
TX packets: 28841085  errors: 0 dropped: 0 overruns: 0 carrier: 0
         
collisions txqueuelen: 0:  1000
         
RX bytes: 4549694654 (4.5  GB) TX bytes: 43,424,812,639 (43.4 GB)
         
Memory: fbfe0000-fc000000

root @ server: ~ #  ifconfig eth9
eth9 Link encap: Ethernet  HWaddr 00:26:55: d6: e6: 25
         
UP BROADCAST RUNNING  SLAVE MULTICAST MTU: 1500 Metric: 1
         
RX packets: 3962775  errors: 0 dropped: 0 overruns: 0 frame: 0
         
TX packets: 29227502  errors: 0 dropped: 0 overruns: 0 carrier: 0
         
collisions txqueuelen: 0:  1000
         
RX bytes: 5779612210 (5.7  GB) TX bytes: 44,003,902,340 (44.0 GB)
         
Memory: fbee0000-fbf00000  |
 
The configuration worked  quite well so far, I thought, at least until it went to the test of the  whole.
The tests I did with  netpef (transmitter) or netserver (receiver) made.
 
The principle is
 
* Testverbindung1: Server  <-> Server *
 
avhe64 root @: ~ #  netperf-H 192.168.10.180-t UDP_STREAM-fg-D 1-l 5 --m 1472 UDP  unidirectional SEND TEST from 0.0.0.0 (0.0.0.0) port 0 AF_INET to  192.168.10.180 (192.168 .10.180) port 0 AF_INET:  demo Interim result: 3.83 10 ^ 9-bit / s over 1:20 seconds Interim  result: 3.82 10 ^ 9-bit / s over 1.00 seconds Interim result: 3.82 10 ^  9-bit / s over 1.00 seconds Interim result: 3.82 10 ^ 9-bit / s over 1.00  seconds Socket Message Elapsed Messages Size Size Time Okay Errors  Throughput bytes bytes secs # # 10 ^ 9bits/sec
 
1048576 1472 1625192 0  3.82 5:00 <- message sender
1048576 1625192 3.82 5:00  <- message recipient
 
 
 
Results:
The sender has sent  1,625,192 packets, each with 1472Byte share data in 5.00 seconds at the  receiver, 0 errors, and a data rate of 3.82Gbit was achieved (pure  payload, the overhead of the remaining occupied 0.18Gbit).
The receiver has received  1,625,192 packages, and responded accordingly with the same amount and  was also a data rate of 3.82 Gbps.
 
So far as beautiful and  wanted.
 
* Testverbindung2: Server  <-> Switch <-> Server *
 
root @ server: ~ #  netperf-H 192.168.10.180-t UDP_STREAM-fg-D 1-l 5 --m 1472 UDP  unidirectional SEND TEST from 0.0.0.0 (0.0.0.0) port 0 AF_INET to  192.168.10.180 (192.168 .10.180) port 0 AF_INET:  demo Interim result: 3.83 10 ^ 9-bit / s over 1:07 seconds Interim  result: 3.83 10 ^ 9-bit / s over 1.00 seconds Interim result: 3.83 10 ^  9-bit / s over 1.00 seconds Interim result: 3.75 10 ^ 9-bit / s over 1:02  seconds Socket Message Elapsed Messages Size Size Time Okay Errors  Throughput bytes bytes secs # # 10 ^ 9bits/sec
 
1048576 1472 5.00 1619005  0 3.81
1048576 406 514 0.96 5:00
 
How to recognize,  although sending works to the switch with 3.8Gbit from the server, but  the result of the switch is on only one data port to the receiver and it  responds accordingly with the amount of packets, as he has received.
 
+ Extract + Switch Web  Interface
 
Image: 1.PNG (https: / /  supportforums.cisco.com/servlet/JiveServlet/showImage/5941/1.PNG)
Image: 2.png (https: / /  supportforums.cisco.com/servlet/JiveServlet/showImage/5942/2.PNG)
 
What surprises me /  annoying is the fact that be to breath at the entrance of the switch  1619005 packets, but only 406 514 packets to reach out and returned by  the recipient accordingly only 406 514 packages.
 
Imagine only the simple  questions:
Where the remaining 1.2  million packages?
Why not go out on all the  packages out on the combined channels, as they arrive at the entrance??
What have I done wrong /  configured??
 
I hope you can help me  ...

Message was translated to English using Google Translation and edited by:   Cindy Toy, Cisco Small Business Community Manager    Note - This question is not a related to a Cisco Small Business Switch and was therefore moved and translated from the Small Business German area to LAN, Switching, and Routing

1080
Views
0
Helpful
0
Replies
CreatePlease to create content